Bug 136024 - Maelstrom Locks up when audio CD is being played
Maelstrom Locks up when audio CD is being played
Status: CLOSED DUPLICATE of bug 143036
Product: Fedora
Classification: Fedora
Component: Maelstrom (Show other bugs)
rawhide
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Karsten Hopp
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-10-16 17:15 EDT by Mike
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 14:06:22 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
strace of game session starting and trying to quit (559.45 KB, text/plain)
2004-10-16 17:19 EDT, Mike
no flags Details

  None (edit)
Description Mike 2004-10-16 17:15:27 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.3)
Gecko/20041012

Description of problem:
If you start Maelstrom while a audio CD is being played the game will
lock up when you try to exit.  You have to resort to killing the process. 

I'll attach and strace. The following was shown on the console:

# strace -oMaelstrom.log Maelstrom
ALSA lib pcm_hw.c:1155:(snd_pcm_hw_open) open /dev/snd/pcmC0D0p
failed: Device or resource busy
SDL: Audio timeout - buggy audio driver? (disabled)
audio: Bad file descriptor


Version-Release number of selected component (if applicable):
Maelstrom-3.0.6-6

How reproducible:
Always

Steps to Reproduce:
1.Start Maelstrom while playing audio CD
2.Exit Maelstrom
3.
    

Actual Results:  Maelstrom locked up.

Expected Results:  Maelstrom should have exited

Additional info:
Comment 1 Mike 2004-10-16 17:19:05 EDT
Created attachment 105329 [details]
strace of game session starting and trying to quit
Comment 2 Karsten Hopp 2005-01-26 10:06:42 EST
That's another incarnation of bug 143036

*** This bug has been marked as a duplicate of 143036 ***
Comment 3 Red Hat Bugzilla 2006-02-21 14:06:22 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.