Bug 143036 - Maelstrom locks up after first stage.
Maelstrom locks up after first stage.
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: Maelstrom (Show other bugs)
3
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Karsten Hopp
:
: 136024 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-12-15 16:39 EST by Joel Hedlund
Modified: 2007-11-30 17:10 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-08-01 10:28:32 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
gzipped output maelstrom.txt.gz of "strace -f Maelstrom" (32.53 KB, text/plain)
2005-01-19 14:13 EST, Andre Robatino
no flags Details

  None (edit)
Description Joel Hedlund 2004-12-15 16:39:20 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.5)
Gecko/20041111 Firefox/1.0

Description of problem:
After i finish the first stage and the points have been counted it
locks up and nothing more happens. I can't even close down the
program. The last times I tried, I can't even open up the program...

Version-Release number of selected component (if applicable):
Maelstrom-3.0.6-6

How reproducible:
Always

Steps to Reproduce:
1. Start the game
2. Finish the first stage
3. Wait...
    

Actual Results:  The game locked up, as described above.

Expected Results:  You should get to the second stage.

Additional info:
Comment 1 Andre Robatino 2004-12-17 18:55:10 EST
  I have a similar problem except that for me it locks up after about
10 seconds, before even starting the game.  If I run Maelstrom from
the command line, I get the message

[andre@localhost ~]$ Maelstrom
SDL: Audio timeout - buggy audio driver? (disabled)
audio: Bad file descriptor

and to kill it it's necessary to do a kill -9 (SIGINT or SIGTERM don't
work).  At this point, the esd daemon is still running, so you have to
use "killall esd" to kill it before running Maelstrom, otherwise you
get the error message

[andre@localhost ~]$ Maelstrom
Couldn't create bound network socket

(see bug #122594, though in this case the fact that esd is still
running is understandable).  At this point, I can run Maelstrom again.
 For some reason the sound is now scratchy, but Maelstrom doesn't hang
anymore.
Comment 2 Karsten Hopp 2005-01-17 10:46:09 EST
Do you have any other programs running which may be using the sound
devices ? 
I've tried to reproduce this without any success so far.
Comment 3 Joel Hedlund 2005-01-18 05:01:49 EST
Well, actually my soundcard doesn't work at all... I don't know if
that could be part of the reason?
Comment 4 Karsten Hopp 2005-01-19 06:50:17 EST
yes, that may be the problem. Unfortunately there's no commandline
switch to turn off sounds in Maelstrom. 
Comment 5 Andre Robatino 2005-01-19 12:13:16 EST
  I have two different machines, both with sound working, where this
problem occurs.  Unfortunately I haven't run Maelstrom for the last
few weeks, and when I try it now, I'm not getting the SDL timeout
message, though the freezeup still happens (and the scratchy sound
when starting it for the second time).  There may have been updates
resulting in a change of behavior.  I'll try running it over the next
few days to establish  typical behavior.
  Also, I tried running it with strace, as follows:

strace -f -o maelstrom.txt Maelstrom

  Is this the correct invocation, and would the output be helpful?
Comment 6 Andre Robatino 2005-01-19 14:13:43 EST
Created attachment 109982 [details]
gzipped output maelstrom.txt.gz of "strace -f Maelstrom"
Comment 7 Andre Robatino 2005-01-19 14:16:53 EST
  The above attachment contains the "SDL: Audio timeout" error message.
Comment 8 Andre Robatino 2005-01-19 16:02:19 EST
  Ignore my earlier comment about the behavior having changed.  It's
behaving the same as always.
Comment 9 Karsten Hopp 2005-01-26 10:06:44 EST
*** Bug 136024 has been marked as a duplicate of this bug. ***
Comment 10 Karsten Hopp 2005-08-01 10:28:32 EDT
sorry, I don't have enough time to track this down. As this package isn't
included anymore in newer releases, I'll close this bugreport as WONTFIX instead
of having it as NEW forever.

Note You need to log in before you can comment on or make changes to this bug.