Bug 1360589 - recipe should be marked as reviewed if it finishes while the user has the recipe page open
Summary: recipe should be marked as reviewed if it finishes while the user has the rec...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Beaker
Classification: Community
Component: web UI
Version: 23
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified vote
Target Milestone: 24.4
Assignee: Anwesha Chatterjee
QA Contact: Dan Callaghan
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-07-27 06:26 UTC by Dan Callaghan
Modified: 2017-10-03 03:57 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-10-03 03:57:42 UTC


Attachments (Terms of Use)

Description Dan Callaghan 2016-07-27 06:26:15 UTC
Beaker tracks "reviewed" state for each recipe: there's a check box on the job page, plus we automatically consider a recipe to be reviewed whenever the recipe page is displayed.

However if the recipe is not complete yet, then it shouldn't be automatically marked as reviewed when the page is displayed (because not all the results are there yet, so by definition the user can't have fully reviewed it). 

There is an interesting edge case which is: what if the recipe finishes while the page is open? The page re-fetches the recipe data every 30 seconds so if the page is already open and the recipe finishes the user will see the complete results, which means they could have reviewed it. The page should probably mark the recipe as reviewed at that point.

Comment 1 Dan Callaghan 2017-07-17 09:33:30 UTC
(In reply to Dan Callaghan from comment #0)
> However if the recipe is not complete yet, then it shouldn't be
> automatically marked as reviewed when the page is displayed (because not all
> the results are there yet, so by definition the user can't have fully
> reviewed it). 

So this part is basically a dupe of bug 1376645, which I seem to have filed and then fixed forgetting that this one was still here. However, the patch for bug 1376645 did not take into account this edge case:

> There is an interesting edge case which is: what if the recipe finishes
> while the page is open? The page re-fetches the recipe data every 30 seconds
> so if the page is already open and the recipe finishes the user will see the
> complete results, which means they could have reviewed it. The page should
> probably mark the recipe as reviewed at that point.

so it would be good to get that fixed too. Let's make this bug about this edge case.

Comment 2 Anwesha Chatterjee 2017-07-18 06:09:03 UTC
https://gerrit.beaker-project.org/#/c/5752/

Comment 5 Dan Callaghan 2017-10-03 03:57:42 UTC
Beaker 24.4 has been released.


Note You need to log in before you can comment on or make changes to this bug.