Bug 1360693 - [RFE] Add a count of snapshots associated with a volume to the output of the vol info command
Summary: [RFE] Add a count of snapshots associated with a volume to the output of the ...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: snapshot
Version: mainline
Hardware: x86_64
OS: Linux
low
low
Target Milestone: ---
Assignee: Avra Sengupta
QA Contact:
URL:
Whiteboard:
Depends On: 1129468
Blocks: 1369326 1369328
TreeView+ depends on / blocked
 
Reported: 2016-07-27 10:58 UTC by Avra Sengupta
Modified: 2017-03-27 18:19 UTC (History)
4 users (show)

Fixed In Version: glusterfs-3.9.0
Doc Type: Enhancement
Doc Text:
Clone Of: 1129468
: 1369326 1369328 (view as bug list)
Environment:
Last Closed: 2017-03-27 18:19:27 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Comment 1 Vijay Bellur 2016-07-27 11:04:54 UTC
REVIEW: http://review.gluster.org/15029 (snapshot: Display number of snapshots in volume info) posted (#1) for review on master by Avra Sengupta (asengupt@redhat.com)

Comment 2 Vijay Bellur 2016-07-28 06:28:37 UTC
REVIEW: http://review.gluster.org/15029 (snapshot: Display number of snapshots in volume info) posted (#2) for review on master by Avra Sengupta (asengupt@redhat.com)

Comment 3 Vijay Bellur 2016-08-02 06:08:15 UTC
REVIEW: http://review.gluster.org/15029 (snapshot: Display number of snapshots in volume info) posted (#3) for review on master by Avra Sengupta (asengupt@redhat.com)

Comment 4 Vijay Bellur 2016-08-18 06:53:01 UTC
REVIEW: http://review.gluster.org/15029 (snapshot: Display number of snapshots in volume info) posted (#4) for review on master by Avra Sengupta (asengupt@redhat.com)

Comment 5 Vijay Bellur 2016-08-18 06:53:53 UTC
REVIEW: http://review.gluster.org/15029 (snapshot: Display number of snapshots in volume info) posted (#5) for review on master by Avra Sengupta (asengupt@redhat.com)

Comment 6 Worker Ant 2016-08-23 07:06:33 UTC
COMMIT: http://review.gluster.org/15029 committed in master by Rajesh Joseph (rjoseph@redhat.com) 
------
commit 1df4a89de17e44c8c1f9b4794a7b8c2741f2bc2e
Author: Avra Sengupta <asengupt@redhat.com>
Date:   Wed Jul 27 16:28:44 2016 +0530

    snapshot: Display number of snapshots in volume info
    
    Display number of snapshots in a volume in volume info
    output. This number gets modified, with create, delete,
    and restore operations.
    
    Change-Id: Ic9b7c2b6950980f8ce75ca362998c097ea7c863d
    BUG: 1360693
    Signed-off-by: Avra Sengupta <asengupt@redhat.com>
    Reviewed-on: http://review.gluster.org/15029
    Smoke: Gluster Build System <jenkins@build.gluster.org>
    NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
    CentOS-regression: Gluster Build System <jenkins@build.gluster.org>
    Reviewed-by: Rajesh Joseph <rjoseph@redhat.com>

Comment 7 Shyamsundar 2017-03-27 18:19:27 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.9.0, please open a new bug report.

glusterfs-3.9.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://lists.gluster.org/pipermail/gluster-users/2016-November/029281.html
[2] https://www.gluster.org/pipermail/gluster-users/


Note You need to log in before you can comment on or make changes to this bug.