Bug 1129468 - [RFE] Add a count of snapshots associated with a volume to the output of the vol info command
Summary: [RFE] Add a count of snapshots associated with a volume to the output of the ...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: snapshot
Version: rhgs-3.0
Hardware: x86_64
OS: Linux
low
low
Target Milestone: ---
: RHGS 3.3.0
Assignee: Avra Sengupta
QA Contact: Anil Shah
URL:
Whiteboard:
Depends On:
Blocks: 1360693 1369326 1369328 1417138
TreeView+ depends on / blocked
 
Reported: 2014-08-12 20:17 UTC by Paul Cuzner
Modified: 2017-09-21 04:53 UTC (History)
6 users (show)

Fixed In Version: glusterfs-3.8.4-19
Doc Type: Enhancement
Doc Text:
Clone Of:
: 1360693 (view as bug list)
Environment:
Last Closed: 2017-09-21 04:25:52 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2017:2774 normal SHIPPED_LIVE glusterfs bug fix and enhancement update 2017-09-21 08:16:29 UTC

Description Paul Cuzner 2014-08-12 20:17:12 UTC
Description of problem:

Feature Request to add an indication of the snapshots available to a volume when querying a volume with the vol info command. At the moment an admin looking at a volume has to use two commands to even know whether the volume has snapshots. By introducing a "Snapshots Count"field to the output of the vol info command, the admin gets improved insight into the volume from a single command. 


Version-Release number of selected component (if applicable):


How reproducible:
N/A

Steps to Reproduce:
1.
2.
3.

Actual results:
vol info currently provided no insight into a volumes snapshots at all

Expected results:
vol info should provide a high level indication of the presence of snapshots for a given volume.


Additional info:

Comment 2 Avra Sengupta 2016-10-20 09:32:49 UTC
Patch posted upstream master : http://review.gluster.org/15029

Comment 4 Atin Mukherjee 2017-03-06 08:52:08 UTC
This patch is already in rhg-3.2.0.

Comment 7 Anil Shah 2017-04-24 06:50:45 UTC
[root@rhs-arch-srv1 core]# gluster snapshot list vol0  | wc -l
256
[root@rhs-arch-srv1 core]# gluster v info vol0
 
Volume Name: vol0
Type: Distributed-Replicate
Volume ID: ad14ae5e-df3a-4e2b-ad3e-5ea263441484
Status: Started
Snapshot Count: 256
Number of Bricks: 4 x 3 = 12

Done basic sanity test for the RFE and looks ok.
Bug verified on build glusterfs-3.8.4-23.el7rhgs.x86_64

Comment 9 errata-xmlrpc 2017-09-21 04:25:52 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2017:2774

Comment 10 errata-xmlrpc 2017-09-21 04:53:56 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2017:2774


Note You need to log in before you can comment on or make changes to this bug.