Bug 136133 - OOo Hangs/Locksup when right clicking for spell checker.
OOo Hangs/Locksup when right clicking for spell checker.
Status: CLOSED DUPLICATE of bug 124374
Product: Fedora
Classification: Fedora
Component: openoffice.org (Show other bugs)
3
athlon Linux
medium Severity medium
: ---
: ---
Assigned To: Dan Williams
:
: 137124 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-10-18 03:14 EDT by Strix Nebulosa
Modified: 2007-11-30 17:10 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-12-15 11:07:52 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Strix Nebulosa 2004-10-18 03:14:26 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.3)
Gecko/20040929

Description of problem:
While working on a larger document in Writer (150 pages) I noticed
that there was a word underlined in red (spelled incorrectly) and so I
right clicked to check the spelling against the list provided. I
noticed that my OO had locked up on me. I rebooted and once again was
able to repeat the problem. I checked this against a smaller document
and couldn't repeat the problem. The document size being the only
thing that changed.

This wasn't a problem with FC2 and my previous install of OpenOffice.

I have 256 Megs of ram. Is this a bug? or am I going to the shop to
buy more ram tommorow?

Version-Release number of selected component (if applicable):
1.1.2

How reproducible:
Always

Steps to Reproduce:
1.Open a large document in Writer.
2. Misspell a word.
3. Right click on misspelled word.
    

Actual Results:  System lockup.

Expected Results:  I would have been given a menu containing a list of
options of correctly spelled words along with the usual copy.paste.etc.

Additional info:

I have 256 Megs of ram. This was a large document (150 pages of
straight text and formatting ~ Novel.)
Comment 1 Dan Williams 2004-11-07 23:23:45 EST
*** Bug 137124 has been marked as a duplicate of this bug. ***
Comment 2 Sitsofe Wheeler 2004-11-22 12:43:01 EST
Stab in the dark but I think this might be dictionary related...

Strix, which dictionaries do you have installed (rpm -qa | grep spell)?
Comment 3 Sitsofe Wheeler 2004-11-22 14:39:33 EST
My previous request to list dictionaries is completely useless since
the FC3 version of OOo ships with all dictionaries installed and there
is no way to remove them individually with RPM.

I'd like to thank Chris Jones for helping to find this workaround.

After a lot of work I've found some steps that workaround for the
right mouse button memory leak problem:

1. Start oowriter .
2. Go to Tools -> Options -> Language Settings -> Writing Aids.
3. Untick "Openoffice.org MySpell Spellchecker".
4. Click the Edit button.
5. Switch to the language you need (e.g. "English (UK)") and tick
"Openoffice.org MySpell Spellchecker".
6. Click the Close button.
7. Go to Language Settings -> Languages.
8. Under Default languages for documents select which ever enabled
language you wish to be the default (e.g. "English (UK)").
9. Click OK.
10. Type a word with an obvious error followed by a space (e.g. "typ ").
11. Press the right mouse button over it and check that OOo brings up
a menu of suggestions and doesn't eat all your memory.
Comment 4 Sitsofe Wheeler 2004-11-22 14:42:07 EST
Dan, can you up the severity of this bug to high beacause on many
machines OOo exhausts all the memory causing the OOM killer to come
and out and start taking pot shots thus causing data loss.

Also note that this is a problem in FC3 final with the updated
openoffice.org-1.1.2-11.5.fc3 RPM (this bug still against fc3test3).
Comment 5 Dan Williams 2004-11-22 14:56:32 EST
Yeah, I'm not quite sure how to approach this.  People want their
language's dictionaries installed by default, but they don't want to
have to select them...  OOo however, will turn "on" all dictionaries
listed in the dictionary.lst file automatically, hence our problem.

There are at least two solutions:

1) Break up the OOo i18n package, make the distionary.lst a config
file.  This will be done for FC4.
2) Make OOo not turn on dictionaries by default when they are listed
in dictionary.lst, make the user explicitly enable "their" dictionary.
 This could be extended such that OOo automatically enables the
dictionary that corresponds to LANG when its started.

I think both need to be done, but (2) is the viable solution for FC3.
 The only problem with (2) is that everybody currently has _all_ the
dictionaries turned on in their config files because they've already
run OOo once.  How do we "turn off" all those extra dictionaries?
Comment 6 Sitsofe Wheeler 2004-11-22 17:29:51 EST
The whole break it up business appears to be what Mandrakelinux do. Of
course people HAVE to make sure they pick a dictionary at install time...

"How do we "turn off" all those extra dictionaries?"

I wish I knew. My quick poke around for a workaround earlier seemed to
suggest that a lot of the OOo config files in the user's directory are
actually binary. However it IS possible to script OOo isn't it? If the
configs are versioned perhaps it will be possible to detect an old
"everything is on config" and migrate it over to one where only the
current locale dictionary is turned on.

But Chris Jones pointed a few things out to me:
a) The "check in all languages" tick box is not ticked.
b) Why does explicit "check now" spell check work correctly?

Is this actually a bug in the AutoSpellcheck and the right mouse button?
Comment 7 Colin Charles 2004-11-27 22:20:50 EST
Dan, isn't this rather related to #124374 ? We know its a problem, we should
probably kill dupe bugs

Also, has timp agreed to getting the packages broken for FC-4? 
Comment 8 Sitsofe Wheeler 2004-11-28 08:24:42 EST
It should also be noted that doing the following:

mv /usr/lib/ooo-1.1/share/dict/ooo/dictionary.lst \
/tmp/dictionary.lst.orig
sort /tmp/dictionary.lst.orig | uniq -d > \
/usr/lib/ooo-1.1/share/dict/ooo/dictionary.lst

Then starting OOo appears to help a little bit.
Comment 9 Sitsofe Wheeler 2004-11-28 09:26:12 EST
Whoops, that uniq -d should have been just uniq
Comment 10 Dan Williams 2004-11-28 12:01:10 EST
I've add that 'cat dictionary.lst | sort | uniq' to the 1.1.2-14 RPMS,
so that should help until we figure out what the heck ooo-build's
dictionary installers are doing, or until a fix for the whole
spell-checking code happens.
Comment 11 Dan Williams 2004-11-29 21:43:02 EST

*** This bug has been marked as a duplicate of 124374 ***

Note You need to log in before you can comment on or make changes to this bug.