Bug 137124 - OO Devours RAM when right mouse click misspelled word
OO Devours RAM when right mouse click misspelled word
Status: CLOSED DUPLICATE of bug 136133
Product: Fedora
Classification: Fedora
Component: openoffice.org (Show other bugs)
2
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Dan Williams
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-10-25 17:34 EDT by Alex Weeks
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-12-15 11:08:59 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Alex Weeks 2004-10-25 17:34:55 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; rv:1.7.3) Gecko/20041001
Firefox/0.10.1

Description of problem:
After upgrading the the latest version of OpenOffice, when I right
mouse click a misspelled word it starts to hog RAM.  So much, that it
leaves my system barely usable until it releases the extra RAM it's
hogged.  For example it takes up to 1 minutes to get a konsole screen.

Overall it lasts anywhere from 1 to 3 minutes before this ends.  I
doubt that it's my laptop.  I have a 1.6G Centrino Processor with 256M
ram and 1G swap.

I have tested this 2 times in a row and got the same results both times:

Perform a fresh boot into run level 5.
Log into KDE
Start OpenOffice and create a new text document.
Start typing a misspell a word.
When OpenOffice underlines it in red indicating it is misspelled right
mouse click it.
Listen to hard drive + watch hard drive light go crazy.
Attempt to get to a konsole <- this could take a couple of minutes.
Do a top and hit M to sort by memory usage.
Watch OpenOffice's memory usage shoot up.  Durning these 2 tests it
hit just over 80% before winding down.

Version-Release number of selected component (if applicable):
1.1.2-10.fc2

How reproducible:
Always

Steps to Reproduce:
1. Start OpenOffice, create new text doc, mispell a word and right
mouse click on it.
2.
3.
    

Actual Results:  OpenOffice starts chewing up RAM (Great terminology,
huh?), making my system temporary unusable.

Expected Results:  Drop down window w/ options and spelling
suggestions. No real hit to RAM

Additional info:

If there is anything I can do to generate more data let me know.
Comment 1 Dan Williams 2004-11-07 23:23:43 EST

*** This bug has been marked as a duplicate of 136133 ***

Note You need to log in before you can comment on or make changes to this bug.