Bug 1362595 - [Beaker][WebUI] No way to "report a problem" with a system from the recipe page or the job page
Summary: [Beaker][WebUI] No way to "report a problem" with a system from the recipe pa...
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Beaker
Classification: Community
Component: web UI
Version: 22
Hardware: Unspecified
OS: Unspecified
medium
unspecified vote
Target Milestone: 24.0
Assignee: Jon Orris
QA Contact: tools-bugs
URL: https://beaker.engineering.redhat.com...
Whiteboard:
Keywords: Patch, UserExperience
: 1378890 (view as bug list)
Depends On: 1366191
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-08-02 15:15 UTC by Jeff Burke
Modified: 2017-02-21 18:51 UTC (History)
6 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2017-02-21 18:51:11 UTC


Attachments (Terms of Use)

Description Jeff Burke 2016-08-02 15:15:48 UTC
Description of problem:
 When using the new WebUI schema in Beaker 23.0. I had a system fail to install multiple times.

https://beaker.engineering.redhat.com/recipes/2920682#task43832076
https://beaker.engineering.redhat.com/recipes/2920327#task43821755

I do not see how to report an issue with a system fromthe recipe page or from the job page:

https://beaker.engineering.redhat.com/recipes/2920327#task43821755
https://beaker.engineering.redhat.com/jobs/1425948

https://beaker.engineering.redhat.com/recipes/2920327#task43821755
https://beaker.engineering.redhat.com/jobs/1425832

Please bring back the report a problem button 

Thanks,
Jeff

Comment 1 Roman Joost 2016-09-26 06:39:28 UTC
*** Bug 1378890 has been marked as a duplicate of this bug. ***

Comment 2 Jon Orris 2016-12-20 21:28:24 UTC
https://gerrit.beaker-project.org/#/c/5557/

Comment 3 Dan Callaghan 2017-01-11 22:20:13 UTC
Seems like it was never mentioned explicitly in the bug here... Our solution was to add an extra item into the system dropdown, which we added to the recipe page for bug 1366191. So now on the recipe page, where before there was just a hyperlink to the system page, you will now see a menu with a few different actions, including "Report problem".

Comment 5 Hui Wang 2017-01-12 01:21:18 UTC
Verified this issues.
The result is PASS.
Version: Beaker 24.0.git.241.4eb2414

Steps:
On a recipe page, click "Report Problem" from the system dropdown menu.
Input message, then send.  It will alert success message.

Comment 6 Dan Callaghan 2017-02-21 18:51:11 UTC
Beaker 24.0 has been released.


Note You need to log in before you can comment on or make changes to this bug.