This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 136359 - keyboard kickstart directive is ignored
keyboard kickstart directive is ignored
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
3
All Linux
medium Severity medium
: ---
: ---
Assigned To: Paul Nasrat
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-10-19 10:44 EDT by david d zuhn
Modified: 2007-11-30 17:10 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-02-01 21:59:23 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
kickstart file for bug (1.67 KB, text/plain)
2004-10-19 10:46 EDT, david d zuhn
no flags Details
My ks file (1.02 KB, text/plain)
2004-10-20 06:46 EDT, Paul Nasrat
no flags Details

  None (edit)
Description david d zuhn 2004-10-19 10:44:20 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7)
Gecko/20040808 Firefox/0.9.3

Description of problem:
I have a kickstart file for FC3test3, and this file contains a 
keyboard directive.  Yet when I perform an installation using this
config file, I am still being prompted for a keyboard choice.








Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. use the kickstart config file attached to this bug
2. see the prompt for keyboard type
3. enter a keyboard type
    

Expected Results:  The keyboard directive should be honored.  

Additional info:
Comment 1 david d zuhn 2004-10-19 10:46:10 EDT
Created attachment 105449 [details]
kickstart file for bug

This kickstart file is loaded via http:

Kernel command line: initrd=/install/fedora/3t3/initrd.img ksdevice=eth0
ks=http://lab/ks/machine/trabant3/fc3t3.ks console=ttyS0,9600
BOOT_IMAGE=/install/fedora/3t3/vmlinuz vnc vncconnect=homestake
Comment 2 Paul Nasrat 2004-10-20 06:46:44 EDT
Created attachment 105503 [details]
My ks file

Unable to reproduce here.

Tested with a FC3T3 tree and above kickstart using uk initially then changing
to us for keyboard directive.  The kickstart boots up into graphical and goes
straight to reading package information, before formatting and installing.  No
additional input required.

Can you confirm with above config just changing the url/nfs line as appropriate
for your setup?
Comment 3 david d zuhn 2004-10-20 11:19:57 EDT
Yes, I can confirm the bug.  I also had to change the disk
partitioning from hda to sda, but using your attached kickstart file I
was again prompted for a keyboard type.  This was the only prompt for
user input.

Some more information about my configuration:  this is a Dell 2650
machine, pxebooting the installation, using a serial console for the
installation.   There is no keyboard actually attached to this system.

Comment 4 Paul Nasrat 2004-10-20 13:05:58 EDT
Can you retest with a keyboard attached?
Comment 5 david d zuhn 2004-10-20 13:53:56 EDT
Tested again, with full keyboard/mouse/video setup attached.  No
change in behavior -- I'm still prompted for a keyboard type.

I then tried it without the serial console (no console= argument on
the kernel command line), and it proceeded to do a complete
installation, without prompting for the keyboard type.



Comment 6 david d zuhn 2004-10-20 14:08:51 EDT
Just for comparison, running the same sort of setup (serial console,
no keyboard, pxebooted kernel) works fine on RHEL 4b1 (Nahant).   
Comment 7 Jeremy Katz 2005-02-01 21:59:23 EST
Add 'serial' to your command line options and it'll work.  It's fixed post-FC3

Note You need to log in before you can comment on or make changes to this bug.