Bug 1364706 - Warn users when they try to create striped volumes
Summary: Warn users when they try to create striped volumes
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: GlusterFS
Classification: Community
Component: cli
Version: mainline
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
Assignee: Vijay Bellur
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks: glusterfs-3.9.0 1364707
TreeView+ depends on / blocked
 
Reported: 2016-08-06 11:02 UTC by Niels de Vos
Modified: 2018-10-31 03:09 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-10-31 03:09:33 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Description Niels de Vos 2016-08-06 11:02:14 UTC
Stripe functionality has been implemented by sharding. The stripe xlator is barely maintained anymore and should be deprecated.

The plan is to remove the stripe xlator in two steps:

1. remove the command line option to prevent users from creating new volumes that
   use the stripe xlator

2. after a release that includes point 1, remove the stripe xlator from the
   sources


This bug deals with step 1, step 2 is to be done after 3.9.0 has been released (see related bug in the blocks field)

Comment 1 Niels de Vos 2016-09-22 11:51:11 UTC
Vijay, you wanted to send a patch for the CLI that warns users when they try to create a striped volume. Did you find time to do that yet?

It should probably also warn once in some of the logs, maybe in the init() routine of the stripe xlator itself.

Comment 2 Atin Mukherjee 2018-10-05 04:07:49 UTC
Vijay - do you want to take this up?

Comment 3 Vijay Bellur 2018-10-30 17:50:18 UTC
(In reply to Atin Mukherjee from comment #2)
> Vijay - do you want to take this up?

Since we are removing stripe from the build, is there a necessity to act on this bug? Should we close this as WONTFIX?

Comment 4 Amar Tumballi 2018-10-31 03:09:33 UTC
Lets mark it as WONTFIX. The patch to remove stripe is merged upstream


Note You need to log in before you can comment on or make changes to this bug.