Bug 1364707 - Remove deprecated stripe xlator
Summary: Remove deprecated stripe xlator
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: stripe
Version: mainline
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: ---
Assignee: Susant Kumar Palai
QA Contact:
URL:
Whiteboard:
Depends On: 1364706
Blocks: 1635688
TreeView+ depends on / blocked
 
Reported: 2016-08-06 11:03 UTC by Niels de Vos
Modified: 2019-03-25 16:30 UTC (History)
3 users (show)

Fixed In Version: glusterfs-6.0
Doc Type: Enhancement
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-03-25 16:30:11 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Gluster.org Gerrit 21433 0 None Open stripe: remove the translator from build and glusterd 2018-10-31 02:25:21 UTC

Description Niels de Vos 2016-08-06 11:03:01 UTC
Stripe functionality has been implemented by sharding. The stripe xlator is barely maintained anymore and should be deprecated.

The plan is to remove the stripe xlator in two steps:

1. remove the command line option to prevent users from creating new volumes that
   use the stripe xlator

2. after a release that includes point 1, remove the stripe xlator from the
   sources


This bug deals with point 2, the first step is done in bug 1364706.

Comment 1 Amar Tumballi 2018-09-18 08:37:34 UTC
https://lists.gluster.org/pipermail/gluster-users/2018-July/034400.html talks about deprecation, and hence we can technically remove all the code for stripe from codebase (including tests)

Comment 2 Amar Tumballi 2018-10-05 03:01:40 UTC
https://review.gluster.org/21327

Comment 3 Worker Ant 2018-10-25 07:13:55 UTC
REVIEW: https://review.gluster.org/21433 (stripe: remove the translator from build and glusterd) posted (#9) for review on master by Amar Tumballi

Comment 4 Worker Ant 2018-10-31 02:25:19 UTC
REVIEW: https://review.gluster.org/21433 (stripe: remove the translator from build and glusterd) posted (#10) for review on master by Atin Mukherjee

Comment 5 Shyamsundar 2019-03-25 16:30:11 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-6.0, please open a new bug report.

glusterfs-6.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] https://lists.gluster.org/pipermail/announce/2019-March/000120.html
[2] https://www.gluster.org/pipermail/gluster-users/


Note You need to log in before you can comment on or make changes to this bug.