Bug 136512 - [PATCH] improve seeking in ogg/vorbis/theora
[PATCH] improve seeking in ogg/vorbis/theora
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: gstreamer-plugins (Show other bugs)
rawhide
All Linux
medium Severity high
: ---
: ---
Assigned To: John (J5) Palmieri
:
: 136514 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-10-20 12:40 EDT by Ronald Bultje
Modified: 2013-03-13 00:46 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-04-29 10:52:05 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
improve seeking in ogg (11.72 KB, patch)
2004-10-20 12:41 EDT, Ronald Bultje
no flags Details | Diff
from other bug (7.35 KB, patch)
2004-10-21 13:38 EDT, Colin Walters
no flags Details | Diff

  None (edit)
Description Ronald Bultje 2004-10-20 12:40:02 EDT
Attached patch improves the speed of seeking in ogg/vorbis/theora
files considerably. This is noticeable with large theora files
(>50MB), where the pause used to take several seconds.

Patch is against 0.8.5-1. It obsoletes (or rather: includes) the
vorbis-seeking patch that the current RPM contains.
Comment 1 Ronald Bultje 2004-10-20 12:41:32 EDT
Created attachment 105525 [details]
improve seeking in ogg
Comment 2 Colin Walters 2004-10-20 15:46:31 EDT
I tested a gstreamer-plugins with these patches, and it did break Rhythmbox's
playback of ogg files.  Didn't try sound-juicer.  I just don't have time to try
to track down the breakage today, it's only an hour before the total freeze
hits.  I will include the patches in the SRPM but off by default, so someone who
doesn't care about Rhythmbox but wants to use Totem can enable them.

Hopefully we can get these patches sorted out and tested with Rhythmbox and
everything else we ship that links to GStreamer, and push it as an FC3 update.
Comment 3 Colin Walters 2004-10-21 13:37:39 EDT
*** Bug 136514 has been marked as a duplicate of this bug. ***
Comment 4 Colin Walters 2004-10-21 13:38:28 EDT
Created attachment 105600 [details]
from other bug

Patch from other bug
Comment 5 John Thacker 2006-04-29 10:52:05 EDT
pretty sure that this already got applied upstream and made it into at
least FC4.

Note You need to log in before you can comment on or make changes to this bug.