Bug 136565 - Add PDF printing to CUPS
Add PDF printing to CUPS
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: cups-pdf (Show other bugs)
9
All Linux
medium Severity medium
: ---
: ---
Assigned To: Remi Collet
Fedora Extras Quality Assurance
bzcl34nup
: Reopened
Depends On: 243605
Blocks:
  Show dependency treegraph
 
Reported: 2004-10-20 18:18 EDT by Mathijs Tieleman
Modified: 2008-05-31 01:29 EDT (History)
4 users (show)

See Also:
Fixed In Version: FC6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-31 01:29:10 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Mathijs Tieleman 2004-10-20 18:18:55 EDT
We're using Fedora in our internet corners. users love to see the
print-to-PDf-file option within CUPS. This makes it easy to create PDF
file from for example Firefox pages.

It easy via one of the following websites, but it would be create if
it is being implemented as a standard.

The only extra whish is to let a pop-up ask the user for the directory
to store the PDF in (and somehow have somewhere a default dir.
available). 


http://www.linux-als-server.de/html/special-pdfprinter.php
http://www.mensinck.de/it_ber/linux/pdfprcups.html
http://cip.physik.uni-wuerzburg.de/~vrbehr/cups-pdf/


Mathijs
Comment 1 Tom Lynema 2006-04-26 20:52:54 EDT
Cups-pdf works well in fc5.
http://www.physik.uni-wuerzburg.de/~vrbehr/cups-pdf/

There are rpms for cups-pdf at http://remi.collet.free.fr/rpms/ .  
I am using
http://remi.collet.free.fr/rpms/fc5.i386/cups-pdf-2.2.0-1.fc5.remi.i386.rpm

Comment 2 Martin Jürgens 2007-09-04 06:25:47 EDT
+ 1. Would be nice if Fedora was shipped with a PDF printer by default. This bug
is here as of 3 years, is there any hope that something will happen?
Comment 3 Tim Waugh 2007-09-04 06:35:11 EDT
We ship cups-pdf already.
Comment 4 Martin Jürgens 2007-09-04 07:07:32 EDT
Isn't this bug report about implenting that as a standard, so shipping it by
default with Fedora?

Also, it says that a file chooser would be nice :)
Comment 5 Martin Jürgens 2007-09-04 07:14:47 EDT
The missing file chooser does not really bug me, but having cups-pdf shipped by
default in a normal desktop Fedora install would be nice.

This depends on bug 276021 being fixed.
Comment 6 Tim Waugh 2007-09-04 07:19:43 EDT
Reassigning.
Comment 7 Remi Collet 2007-09-20 12:58:55 EDT
Having cups-pdf shipped by default seems not possible.

In fact, cups-pdf need a "running" cupsd after install to be able to create the
printer queue. This is not possible during anaconda installation.

I will have to work on a "first run" solution to solve this problem.

Regards
Comment 8 Bug Zapper 2008-04-03 11:42:55 EDT
Based on the date this bug was created, it appears to have been reported
against rawhide during the development of a Fedora release that is no
longer maintained. In order to refocus our efforts as a project we are
flagging all of the open bugs for releases which are no longer
maintained. If this bug remains in NEEDINFO thirty (30) days from now,
we will automatically close it.

If you can reproduce this bug in a maintained Fedora version (7, 8, or
rawhide), please change this bug to the respective version and change
the status to ASSIGNED. (If you're unable to change the bug's version
or status, add a comment to the bug and someone will change it for you.)

Thanks for your help, and we apologize again that we haven't handled
these issues to this point.

The process we're following is outlined here:
http://fedoraproject.org/wiki/BugZappers/F9CleanUp

We will be following the process here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping to ensure this
doesn't happen again.
Comment 9 Andrew Farris 2008-04-07 21:25:41 EDT
This appears to be one that shouldn't close quite yet.

Remi, has cups-pdf shipping by default been solved or abandoned as not possible?
Comment 10 Bug Zapper 2008-05-06 20:01:58 EDT
This bug has been in NEEDINFO for more than 30 days since feedback was
first requested. As a result we are closing it.

If you can reproduce this bug in the future against a maintained Fedora
version please feel free to reopen it against that version.

The process we're following is outlined here:
http://fedoraproject.org/wiki/BugZappers/F9CleanUp
Comment 11 Bug Zapper 2008-05-13 21:58:07 EDT
Changing version to '9' as part of upcoming Fedora 9 GA.
More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 12 Remi Collet 2008-05-31 01:29:10 EDT
Gnome printing dialog now allow printing to PDF.

Even Firefox use it now.
OOo can also produce PDF.

Cups-pdf still usefull for a very few apps.
So, i don't think is really usefull to have cups-pdf installed by default.

Note You need to log in before you can comment on or make changes to this bug.