Bug 136665 - Cdrecord fails to write DVD+R correctly works with DVD+RW
Cdrecord fails to write DVD+R correctly works with DVD+RW
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: cdrtools (Show other bugs)
4.0
i686 Linux
medium Severity medium
: rc
: ---
Assigned To: Harald Hoyer
: Reopened
: 166322 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-10-21 11:32 EDT by Terry Barnaby
Modified: 2009-05-18 16:29 EDT (History)
23 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-05-18 16:29:27 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Commands and output (6.94 KB, text/plain)
2004-12-10 03:04 EST, Bjorn Karlsen
no flags Details
error message when fixating disk (2.06 KB, text/plain)
2005-02-15 09:29 EST, Aleksandar Milivojevic
no flags Details

  None (edit)
Description Terry Barnaby 2004-10-21 11:32:49 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.3)
Gecko/20040922

Description of problem:
System: Fedora 2 system, with all updates to about 15/10/04
DVD Drive: NEC DVD_RW ND-2510A Rev: 2.15 IDE
Command line: "cdrecord -v speed=2 dev=/dev/cdrom -dao don.dvd"

I am trying to write a 2.4G iso image to a DVD+R disk using cdrecord.
The command appears to work fine but I am unable to mount the
resulting disk. If I run "dd=/dev/cdrom of=/tmp/aa" this only transfers
2048 bytes before stopping.

If I use the same command with a DVD+RW disk all works fine ....

The output from the command was:

Note: This version is an unofficial (modified) version with DVD support
Note: and therefore may have bugs that are not present in the original.
Note: Please send bug reports or support requests to
http://bugzilla.redhat.com/bugzilla
Note: The author of cdrecord should not be bothered with problems in
this version.
TOC Type: 1 = CD-ROM
scsidev: '/dev/cdrom'
devname: '/dev/cdrom'
scsibus: -2 target: -2 lun: -2
Linux sg driver version: 3.5.27
Using libscg version 'schily-0.8'.
cdrecord: Warning: using inofficial libscg transport code version
(schily - Red Hat-scsi-linux-sg.c-1.83-RH '@(#)scsi-linux-sg.c       
1.83 04/05/20 Copyright 1997 J. Schilling').
SCSI buffer size: 64512
atapi: 1
Device type    : Removable CD-ROM
Version        : 0
Response Format: 2
Capabilities   :
Vendor_info    : '_NEC    '
Identifikation : 'DVD_RW ND-2510A '
Revision       : '2.15'
Device seems to be: Generic mmc2 DVD-R/DVD-RW.
Current: 0x001B
Profile: 0x002B
Profile: 0x001B (current)
Profile: 0x001A
Profile: 0x0014
Profile: 0x0013
Profile: 0x0011
Profile: 0x0010
Profile: 0x000A
Profile: 0x0009
Profile: 0x0008
cdrecord: Found DVD media: using cdr_mdvd.
Using generic SCSI-3/mmc DVD-R(W) driver (mmc_mdvd).
Driver flags   : SWABAUDIO BURNFREE
Supported modes: PACKET SAO
Drive buf size : 1769472 = 1728 KB
FIFO size      : 4194304 = 4096 KB
Track 01: data  2443 MB
Total size:     2806 MB (278:01.24) = 1251093 sectors
Lout start:     2806 MB (278:03/18) = 1251093 sectors
Current Secsize: 2048
  ATIP start of lead in:  -150 (00:00/00)
  ATIP start of lead out: 157789 (35:05/64)
Disk type:    unknown dye (reserved id code)
Manuf. index: -1
Manufacturer: unknown (not in table)
Blocks total: 2295104 Blocks current: 2295104 Blocks remaining: 1044011
scsi_set_streaming
Speed set to 2822 KB/s
Starting to write CD/DVD at speed   2.0 in real SAO mode for single
session.
Last chance to quit, starting real write    0 seconds. Operation starts.
Waiting for reader process to fill input buffer ... input buffer ready.
trackno=0
BURN-Free is OFF.
BURN-Free is OFF.
Performing OPC...
Sending CUE sheet...
cdrecord: WARNING: Drive returns wrong startsec (0) using -150
Starting new track at sector: 0
Track 01: 2443 of 2443 MB written (fifo 100%) [buf  96%]   2.6x.
Track 01: Total bytes read/written: 2562238464/2562238464 (1251093
sectors).
Writing  time:  765.870s
Average write speed   2.5x.
Min drive buffer fill was 15%
Fixating...
Fixating time:    0.516s
cdrecord: fifo had 40358 puts and 40358 gets.
cdrecord: fifo was 58 times empty and 31752 times full, min fill was 0%.

Version-Release number of selected component (if applicable):
2.01.1-0.FC2.1

How reproducible:
Always

Steps to Reproduce:
1. Try to record a DVD+R using cdrecord (Options in description)
2.
3.
    

Additional info:
Comment 1 Jeff Cheng 2004-12-01 19:01:06 EST
I have similar problems with growisofs.  DVD+RW's work fine, but
DVD+R's do not.  So maybe this is not just a cdrecord issue.
Comment 2 Jeff Cheng 2004-12-01 19:08:23 EST
Forgot to mention that I'm using FC3 (kernel-2.6.9-1.681_FC3) and
dvd+rw-tools-5.21.4.10.8-2.
Comment 3 Harald Hoyer 2004-12-07 11:44:50 EST
hmm, strange...
Comment 4 Terry Barnaby 2004-12-08 04:43:42 EST
Note that I was tring to burn an ISO image of Fedora 2 with boot ability.
So I am using quite a lot of mkisofs options. So this could be a mkisofs
issue, although it is strange than wring to a DVD+RW works fine with the
same iso image.

I will try creating a simple big (3G) iso image today and try burning that.
My system is stock Fedora 2 with upgrades to date.
Comment 5 Harald Hoyer 2004-12-08 06:00:12 EST
are you sure, the DVD+R media is fine with your burning speed?
Comment 6 Terry Barnaby 2004-12-08 06:12:27 EST
No I am not sure, I set the speed at what I thought was slow, 2x. I used
a higher speed with the DVD+RW and that worked fine.

The DVD+R's are marked "Nashua Version 1.0 4.7Gigabyte 120 minute" and
state "For Use ONLY in DVD+R/+RW" recorders. But do not mention anything
about speed.

I will try them at 1x, this will be slow !
Comment 7 Harald Hoyer 2004-12-08 06:44:07 EST
another try would be to use other DVD+R products, since this is the sole
bugreport about this problem
Comment 8 Jeff Cheng 2004-12-08 13:47:56 EST
Maybe this is somehow related to bug#141081 that I'm tracking.

I've also tried setting the speed to 1x, 2x, and 4x, and two different
brands of dvd+r's without success.

Output from dvd+rw-mediainfo for dvd+r:
INQUIRY:                [_NEC    ][DVD_RW ND-3500AG][2.16]
GET [CURRENT] CONFIGURATION:
 Mounted Media:         1Bh, DVD+R
 Media ID:              RICOHJPN/R01
 Current Write Speed:   6.1x1385=8467KB/s
 Write Speed #0:        6.1x1385=8467KB/s
 Write Speed #1:        5.1x1385=7056KB/s
 Write Speed #2:        4.1x1385=5645KB/s
 Write Speed #3:        3.1x1385=4234KB/s
 Write Speed #4:        2.0x1385=2822KB/s
 Write Speed #5:        1.0x1385=1411KB/s
GET [CURRENT] PERFORMANCE:
 Write Performance:     4.0x1385=5540KB/s@[0 -> 442367]
                        6.0x1385=8310KB/s@[442368 -> 1155071]
                        8.0x1385=11080KB/s@[1155072 -> 2295104]
 Speed Descriptor#0:    00/2295104 R@8.0x1385=11080KB/s
W@8.0x1385=11080KB/s
 Speed Descriptor#1:    00/2295104 R@8.0x1385=11080KB/s
W@6.0x1385=8310KB/s
 Speed Descriptor#2:    00/2295104 R@5.0x1385=6925KB/s W@4.0x1385=5540KB/s
 Speed Descriptor#3:    00/2295104 R@5.0x1385=6925KB/s W@2.4x1385=3324KB/s
READ DISC INFORMATION:
 Disc status:           blank
 Number of Sessions:    1
 State of Last Session: empty
 Number of Tracks:      1
READ TRACK INFORMATION[#1]:
 Track State:           blank
 Track Start Address:   0*2KB
 Next Writable Address: 0*2KB
 Free Blocks:           2295104*2KB
 Track Size:            2295104*2KB
READ CAPACITY:          1*2048=2048

Output from dvd+rw-mediainfo for dvd+rw:
INQUIRY:                [_NEC    ][DVD_RW ND-3500AG][2.16]
GET [CURRENT] CONFIGURATION:
 Mounted Media:         1Ah, DVD+RW
 Media ID:              RICOHJPN/W11
 Current Write Speed:   6.1x1385=8467KB/s
 Write Speed #0:        6.1x1385=8467KB/s
 Write Speed #1:        5.1x1385=7056KB/s
 Write Speed #2:        4.1x1385=5645KB/s
 Write Speed #3:        3.1x1385=4234KB/s
 Write Speed #4:        2.0x1385=2822KB/s
 Write Speed #5:        1.0x1385=1411KB/s
GET [CURRENT] PERFORMANCE:
 Write Performance:     4.0x1385=5540KB/s@[0 -> 2295104]
 Speed Descriptor#0:    00/2295104 R@5.0x1385=6925KB/s W@4.0x1385=5540KB/s
 Speed Descriptor#1:    00/2295104 R@5.0x1385=6925KB/s W@2.4x1385=3324KB/s
READ DVD STRUCTURE[#0h]:
 Media Book Type:       92h, DVD+RW book [revision 2]
 Legacy lead-out at:    2295104*2KB=4700372992
READ DISC INFORMATION:
 Disc status:           complete
 Number of Sessions:    1
 State of Last Session: complete
 Number of Tracks:      1
 BG Format Status:      suspended
READ TRACK INFORMATION[#1]:
 Track State:           complete
 Track Start Address:   0*2KB
 Free Blocks:           0*2KB
 Track Size:            2295104*2KB
FABRICATED TOC:
 Track#1  :             14@0
 Track#AA :             14@2295104
 Multi-session Info:    #1@0
READ CAPACITY:          2295104*2048=4700372992
Comment 9 Terry Barnaby 2004-12-09 06:01:32 EST
I have tried a different type of DVD to record onto, in this case a
TDK DVD-R, 4.7GByte 1-8x. This recorded fine.

So the problem may be:

1. There is some issue with writing to DVD+R disks rather than DVD-R disks.
2. There is some incompatibility with the Nashua DVD+R's and the NEC DVD
recorder I am using.
3. I notice that even though I used the "speed=1" option the Nashua DVD+RW and
DVD+R seemed to record at 2.5x and the TDK DVD-R seemd to record at 4x. Is the
speed option working corectly ?
Comment 10 Harald Hoyer 2004-12-09 09:27:40 EST
oh, you a USB DVD writer? You might try a kernel > 2.6.9-1.698_FC3
Comment 11 Harald Hoyer 2004-12-09 09:28:01 EST
+have
Comment 12 Bjorn Karlsen 2004-12-10 03:02:20 EST
I have the same problem on 2 systems. I'm not able to write DVD+R 
disks (the write process seems ok, but the disks are not readable in 
any of my DVD-ROM drives or DVD-writers).
DVD-R disks are ok, though.

System 1: Home-made PC with FC2 and LG GSA-4040B DVD writer.
Brands: DVD+R: Smartbuy, didn't work. DVD-R: That's Write!, ok.

System 2: Compaq Evo D510 with FC3 and HP DVD Writer dvd530i.
Brands: DVD+R: Sony and Verbatim, didn't work. DVD-R: That's Write!, 
ok.

See attachment for details.
Comment 13 Bjorn Karlsen 2004-12-10 03:04:36 EST
Created attachment 108304 [details]
Commands and output
Comment 14 Edward Clark 2004-12-24 16:48:23 EST
I have the same issue with Fedora Core 2.6.9-1.681_FC3 using USB
connected DVD writer (NEC) and burning to DVD+R Philips media. Will
try kernel 698_FC3 and report back.

System:
Dell D800 Latitude w/ ATI 9600
1 GB RAM
40 GB HD in Bay (Fedora)
60 GB HD in HD Bay (windows)
NEC 6500 writer
Comment 15 Edward Clark 2004-12-24 17:30:28 EST
KERNEL 2.6.9-1.698_FC3 FIXED MY ISSUE!

Thanks!
Comment 16 Aleksandar Milivojevic 2005-01-27 17:12:00 EST
I still have this issue with all versions of kernel, from stock FC3
kernel, to the latest update.  The drive is Sony DRX-710UL.  This is
USB2 DVD burner for both DVD+R/RW and DVD-R/RW media support.

The problem with cdrecord and DVD+R discs is that cdrecord is not
fixating them!  Actually, I had exactly the same problem with both
DVD+R and DVD-R media.  DVD-R media worked under specific combination
of kernel and udev, but not under other.  Worked might be a strong
word.  I got exactly one DVD-R disc burned properly so far.  DVD+R
media didn't work on any version of kernel and/or udev.  I've
discovred this because fixating time that cdrecord reported was
suspiciously short.  For example, Nero under Windows spends almost 15
seconds (maybe even more) fixating the disc at the end of the write. 
Cdrecord exits (and reports) after about half a second.  See cdrecord
output from original bug report.  The relevant lines read:

Fixating...
Fixating time:    0.516s

This is wrong.  It should be way longer.  In reality, disc wasn't
fixated at all (read bellow).

This worked for me to save DVD+R discs burned with cdrecord.  If I
burn DVD+R using cdrecord, it is not readable in anything.  Not even
DVD my burner.  Than if I reboot to Windows and start Nero, and click
on "Disc Info" (with that same DVD+R disc in the burner), it reports
that disc is still open and additional writes (sessions) are possible.
 If (still in Nero) I select "close disc" (or something similar,
basically it instructs Nero to fixate disc) option from drop down
menu, Nero will fixate the disc.  After this, disc works perfectly and
was readable in all DVD drives I tested it with.

So, the problem is with cdrecord not perfoming disc fixation.  Even if
I do explicit "cdredord -fix", it will not fixate the disc.  It will
report it did, but it will not perform the operation.

Another problem I had with cdrecord and my Sony DVD burner was that
from time to time it will exit in the middle of the session (before
all data is written to DVD) and report that disc was recorded
successfully.  Well it wasn't.  So far, I had this problem only with
DVD-R media.  Even when burnproof was turned on.  The funny part was
that (when -v option is used) it would count to (for example) 1200MB
out of 2000MB, than it would exit, and report successfull recording. 
the sad part was that each time I got a nice coaster.  And I already
have way more coasters than glasses and mugs.
Comment 17 Aleksandar Milivojevic 2005-01-28 09:22:28 EST
I forgot to mention, I had exactly the same problem with growisofs
too.  Could it be kernel or underlying library (cdrecord and growisofs
are both using Schilling's libscg)?
Comment 18 Harald Hoyer 2005-01-28 09:30:42 EST
growisofs does not use Schilling's libscg.
I would guess, that the kernel is to blame... or bad media..
You may also try Schilling's cdrecord-prodvd ... 
Or an original FC2 kernel..
Comment 19 Aleksandar Milivojevic 2005-01-28 16:41:18 EST
Media was fine.  I used DVDs from the very same box under Windows with
Nero, all worked perfectly.  The ones I burned under Linux using
cdrecord/growisofs were not burned properly.  I was able to save those
by manually fixating them under Windows with Nero.  So as I wrote,
cdrecord and growisofs burn the session correctly, but than fail to
fixate disk for whatever reason.  Looking at the cdrecord output from
this bug report (the one in original report), this was exactly what
happened to Terry.  There's no way that fixation was completed in just
half a second.  Might as well be kernel problem (kernel not
forwarding/translating SCSI command to USB device).  I also had
problems with FC3 that depending to what kind of motherboard DVD
burner was connected, it wouldn't work at all.  Under some (newer)
versions of kernel udev wasn't doing its job properly.  Under some
(older) everything worked.  I've opened another bug report about that
(bug #146043).

BTW, I tought I saw message somewhere in the output of growisofs
"using libscg"?  I might be wrong, I'm in 30s now, getting old, my
memory doesn't serve me as it used to in my 20s ;-)
Comment 20 Harald Hoyer 2005-01-28 20:30:54 EST
This is no excuse! I am 33 years young :)
Comment 21 Aleksandar Milivojevic 2005-01-31 16:39:56 EST
I'll be as young as you sometime around April :-)

Anyhow, I saw after one of my comments status chagned to needinfo. 
What kind of info is needed?  Not sure if it was needed about
something I added to bug report, or if I can also try to test something?
Comment 22 Aleksandar Milivojevic 2005-02-15 09:29:24 EST
Created attachment 111087 [details]
error message when fixating disk

With latest kernels, I got a bit different behaviour.  As before, writing to
DVD-R media is OK, but when writing to DVD+R media disk is not fixated.

However, now when I attempt to simply just fix the disk using "cdrecord
dev=0,0,0 -fix -v" after write is done, I'm getting an error (with older
kernels, cdrecord would report that disk was fixated, but it wasn't).  I've
included complete output of cdrecord as attachment.
Comment 23 Bjorn Karlsen 2005-02-16 09:21:37 EST
Tested on system #2 (see comment #12) with kernel 2.6.9-1.681_FC3.

Media: Sony DVD+R.
-Writing to the DVD is ok.
-DVD is unreadable.
-Inserting the DVD into a Microsoft Windows PC with Nero Burning ROM.
-Fixating the DVD in Nero Burning ROM.
-DVD is ok.
Comment 24 Chuck Berg 2005-03-10 15:23:47 EST
I have the same problem, on Plextor, NEC, and Pioneer burners. All USB.

With kernel 2.6.11 and cdrecord 2.01.1-5, I am able to fixate the discs with
cdrecord -fix and they then work fine.
Comment 25 Steve Fink 2005-03-22 18:17:54 EST
I was having the same problem. kernel 2.6.9-1.681_FC3, two versions of cdrecord,
the later one is "Cdrecord-Clone 2.01-dvd". I am using a Yamakawa DVD burner,
directly attached to the IDE bus as /dev/hdb (no USB involved). I was unable to
mount the DVDs. dvd+rw-tools showed an open session. After running

  cdrecord -v dev=ATA:0,1,0 -fix

the one I tried works fine. It reported

  Fixating time:   23.507s

Thank you Aleksandar!
Comment 26 Thomas Zehetbauer 2005-03-29 16:08:20 EST
Got hit by this bug too, hardware is a "_NEC DVD_RW ND-3500AG", commands used
for ISO creation/burning were "mkisofs -J -r -V 'XXX' >DVD.iso" and "cdrecord
-dao -eject -v DVD.iso", kernel is 2.6.11/x86_64
Comment 27 Jonathan Kamens 2005-06-08 06:41:40 EDT
I am having this problem with a Sony DW-D26A DVD+R drive, and "cdrecord -v
dev=ATA:1,0,0 -fix" doesn't work.  It says:

cdrecord: Success. reserve track: scsi sendcmd: no error
CDB:  53 00 00 00 00 00 00 00 00 00
status: 0x2 (CHECK CONDITION)
Sense Bytes: 70 00 05 00 00 00 00 0A 00 00 00 00 72 05 00 00
Sense Key: 0x5 Illegal Request, Segment 0
Sense Code: 0x72 Qual 0x05 (no more track reservations allowed) Fru 0x0
Sense flags: Blk 0 (not valid) 
cmd finished after 0.000s timeout 40s
cdrecord: Cannot open new session.

I'm not using ide-scsi; do you think that would make a difference?
Comment 28 Jonathan Kamens 2005-06-08 08:54:50 EDT
This bug is over seven months old.  I don't see anything in the comments 
explaining why it's still in NEEDINFO state.  It seems to me that plenty of 
information has been provided, and what's more, enough people have reported 
the problem that it's clearly not an isolated case.  I'm changing the status 
to ASSIGNED.  If there really is still needed info, please change it back to 
NEEDINFO and explain what's needed, because I don't see it.
Comment 29 Jonathan Kamens 2005-06-08 23:04:43 EDT
FWIW, I was able to burn an ISO to DVD+R with growisofs even though cdrecord
wouldn't work to burn the same ISO.  This seems to differ from the experience
mentioned by someone else above that they couldn't get either cdrecord or
growisofs to work.
Comment 30 Matthew Miller 2005-07-12 17:40:13 EDT
Fedora Core 2 is now maintained by the Fedora Legacy project for
security updates only. Can someone please test this on FC4?
Comment 31 Jonathan Kamens 2005-07-12 18:26:01 EDT
When I encountered this problem (note the date of my comment above) it was on an
FC4 system with all the current devel packages installed.
Comment 32 Matthew Miller 2005-07-12 19:26:59 EDT
Date of comment could just mean you're slow to upgrade. :)

Thanks for confirming.
Comment 33 Aleksandar Milivojevic 2005-07-13 21:06:26 EDT
If memory serves me right, problem exists on RHEL4 too.
Comment 34 Jean-Rene Cormier 2005-07-16 22:02:34 EDT
I'm getting the same results, I haven't tried DVD+R nor DVD+RW but I can't read
DVD-R burned with a NEC ND-3500AG from my other DVD drives and I tried 4
different ones. The NEC DVD writer can read them fine though, in Linux and
WinXP. Also I can read the FC3 and FC4 DVD ISOs I burned with this writer in my
other DVD drives just fine. Could it just be the way we create the ISOs?
Comment 35 Jonathan Kamens 2005-07-16 22:10:21 EDT
That does not sound like the problem that this bug is about.
Comment 36 Andrew Smith 2005-07-26 02:38:41 EDT
Same problem with FC3 and FC4
Pioneer DVR-108
DVD+R
Specific FC4 kernels:
 kernel-2.6.12-1.1390_FC4.i686
 kernel-2.6.12-1.1398_FC4.i686
CPU: Athlon64 3000+, 1.5G RAM
DVD appears to burn OK but fixate time is 0.1 or 0.2 seconds.
DVD won't read anywhere (Linux or Windows)
Just using the cdrecord -fix option, later, also fails to fixate the DVD
Using 'CDBurnerXP Pro 3 Freeware' on windows, I am able to fixate the DVD
(the windows program hangs after fixating it - but it appears to be a software 
bug in the requester that allows you to fixate the DVD)
Once the DVD is fixated - it reads 100% OK under Linux and Windows
Comment 37 Andrew Smith 2005-07-26 03:02:51 EDT
Forgot to mention the obvious (there have been no FC4 updates):
cdrecord-2.01.1-9
Comment 38 Andrew Smith 2005-07-26 03:33:01 EDT
More info to suggest this needs attention:
The same command works fine with DVD-R and fixates discs correctly - I've been
using DVD-R for quite a while til I got some DVD+R a few months ago to try out
using them also - failed on FC3 (can't remember version) - now I'm at FC4 I can
report with everything up-to-date
Command is:
dvdrecord -eject -v -dao fs=6m dev=/dev/cdwriter driveropts=burnfree -speed=0
-data "$1"
(where $1 is an ISO I have created with mkisofs)
I'm not using ide-scsi
No errors are reported by dvdrecord (cdrecord) - just a VERY short fixating time
Comment 39 Andrew Smith 2005-08-06 04:18:19 EDT
More info:
Putting a blank DVD+R into the drive pops up an icon on the Desktop
that says "CD-ROM Disc"

Putting a blank DVD-R into the drive, however, correctly says "Blank DVD-R Disc"

Lastly, burning a DVD+R appears to think that it is a DVD-R as the logs says:
INFO: dvdrecord's functionality is now replaced by cdrecord
Cdrecord-Clone 2.01-dvd (i686-pc-linux-gnu) Copyright (C) 1995-2004 Jörg Schilling
Note: This version is an unofficial (modified) version with DVD support
Note: and therefore may have bugs that are not present in the original.
Note: Please send bug reports or support requests to
http://bugzilla.redhat.com/bugzilla
Note: The author of cdrecord should not be bothered with problems in this version.
TOC Type: 1 = CD-ROM
scsidev: 'ATA:1,1,0'
devname: 'ATA'
scsibus: 1 target: 1 lun: 0
Linux sg driver version: 3.5.27
Using libscg version 'schily-0.8'.
cdrecord: Warning: using inofficial libscg transport code version (schily - Red
Hat-scsi-linux-sg.c-1.83-RH '@(#)scsi-linux-sg.c        1.83 04/05/20 Copyright
1997 J. Schilling').
Driveropts: 'burnfree'
SCSI buffer size: 64512
atapi: -1
Device type    : Removable CD-ROM
Version        : 0
Response Format: 2
Capabilities   :
Vendor_info    : 'PIONEER '
Identifikation : 'DVD-RW  DVR-108 '
Revision       : '1.14'
Device seems to be: Generic mmc2 DVD-R/DVD-RW.
Current: 0x001B
Profile: 0x002B
Profile: 0x001B (current)
Profile: 0x001A
Profile: 0x0014
Profile: 0x0013
Profile: 0x0011
Profile: 0x0010
Profile: 0x000A
Profile: 0x0009
Profile: 0x0008
cdrecord: Found DVD media: using cdr_mdvd.
Using generic SCSI-3/mmc DVD-R(W) driver (mmc_mdvd).
Driver flags   : SWABAUDIO BURNFREE
Supported modes: PACKET SAO
Drive buf size : 1605632 = 1568 KB
FIFO size      : 6291456 = 6144 KB
Track 01: data  3836 MB
Total size:     4405 MB (436:29.61) = 1964221 sectors
Lout start:     4406 MB (436:31/46) = 1964221 sectors
Current Secsize: 2048
  ATIP start of lead in:  -150 (00:00/00)
  ATIP start of lead out: 157789 (35:05/64)
Disk type:    unknown dye (reserved id code)
Manuf. index: -1
Manufacturer: unknown (not in table)
Blocks total: 2295104 Blocks current: 2295104 Blocks remaining: 330883
scsi_set_streaming
Speed set to 5540 KB/s
Starting to write CD/DVD at speed   4.0 in real SAO mode for single session.
Last chance to quit, starting real write    0 seconds. Operation starts.
Waiting for reader process to fill input buffer ... input buffer ready.
trackno=0
BURN-Free is ON.
Turning BURN-Free off
BURN-Free is OFF.
cdrecord: Turning BURN-Free on
Performing OPC...
Sending CUE sheet...
cdrecord: WARNING: Drive returns wrong startsec (0) using -150
Starting new track at sector: 0
Track 01: 3836 of 3836 MB written (fifo 100%) [buf  86%]   5.5x.
Track 01: Total bytes read/written: 4022724608/4022724608 (1964221 sectors).
Writing  time:  744.813s
Average write speed   4.0x.
Min drive buffer fill was 62%
Fixating...
Fixating time:    0.202s
cdrecord: fifo had 63362 puts and 63362 gets.
cdrecord: fifo was 0 times empty and 7813 times full, min fill was 51%.
Comment 40 Andrew Smith 2005-08-06 04:34:49 EDT
Tried the dev=ATA option and that worked.

I have no idea if this helped, but I did 2 DVDs in this order: burn A, burn B,
fix A - succeeded

Probably the issue is with using dev=/dev/cdwriter with a DVD+R
(as stated before it works fine with DVD-R)


output follows:

[root@and64 ~]# cdrecord -scanbus
Cdrecord-Clone 2.01-dvd (i686-pc-linux-gnu) Copyright (C) 1995-2004 Jörg Schilling
Note: This version is an unofficial (modified) version with DVD support
Note: and therefore may have bugs that are not present in the original.
Note: Please send bug reports or support requests to
http://bugzilla.redhat.com/bugzilla
Note: The author of cdrecord should not be bothered with problems in this version.
scsidev: 'ATA'
devname: 'ATA'
scsibus: -2 target: -2 lun: -2
Linux sg driver version: 3.5.27
Using libscg version 'schily-0.8'.
cdrecord: Warning: using inofficial libscg transport code version (schily - Red
Hat-scsi-linux-sg.c-1.83-RH '@(#)scsi-linux-sg.c        1.83 04/05/20 Copyright
1997 J. Schilling').
scsibus1:
        1,0,0   100) *
        1,1,0   101) 'PIONEER ' 'DVD-RW  DVR-108 ' '1.14' Removable CD-ROM
        1,2,0   102) *
        1,3,0   103) *
        1,4,0   104) *
        1,5,0   105) *
        1,6,0   106) *
        1,7,0   107) *
[root@and64 ~]# cdrecord -v dev=ATA:1,1,0 -fix
Cdrecord-Clone 2.01-dvd (i686-pc-linux-gnu) Copyright (C) 1995-2004 Jörg Schilling
Note: This version is an unofficial (modified) version with DVD support
Note: and therefore may have bugs that are not present in the original.
Note: Please send bug reports or support requests to
http://bugzilla.redhat.com/bugzilla
Note: The author of cdrecord should not be bothered with problems in this version.
TOC Type: 1 = CD-ROM
scsidev: 'ATA:1,1,0'
devname: 'ATA'
scsibus: 1 target: 1 lun: 0
Linux sg driver version: 3.5.27
Using libscg version 'schily-0.8'.
cdrecord: Warning: using inofficial libscg transport code version (schily - Red
Hat-scsi-linux-sg.c-1.83-RH '@(#)scsi-linux-sg.c        1.83 04/05/20 Copyright
1997 J. Schilling').
SCSI buffer size: 64512
atapi: -1
Device type    : Removable CD-ROM
Version        : 0
Response Format: 2
Capabilities   :
Vendor_info    : 'PIONEER '
Identifikation : 'DVD-RW  DVR-108 '
Revision       : '1.14'
Device seems to be: Generic mmc2 DVD-R/DVD-RW.
Current: 0x001B
Profile: 0x002B
Profile: 0x001B (current)
Profile: 0x001A
Profile: 0x0014
Profile: 0x0013
Profile: 0x0011
Profile: 0x0010
Profile: 0x000A
Profile: 0x0009
Profile: 0x0008
cdrecord: Found DVD media: using cdr_mdvd.
Using generic SCSI-3/mmc DVD-R(W) driver (mmc_mdvd).
Driver flags   : SWABAUDIO BURNFREE
Supported modes: PACKET SAO
Drive buf size : 1605632 = 1568 KB
Current Secsize: 2048
  ATIP start of lead in:  -150 (00:00/00)
  ATIP start of lead out: 157789 (35:05/64)
Disk type:    unknown dye (reserved id code)
Manuf. index: -1
Manufacturer: unknown (not in table)
scsi_set_streaming
Speed set to 22160 KB/s
Starting to write CD/DVD at speed  17.0 in real TAO mode for single session.
Last chance to quit, starting real write    0 seconds. Operation starts.
trackno=1
BURN-Free is ON.
Turning BURN-Free off
BURN-Free is OFF.
Performing OPC...
Fixating...
Fixating time:   27.560s
Comment 41 xtrollo 2005-08-22 02:12:54 EDT
I have smae problem with mz DVD burner PIONEER DVR-109/A09XL (with latest
firmware 1.57). Afret burning data to DVD+R media, these data is not accessible
(readable). 

When I burn via growisofs-5.21 program tell me this error :

Close Session failed wish Sk=2h/ASC=04h/ACQ=07h:resource temporarily 
unavailable

I mean, that this error is related to closing actual session. When I fix this
session manualy (via dvdrecord dev=/dev/hdc -fix) all data are readable.

Please fix this problem with closing burned session in SAO mode

cdrecord-2.01-dvd
growisfs-5.21
Comment 42 xtrollo 2005-08-22 02:15:07 EDT
I have smae problem with mz DVD burner PIONEER DVR-109/A09XL (with latest
firmware 1.57). Afret burning data to DVD+R media, these data is not accessible
(readable). 

When I burn via growisofs-5.21 program tell me this error :

Close Session failed wish Sk=2h/ASC=04h/ACQ=07h:resource temporarily 
unavailable

I mean, that this error is related to closing actual session. When I fix this
session manualy (via dvdrecord dev=/dev/hdc -fix) all data are readable.

Please fix this problem with closing burned session in SAO mode

cdrecord-2.01-dvd
growisfs-5.21

Configuration :

Fedora Core 4 (base installation)
cdrecord-2.01-dvd
growisfs-5.21
DVD Burner : Pioneer DVR-109/A09XL (firmware 1.57)
Comment 43 Harald Hoyer 2005-08-25 08:21:36 EDT
*** Bug 166322 has been marked as a duplicate of this bug. ***
Comment 44 Phil O'Neill 2005-08-26 12:41:49 EDT
It seems that cdrecord for EL4 does not have the +R drivers

cdrecord driver=help
Driver types:
mmc_cd_dvd          generic SCSI-3/mmc   CD/DVD driver (checks media)
mmc_cdr             generic SCSI-3/mmc   CD-R/CD-RW driver
mmc_mdvd            generic SCSI-3/mmc DVD-R(W) driver
mmc_cdr_sony        generic SCSI-3/mmc   CD-R/CD-RW driver (Sony 928 variant)
mmc_cd              generic SCSI-3/mmc   CD-ROM driver
scsi2_cd            generic SCSI-2       CD-ROM driver
philips_cdd521_old  driver for Philips old CDD-521
philips_dumb        driver for Philips CDD-521 with pessimistic assumptions
philips_cdd521      driver for Philips CDD-521
philips_cdd522      driver for Philips CDD-522
tyuden_ew50         driver for Taiyo Yuden EW-50
kodak_pcd_600       driver for Kodak PCD-600
pioneer_dws114x     driver for Pioneer DW-S114X
plasmon_rf4100      driver for Plasmon RF 4100
yamaha_cdr100       driver for Yamaha CDR-100 / CDR-102
ricoh_ro1060c       driver for Ricoh RO-1060C
ricoh_ro1420c       driver for Ricoh RO-1420C
sony_cdu924         driver for Sony CDU-924 / CDU-948
teac_cdr50          driver for Teac CD-R50S, Teac CD-R55S, JVC XR-W2010,
Pinnacle RCD-5020
cw_7501             driver for Matsushita/Panasonic CW-7501
cdr_simul           simulation CD-R driver for timing/speed tests
dvd_simul           simulation DVD-R driver for timing/speed tests


None of the document plus drivers are available.

Is this correct or did I miss something?

phil
Comment 45 Aleksandar Milivojevic 2005-08-26 16:31:19 EDT
Regarding the comment #40.  Running cdrecord -fix doesn't work always.  It
doesn't work with my USB DVD burner (Sony DRU-710A), for example.

I'm simply getting:
# cdrecord -v dev=3,0,0 -fix
Cdrecord-Clone 2.01-dvd (i686-pc-linux-gnu) Copyright (C) 1995-2004
J\uffff\uffffrg Schilling
Note: This version is an unofficial (modified) version with DVD support
Note: and therefore may have bugs that are not present in the original.
Note: Please send bug reports or support requests to
http://bugzilla.redhat.com/bugzilla
Note: The author of cdrecord should not be bothered with problems in this version.
TOC Type: 1 = CD-ROM
scsidev: '3,0,0'
scsibus: 3 target: 0 lun: 0
Linux sg driver version: 3.5.27
Using libscg version 'schily-0.8'.
cdrecord: Warning: using inofficial libscg transport code version (schily - Red
Hat-scsi-linux-sg.c-1.83-RH '@(#)scsi-linux-sg.c        1.83 04/05/20 Copyright
1997 J. Schilling').
SCSI buffer size: 64512
atapi: 1
Device type    : Removable CD-ROM
Version        : 2
Response Format: 2
Capabilities   :
Vendor_info    : 'SONY    '
Identifikation : 'DVD RW DRU-710A '
Revision       : 'BYX3'
Device seems to be: Generic mmc2 DVD-R/DVD-RW.
Current: 0x001B
Profile: 0x002B
Profile: 0x001B (current)
Profile: 0x001A
Profile: 0x0014
Profile: 0x0013
Profile: 0x0011
Profile: 0x0010
Profile: 0x000A
Profile: 0x0009
Profile: 0x0008
cdrecord: Found DVD media: using cdr_mdvd.
Using generic SCSI-3/mmc DVD-R(W) driver (mmc_mdvd).
Driver flags   : SWABAUDIO BURNFREE
Supported modes: PACKET SAO
Drive buf size : 1602048 = 1564 KB
Current Secsize: 2048
  ATIP start of lead out: 157789 (35:05/64)
scsi_set_streaming
Speed set to 11080 KB/s
Starting to write CD/DVD at speed   8.0 in real TAO mode for single session.
Last chance to quit, starting real write    0 seconds. Operation starts.
trackno=1
BURN-Free is OFF.
BURN-Free is OFF.
cdrecord: Input/output error. reserve track: scsi sendcmd: no error
CDB:  53 00 00 00 00 00 00 00 00 00
status: 0x2 (CHECK CONDITION)
Sense Bytes: 70 00 05 00 00 00 00 0A 00 00 00 00 24 00 00 00
Sense Key: 0x5 Illegal Request, Segment 0
Sense Code: 0x24 Qual 0x00 (invalid field in cdb) Fru 0x0
Sense flags: Blk 0 (not valid)
cmd finished after 0.001s timeout 40s
cdrecord: Cannot open new session.
Comment 46 clive darra 2006-03-03 17:02:28 EST
i can't burn any DVDs on RHEL4 either !
Comment 47 Tomasz Ostrowski 2006-03-22 10:01:34 EST
Same here:
Drive: LG SuperMulti GSA-4167B
DVD+R: Emtec 8x
After burning with
# cdrecord -v -sao -pad -eject -data FC-5-i386-DVD.iso
fixating time was very short, DVD didn't mount.
# cdrecord -fix didn't help

I've upgraded to cdrecord-2.01.01.0.a03-3 from FC5 and it didn't work either.

AFter that I've upgraded drive firmware (had to install XP to do this...) and
then tried
# growisofs -dvd-compat -Z /dev/dvd=FC-5-i386-DVD.iso
and it worked fine (just found that growisofs can also burn ISO images - so
there's no need for using cdrecord on DVD).

I don't want to brake another DVD so I don't know if firmware upgrade helped or
was it thanks to growisofs.
Comment 48 clive darra 2006-03-25 02:12:29 EST
It's started working ! Using 2.6.9-22.EL and dvd+rw-tools-5.21.4.10.8-4
Comment 49 Pavel Polischouk 2006-10-05 13:01:53 EDT
The new version of cdrecord from "FC5 updates testing" fixes the problem:

cdrecord-2.01.01.0.a10-0.FC5.1

This version can also be used to -fix the coasters produced by the bug.

The previous released version in FC5 (2.01.01.0.a03-3) still has it. 

Looking at the code, the new "a10" version seems to completely separate the +r
and +rw drivers into their own code paths, and now fixating in +r mode works
properly.
Comment 50 Aleksandar Milivojevic 2006-10-06 09:34:59 EDT
Ah finally.  Hopefully there'll be backport of the fix to RHEL 3 and 4 too (that
also suffer from this bug).
Comment 51 Andrea V. 2007-01-21 10:49:22 EST
I'm having this problem too. I'm trying to burn a DVD+R on my system:

Fedora Core 6 (development) - i686 - P4 3.0 Ghz - PIONEER DVR-107D 1.22

it seems to me that cdrecord hasn't the driver support for DVD+R, anyway if I
burn the same iso image on a DVD+RW it works correctly and I can read the DVD+RW
What I am missing?

Thanks, Andrea V.
Comment 52 Andrea V. 2007-01-22 04:08:11 EST
I contacted the developer list of cdrecord, here's what they told me:

You need to tell the Fedora people that they are years behind actuality.
ftp://ftp.berlios.de/pub/cdrecord/alpha/
Here is a recent source, I cannot help if Fedora is not up to date......

I hope that this will help fedora developers to solve the problem.

Andrea V.
Comment 53 Harald Hoyer 2007-01-22 09:29:03 EST
the problem is:
1. Pioneer needs some special SG_IO commands, which are only allowed as root
2. cdrecord/cdrtools has changed its license and should be dropped anyway, as
soon as there is an alternative.
Comment 54 Matthew Miller 2007-04-10 15:36:44 EDT
Fedora Core 4 is now completely unmaintained. These bugs can't be fixed in that
version. If the issue still persists in current Fedora Core, please reopen.
Thank you, and sorry about this.
Comment 55 Aleksandar Milivojevic 2007-04-10 16:51:00 EDT
The bug is also present in RHEL4.  This bug should be reopened.  Possibly
changed to point to RHEL4 instead.  The fix could be as simple as backporting
cdrecord from FC5 (where the bug was fixed, as reported in comment #49 and
comment #50) to RHEL4.
Comment 56 Matthew Miller 2007-04-10 17:07:47 EDT
okay then. :)
Comment 61 Harald Hoyer 2009-01-23 12:53:28 EST
The DVD+R/DVD+RW code will be removed from cdrecord and replaced with this hint:

Please use growisofs from dvd+rw-tools or cdrecord-Pro for DVD+R/DVD+RW.
Comment 64 Jörg Schilling 2009-02-10 08:28:53 EST
The reason why there is a problem is that these people did not
run cdrecord but a defective fork.

The original software of course supports to write DVD media.

see ftp://ftp.berlios.de/pub/cdrecord/alpha/
Comment 67 errata-xmlrpc 2009-05-18 16:29:27 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2009-1007.html

Note You need to log in before you can comment on or make changes to this bug.