Bug 136732 - Mouse/keyboard both dead with smp kernel
Mouse/keyboard both dead with smp kernel
Status: CLOSED DUPLICATE of bug 123535
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
3
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Jones
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-10-21 19:07 EDT by David Chambers
Modified: 2015-01-04 17:11 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 14:06:32 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description David Chambers 2004-10-21 19:07:42 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8a4)
Gecko/20041017

Description of problem:
Keyboard and mouse are both "dead" upon completion of boot.  Kudzu
complains that keyboard has been removed.  Machine is alive and I can
log in via ssh.  "/sbin/shutdown -r now" hangs after "Restarting System"

Booting with "acpi-off" does not fix the problem.

UP kernel works as expected.



Version-Release number of selected component (if applicable):
kernel-smp-2.6.9-1.639

How reproducible:
Always

Steps to Reproduce:
1. Install
2. Boot smp kernel
3.
    

Actual Results:  Keyboard and mouse are both dead after boot
completes.  Kudzu can't find keyboard and offers to remove it.  Typing
various keys results in random movements of mouse cursor on graphical
boot screen.  Mouse completely dead, no lights on (MS optical mouse),
unresponsive.

Expected Results:  Keyboard & mouse should work.

Additional info:

Systems (2 different ones) are both Tyan S2665 motherboard with i7505
chipset and dual Xeon (2.4 GHz stepping 9) processors.  Hyperthreading
is enabled.  I can reproduce the problem on an older board if I enable
legacy USB support in the BIOS.  Unfortunately the newer CPUs want a
newer BIOS revision to satisfy microcode requirements and the new
BIOSes do not have the option to disable legacy USB support.

I see the following messages from i8042.c in the output of "dmesg":

"Failed to disable AUX port, but continuing anyway... Is this a SiS?"
"If AUX port is really absent please use the 'i8042.naoux' option"

After completion of boot, /proc/interrupts does not show anything
assigned to i8042 (expect 1 and 12).

I recompiled the kernel after activating Alan Cox's i8042 patch but
the keyboard/mouse are still dead.  I also tried explicitly calling
i8042_spank_usb() after the "AUX port" messages and the reboot problem
is gone but the mouse and keboard are still dead.  Adding printk's
throughout the spank_usb() function seems to imply that it never finds
anything to disable (comes out with addr=0 and i==PCI_ROM_RESOURCE)

Compiling the kernel with voluntary preempt disabled has no effect either.
Comment 1 Edward Simmonds 2004-11-24 12:29:50 EST
I've had this same problem since Fedora Core 2.  SMP kernel doesn't
see mouse or keyboard, UP kernel does.
Comment 2 David Chambers 2005-01-24 14:12:46 EST
Booting with kernel option "usb-handoff" (in 2.6.9 and up, I think)
fixes the problem.  2.6.10-741-smp definitely works on my systems
provided the "usb-handoff" option is given at boot time.

*** This bug has been marked as a duplicate of 123535 ***
Comment 3 Adam 2005-02-22 12:46:29 EST
How do I add this "usb-handoff" option?  Where do I place this
statement? In Grub?
Comment 4 Red Hat Bugzilla 2006-02-21 14:06:32 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.