Bug 123535 - Intel E750x PS2 Keyboard stopped working after upgrade to fedora 2
Intel E750x PS2 Keyboard stopped working after upgrade to fedora 2
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
2
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Jones
:
: 121481 123600 136732 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-05-19 02:31 EDT by Stephen Moore
Modified: 2015-01-04 17:06 EST (History)
14 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-04-16 01:26:41 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Stephen Moore 2004-05-19 02:31:59 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6) Gecko/20040510

Description of problem:
I have a logitech cordless keyboard and mouse. The keyboard (and I
believe the mouse also) do not work in Fedora Core 2. They worked in
Fedora Core 1

The Keyboard/mouse plug into the PS2 ports of the computer which is a
Inter 7505 Motherboard with dual xeon processors.

I swaped the kb/mouse, this had no effect.

I have plugged kb/mouse in the usb port and this works (mostly) but
has some wierd side effects.

The following Console messages appear

psmouse.c: Mouse at isa0060/serio0/input0 lost synchronization,
throwing 2 bytes away.
psmouse.c: Mouse at isa0060/serio0/input0 lost synchronization,
throwing 2 bytes away.
psmouse.c: Mouse at isa0060/serio0/input0 lost synchronization,
throwing 2 bytes away.
psmouse.c: Mouse at isa0060/serio0/input0 lost synchronization,
throwing 1 bytes away.
psmouse.c: Mouse at isa0060/serio0/input0 lost synchronization,
throwing 2 bytes away.
psmouse.c: Mouse at isa0060/serio0/input0 lost synchronization,
throwing 2 bytes away.



Version-Release number of selected component (if applicable):
kernel-smp-2.6.5-1.358

How reproducible:
Always

Steps to Reproduce:
1.Turn computer on
2.try to log on
3.
    

Actual Results:  system ignores keyboard

Additional info:
Comment 1 travis abbott 2004-05-19 19:38:34 EDT
I experienced the same problem with the 2.6.5smp kernel that came with
FC2 on the Intel 7505 chipset (HP xw8000 workstations). The single
processor kernel seemed to work ok. After a bit of playing around, I
was able to compile a working 2.6.5smp kernel with PAE (>4GB memory
support) disabled (from make menuconfig, Processor type and features
-> High Memory Support -> off). I checked to make sure this feature
was properly enabled in the BIOS, and still no luck. I found out there
were some BIOS updates for these HP machines and took them from
Phoenix BIOS version JQ.W1.03US to JQ.W1.13US, and that solved the
problem. If you don't need the PAE support, try compiling your kernel
with it disabled, and if you do, look for some BIOS updates.
Comment 2 Dave Jones 2004-05-19 20:13:21 EDT
*** Bug 123600 has been marked as a duplicate of this bug. ***
Comment 3 Stephen Moore 2004-05-20 01:50:01 EDT
I downloaded linux-2.6.6 compiled using the fedora smp config file and
the ps2 mouse and keyboard still don't work! bugger!

I updated the bios to 1.08 to no avail also. I realise that this is
not the right forum but I am getting lots of acpi cpu errors as well. 

Life is not happy in xeon land right now :-)
Comment 4 Jesse Keating 2004-05-20 19:25:56 EDT
I can duplicate this issue as well, supermicro E7501 based motherboards.
Comment 5 Lee Woodcock 2004-05-23 17:06:02 EDT
I have the following motherboard (in a micron workstation)...

       product: SE7505VB2 Board
       vendor: Intel Corporation

and I tried flashing the bios to go from 1.07 to 1.08 and this did not
fix the problem. When I boot into the smp kernel I get the following
error....

ACPI: S2 and PAE do not like each other for now, S3 disabled
audit :(1085319714.886:0) initialized

I am not sure if this has something to do with the problem or not, but
I really hope that this gets fixed soon as we have an entire lab ful
of dual Xeons and we cannot upgrade to FC 2. :-(
Comment 6 Jesse Keating 2004-05-24 14:24:37 EDT
Can we get a higher priority on this bug?  SMP Xeons are pretty much
unusable with this kernel.
Comment 7 Colin Adams 2004-05-27 01:52:52 EDT
I have the Intel E7505 chipset (IWILL DPL533 motherboard).
I have version 1.26 of their BIOS installed (Phoenix BIOS).
On their web site, version 1.28 is available for download. This is
Award BIOS (Not phoenix).
Is it worth me trying to upgrade to this BIOS? If so, how do I do it?
(I've no idea how to upgrade a motherboard BIOS).
Comment 8 john.l.villalovos 2004-05-27 19:30:47 EDT
I have the same issue on my Intel Dual Xeon box with Hyperthreading. 
So it appears as four processors.  Works fine with the UP kernel.
Comment 9 Chris Knapp 2004-05-30 20:38:02 EDT
I have a similar problem.  I'm running a Tyan Tiger MPX with dual
Althon MP (2200+).  Boot is normal with the SMP kernel, except that I
also get the following error:

ACPI: S2 and PAE do not like each other for now, S3 disabled
audit :(1085319714.886:0) initialized

Aside from that, the keyboard works fine for a while, but then it
stops working after a time, usually I'll notice that it has been
"lost" the next day.  A restart fixes the problem.

CK
Comment 10 Colin Adams 2004-06-01 16:02:27 EDT
Can we have a comment on the likelyhood of this problem being solved
soon, please?
I have to make a decision as to whether or not to take my box back to FC1.
Comment 11 Arjan van de Ven 2004-06-01 16:03:58 EDT
I can recommend looking at the kernel in
http://people.redhat.com/arjanv/2.6/
it has a whole slew of fixes including acpi and keyboard fixes.
(and is the planned kernel for an update shortly)
Comment 12 Lee Woodcock 2004-06-01 20:49:06 EDT
I upgraded to the kernel-smp-2.6.6-1.406.i686.rpm in the directory
listed above and I still get the ACPI error and the keyboard still is
not functional at boot time (or any other time for that matter).
Again, this is for a dual 3.06GHz Xeon with an intel motherboard (see
comment #5).

I'll be honest. I am not too far from giving up on fedora core 2! 
Comment 13 Colin Adams 2004-06-02 01:36:16 EDT
I tried to upgrade to this kernel.
When I do an rpm -iFvh on it (or first do an rpm -e kernel-smp and
then an rpm -i), I get the message:

All of your loopback devices are in use.
mkinitrd failed.

and the smp-kernel entry has been removed from grub.conf

How do I get round this?
Comment 14 Colin Adams 2004-06-02 03:27:17 EDT
OK, I worked out I had to dismount my Fedora ISO images to get
loopback devices back.
Then booting with the kernel-smp-2.6.6-1.406.i686.rpm kernel,
I again get the message:
ACPI: S2 and PAE do not like each other for now, S3 disabled
(I also got another error message, but I did not have time to note it
down - I shall try and look for it again some time soon).
Once again, no keyboard input is accepted at all (and pressing keys
such as Caps Lock does not toggle an LED).
I tried booting again with the noacpi, but this made no difference
(except I did not see the second error message).
Comment 15 Colin Adams 2004-06-02 03:33:45 EDT
The additional error message was:
i8042.c: Can't read CTR while initializing i8042.

This sounds significant to me. I hope it sheds some light on the problem.
Comment 16 Jesse Keating 2004-06-07 11:57:19 EDT
Arjan, I tested your kernel on Friday, the 4th.  Still not working,
however the messages that I was getting on console when I'd touch the
keyboard did go away, the keyboard just fails silently now.

I have to wonder if this is somehow related to the problems we saw on
2.4 kernels with PAE enabled, in that keyboards would not work until
after kudzu had ran.  If kudzu was disabled, keyboards would fail
silently when touched.  During the boot up though you'd see messages
such as "pc_kbd jammed" or something similar.  Other distributions,
such as Debian, would never work as they don't run Kudzu, so something
Kudzu was doing (RHL 7.3-9 days) was making the keyboard work once
again.  Perhaps this is a related thing?
Comment 17 Sammy 2004-06-08 12:00:22 EDT
I have reported this problem prior to release of Fedora Core 2 a number 
of times. The way to FIX it is to recompile the kernels from fedora using 
the same config file EXCEPT compile ehci-hcd, ohci-hcd, and uhci-hcd 
into the kernel directly and not as a module. This works for smp as well. 
 
Comment 18 Colin Adams 2004-06-08 12:59:49 EDT
So how do you go about doing this recompile? I assume the first step
is to install the source rpm. But then what?
Comment 19 Colin Adams 2004-06-09 03:58:37 EDT
Sammy's fix works.
I did the following - I installed kernel-sourcecode 2.6.6.-1.422 from
Arjan's directory.
I then copied /usr/src/redhat/SOURCES/kernel-2.6.5-i686-smp.config
to /usr/src/linux.config, and did a make oldconfig.
I then did a make menuconfig and selected Y for the three options
Sammy suggested.
I then did a make followed by a make modules_install install and
re-booted.
A couple of failure messages cam up at boot time about not being able
to find modules (not surprising as they are now within the kernel),
but everything seems to work OK (including my USB mouse and USB ADSL
modem).
But I assume the redhat patches are not applied to this kernel (am I
wrong Aajan? - I hope so).
Would it be possible to have a kernel-smp rpm with these three options
compiled into the kernel?
Comment 20 Arjan van de Ven 2004-06-09 04:24:29 EDT
kernel-sourcecode has all the patches applied.

building USB into the kernel sounds an interesting experiment that
deserves some testing for sure (it might solve a bunch of other things
as well), but it sure needs to be tested widely because it has the
potential to break a lot of other stuff too ;)
Comment 21 Sammy 2004-06-09 09:02:13 EDT
If you use the arjanv sourcecode than the redhat patches should be 
all applied. 
Comment 22 Christopher Fraser 2004-06-09 10:29:12 EDT
I've experienced a similar where my standard PS2 keyboard dpesn't
work.  I have a Microsoft optical wheel mouse attached to the USB
port.  My machine is a dual Xeon Dell Precision 530.  I get the "ACPI:
S2 and PAE do not like each other for now, S3 disabled" and "i8042.c:
Can't read CTR while initializing i8042" messages.
Comment 23 Jesse Keating 2004-06-09 10:38:11 EDT
In reply to comment #20, Arjan, isn't that what Fedora is for? 
Getting many many people to test interesting experiments?  </sarcasm>
Comment 24 Colin Adams 2004-06-12 02:22:12 EDT
Kernel-smp 427 just arrived on my system via yum.
Would I be right to assume that this kernel does NOT have the fix in it
(compiling USB 2 support into the kernel)?
My system state now looks to be very strange. If I do an rpm -q
kernel-smp, then I see two entries:
kernel-smp-2.6.6-1.422
kernel-smp-2.6.6-1.427
And if I do an rpm -q kernel, I see:
kernel-2.6.5-1.358
kernel-2.6.6-1.427
In addition, my grub.conf shows entries for:
title Fedora Core (2.6.6-1.422custom)
title Fedora Core (2.6.6-1.422smp)
title Fedora Core-up (2.6.5-1.358)

(the first one is a result of my applying the fix to get a working
SMP system).
I presume it is best for me to upgrade to 427. Should I go about
adding the fix the same way (via kernel-sourcecode)? And what should I
do about the non-custom grub entries, and the duplicates in the rpm
database?
Comment 25 Jesse Keating 2004-06-27 15:44:58 EDT
I can confirm that disabling USB-Legacy support makes this problem go
away.  I've duplicated this on 3 systems thus far, if USB-Legacy
support is disabled in bios, there is no problem at all.
Comment 26 Alan Cox 2004-07-12 10:18:09 EDT
*** Bug 121481 has been marked as a duplicate of this bug. ***
Comment 27 Habig, Alec 2004-07-20 16:12:24 EDT
I can confirm this problem still exists in kernel 2.6.6-1.435.2.3smp,
and that disabling USB legacy support in the BIOS makes the problem go
away.

Although the kernel still complains:

  ACPI: S3 and PAE do not like each other for now, S3 disabled.
Comment 28 Arjan van de Ven 2004-07-29 05:23:05 EDT
the 499 kernel at http://people.redhat.com/arjanv/2.6/ has a
workaround for the 750x SMM bios bug; please test.
Comment 29 Jesse Keating 2004-08-09 19:55:52 EDT
So I just tried the 509 kernel from people.redhat.com, and this does
not work.  I still get a kernel panic upon boot if USB Legacy support
is enabled and I boot an SMP kernel.  Whats more, it seems that all
USB devices cause messages to show up on the console when they are
inserted.  Something about 'something bad has happened, very bad'.  No
USB device is usable on these boards (X5DPE-G2).
Comment 30 Keith Hunt 2004-08-11 17:19:33 EDT
Another "me too".  I am running a Dell dual Xeon box. With both SMP
kernel 358 and 494, neither the standard PS/2 mouse or keyboard work
at all.  The UP kernels seem to be fine.
Comment 31 Robert Kuehn 2004-08-12 05:01:02 EDT
Yes, I can confirm. Still the same problem(Comment#29) with Dual Xeon
(Board: Tyan Thunder S2665 / E7505 / BIOS v1.14 / USB Mouse and PS2
Keyboard) and SMP kernel 358, 494, 506, 509. Kernel option "ACPI=off".
Unfortunately there is no option for disabling USB legacy in the
Phoenix bios. UP kernel 358 works fine!
Comment 32 Freddy VOLVERT 2004-10-21 05:31:04 EDT
I can confirm keyboard problems with kernel 2.6.5-1.358smp on my TYAN 
dual Xeon (i7505),and that disabling USB legacy support in the BIOS 
makes the problem go away.
Comment 33 john.l.villalovos 2004-10-21 16:50:47 EDT
I also see this happen on a Dell Dimension 4550.  This is a single P4
with HT.

I disabled USB and it worked.

Is anyone going to fix this?
Comment 34 Colin Adams 2004-11-20 14:28:04 EST
I've just upgraded to FC3 - and I'm disappointed to see this bug is
still present in the 2.6.9 kernel shipped with it.
So I guess I have to recompile a custom kernel again.
I assume that means I shall have to disable the automatic selection of
upgraded kernels as the GRUB default kernel.
Anyway, with FC3, how do I go about building a custom kernel, now that
the kernel-source package is removed?
Comment 35 Jesse Keating 2004-12-08 01:01:17 EST
Colin: Have you disabled USB Legacy support in bios?
Comment 36 Colin Adams 2004-12-08 02:32:15 EST
No. The Phoenix BIOS does not have such an option.
Comment 37 Colin Adams 2004-12-08 02:35:16 EST
P.S. I worked out how to re-compile the kernel with FC3.
But this is not a great solution, as it means I cannot have my kernel
updated automatically.
Comment 38 David Chambers 2005-01-24 14:13:04 EST
*** Bug 136732 has been marked as a duplicate of this bug. ***
Comment 39 Gene Czarcinski 2005-01-27 18:32:31 EST
The recommendation in
https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=136732 to use a
2.6.10 kernel and specify usb-handoff worked!  I now have keyboard and
mouse running the smp kernel.
Comment 40 Dave Jones 2005-04-16 01:26:41 EDT
Fedora Core 2 has now reached end of life, and no further updates will be
provided by Red Hat.  The Fedora legacy project will be producing further kernel
updates for security problems only.

If this bug has not been fixed in the latest Fedora Core 2 update kernel, please
try to reproduce it under Fedora Core 3, and reopen if necessary, changing the
product version accordingly.

Thank you.

Note You need to log in before you can comment on or make changes to this bug.