Bug 136746 - kernel-2.6.9 switchroot: mount failed: 22
kernel-2.6.9 switchroot: mount failed: 22
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
3
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Jones
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-10-21 22:11 EDT by rtoledo
Modified: 2015-01-04 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-10-23 07:46:12 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description rtoledo 2004-10-21 22:11:40 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; rv:1.7.3) Gecko/20041016
Firefox/0.10.1

Description of problem:
kernel-2.6.9 switchroot: mount failed: 22

umount /initrd/dev failed: 2

kernel panic-not syncing: attempting to kill init!

I followed the instructions at
http://www.mjmwired.net/resources/mjm-notes-fc2.shtml

and have gone thru the oldconfig  using make xconfig several times
have unchecked several items I do not use such as ISDN media dvb

I looked thru bugzilla to bug #129667 and 129120, also bugzilla says 
I do not have access to bug # 102734 so I;m not sure what it says, but
129667 seems somewhat similar but exact.

Version-Release number of selected component (if applicable):
kernel-2.6.9 

How reproducible:
Always

Steps to Reproduce:
1.donwload from kernel.org install, compile using oldconfig
from 2.6.8-1.624smp  
2.follow instaructions at
http://www.mjmwired.net/resources/mjm-notes-fc2.shtml
3.reboot
    

Actual Results:  kernel fails to boot

Expected Results:  to boot up

Additional info:

I've done several compilations on the gentoo partition and I'm gaining
more experience, but not sure if I'm missing something simple here.
Comment 1 Pekka Pietikäinen 2004-10-23 07:46:12 EDT
Hiya

fc3 pretty much requires an initrd due to the use of udev.
You should be able to use /sbin/mkinitrd /boot/initrd-<yourkernelver>
<yourkernelver> and add a suitable entry in your grub.conf.

In any case, when using custom kernels other forums
(fedora-list@redhat.com, #fedora on freenode perhaps) are more
appropriate, as this certainly isn't a bug in the fedora kernel.
Comment 2 rtoledo 2004-10-24 11:05:47 EDT
thank you. I was not aware of udev and it's requirement of initrd.

I'm now running fine after your advice and able to mount my ntfs
partitions.

thanks again

Note You need to log in before you can comment on or make changes to this bug.