Bug 136766 - Block device node not created for Zip drive
Summary: Block device node not created for Zip drive
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: udev   
(Show other bugs)
Version: rawhide
Hardware: i686
OS: Linux
medium
high
Target Milestone: ---
Assignee: Harald Hoyer
QA Contact: Brian Brock
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-10-22 08:45 UTC by Tony Tsui
Modified: 2007-11-30 22:10 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-12-07 11:19:15 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
dmesg output (15.44 KB, text/plain)
2004-10-28 12:28 UTC, Tony Tsui
no flags Details

Description Tony Tsui 2004-10-22 08:45:47 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.3)
Gecko/20041020 Epiphany/1.4.4

Description of problem:
The block device node for my internal Zip drive is not created unless
there is a Zip disk inserted when FC3 booted. The device node should
be /dev/hdc. The fix from bug 134846 does not fix this problem.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Boot without a Zip disk inserted in the drive.
2. ls /dev/hdc*
    

Actual Results:  ls: /dev/hdc*: No such file or directory

Expected Results:  /dev/hdc

Additional info:

Inserting a Zip disk after boot does not create the device node either.

Comment 1 Harald Hoyer 2004-10-22 09:13:14 UTC
the kernel should provide /dev/hdc like it does for cdroms without a
medium inserted...

Comment 2 Dave Jones 2004-10-27 03:32:04 UTC
can you show us the output of dmesg please ?


Comment 3 Tony Tsui 2004-10-28 12:28:53 UTC
Created attachment 105888 [details]
dmesg output

Sorry for taking so long. Here is the dmesg output.

Comment 4 Dave Jones 2004-11-27 21:21:49 UTC
hdc: No disk in drive
hdc: 98304kB, 96/64/32 CHS, 4096 kBps, 512 sector size, 2941 rpm

The kernel obviously does know its hdc, so this looks like a userspace bug to me.

DavidZ was playing with IDE ZIP drives last week, so its possible there needs to
be some interaction between hal & udev.

Comment 5 David Zeuthen 2004-11-28 17:14:37 UTC
This looks like a dupe of bug 139939 - Tony, can you confirm that this line 

 KERNEL="hd[a-z]", BUS="ide", SYSFS{removable}="1",
PROGRAM="/etc/udev/scripts/ide-media.sh %k", RESULT="floppy", SYMLINK="floppy%e

in /etc/udev/rules/50-udev.rules is missing the trailing " character?

Comment 6 Tony Tsui 2004-12-07 11:19:15 UTC
Hi,

Yes the trailing " character was mission. Anyway the latest updates
seem to have fixed this problem. Thanks.

Tony


Note You need to log in before you can comment on or make changes to this bug.