Bug 136784 - Text files, .pl files not opening with default text editor
Summary: Text files, .pl files not opening with default text editor
Keywords:
Status: CLOSED UPSTREAM
Alias: None
Product: Fedora
Classification: Fedora
Component: gnome-vfs
Version: 3
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Marco Pesenti Gritti
QA Contact:
URL:
Whiteboard:
: 137295 (view as bug list)
Depends On:
Blocks: FC4Target
TreeView+ depends on / blocked
 
Reported: 2004-10-22 11:45 UTC by Need Real Name
Modified: 2007-11-30 22:10 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-01-12 12:56:14 UTC
Type: ---


Attachments (Terms of Use)

Description Need Real Name 2004-10-22 11:45:50 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.3)
Gecko/20041020 Epiphany/1.4.4

Description of problem:
File-roller should use the Gnome default text editor when an item in
an archive is double-clicked.

Currently it launched emacs.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
x

Additional info:

Comment 1 Marco Pesenti Gritti 2004-10-28 10:02:39 UTC
Works for me on rawhide (file-roller is 2.8.1). If you can still
reproduce please reopen and specify:

- What editor is used to open the file, what is your default text
editor and how you configured it
- What nautilus does on the same (unarchived) file

Comment 2 Need Real Name 2004-10-28 10:09:46 UTC
If the file is a perl script, with the extension .pl, emacs opens.

My default text editor (in gnome) is gedit.

If a "proper" editor is going to be opened rather than a simple text
editor, maybe there should be a preference for that.

Comment 3 Need Real Name 2004-10-28 10:10:55 UTC
Do you want this reassinged to gnome, or to the preferred-apps program?

Comment 4 Need Real Name 2004-10-28 12:21:25 UTC
Following this link using epiphany also opens emacs:
 http://www.openoffice.org/nonav/issues/showattachment.cgi/18719/ooffice-crash

The content type is text/txt.

Comment 5 Need Real Name 2004-10-29 08:12:49 UTC
*** Bug 137295 has been marked as a duplicate of this bug. ***

Comment 6 Marco Pesenti Gritti 2004-10-29 10:23:50 UTC
The problem with perl files is user interface unintuitiveness ihmo.
The Text Editor tab in preferred applications is confusing. You can
use nautilus properties to change the editor for perl files.

I'm confused about the issue with epiphany. Unless you have text/txt
handler set, it should just use the text/plain handler which is the
one that open normal text files in nautilus (so gedit for you). Could
you test that with a clean user please ?

Comment 7 Marco Pesenti Gritti 2004-10-29 10:26:09 UTC
This is about the user interface problem:

http://bugzilla.gnome.org/show_bug.cgi?id=155612

Comment 8 Need Real Name 2004-10-29 10:41:08 UTC
Tested with a new user. Same problem.

Also a new problem- using the new account, clicking the web browser icon tried
to install firefox, which isn't installed. Euck.

Comment 9 Marco Pesenti Gritti 2004-10-29 12:21:13 UTC
Ok, this is a bit of a pain. I think the correct fix is to add an
alias to shared-mime but first we need to improve gnome-vfs alias support.

Comment 10 Need Real Name 2004-11-02 16:35:52 UTC
application/rtf opens with emacs too. Nice!

Comment 11 Matthias Clasen 2004-11-11 13:00:46 UTC
Marco, the upstream xdgmime sources provide alias subclass information
now, you should get that for free when you update the xdgmime in gnome-vfs

Comment 12 Marco Pesenti Gritti 2005-01-12 12:56:14 UTC
I think this is all fixed upstream. It required large changes,
included API, so I dont think we can release updates to fix it.


Note You need to log in before you can comment on or make changes to this bug.