Bug 1368012 - gluster fails to propagate permissions on the root of a gluster export when adding bricks
Summary: gluster fails to propagate permissions on the root of a gluster export when a...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: distribute
Version: mainline
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Susant Kumar Palai
QA Contact:
URL: dht-file-permission triaged
Whiteboard:
Depends On: 1082671 1294035
Blocks: 1286204 1374573
TreeView+ depends on / blocked
 
Reported: 2016-08-18 06:28 UTC by Susant Kumar Palai
Modified: 2017-03-06 17:22 UTC (History)
14 users (show)

Fixed In Version: glusterfs-3.10.0
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 1294035
: 1374573 (view as bug list)
Environment:
Last Closed: 2017-03-06 17:22:51 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Comment 1 Vijay Bellur 2016-08-18 07:28:54 UTC
REVIEW: http://review.gluster.org/15195 (cluster/dht: heal root permission post add-brick) posted (#1) for review on master by Susant Palai (spalai@redhat.com)

Comment 2 Worker Ant 2016-08-25 04:21:56 UTC
REVIEW: http://review.gluster.org/15195 (cluster/dht: heal root permission post add-brick) posted (#2) for review on master by Susant Palai (spalai@redhat.com)

Comment 3 Worker Ant 2016-09-06 06:59:20 UTC
REVIEW: http://review.gluster.org/15195 (cluster/dht: heal root permission post add-brick) posted (#3) for review on master by Atin Mukherjee (amukherj@redhat.com)

Comment 4 Worker Ant 2016-09-06 07:05:38 UTC
REVIEW: http://review.gluster.org/15195 (cluster/dht: heal root permission post add-brick) posted (#4) for review on master by Susant Palai (spalai@redhat.com)

Comment 5 Worker Ant 2016-09-06 12:59:46 UTC
REVIEW: http://review.gluster.org/15195 (cluster/dht: heal root permission post add-brick) posted (#5) for review on master by Susant Palai (spalai@redhat.com)

Comment 6 Worker Ant 2016-09-09 06:14:31 UTC
REVIEW: http://review.gluster.org/15195 (cluster/dht: heal root permission post add-brick) posted (#6) for review on master by Susant Palai (spalai@redhat.com)

Comment 7 Worker Ant 2016-09-12 04:57:07 UTC
COMMIT: http://review.gluster.org/15195 committed in master by Raghavendra G (rgowdapp@redhat.com) 
------
commit 801cd07a4c6ec65ff930b2ae6bb5e405ccd03334
Author: Susant Palai <spalai@redhat.com>
Date:   Wed Aug 17 15:10:04 2016 +0530

    cluster/dht: heal root permission post add-brick
    
    Post add-brick event the new brick will have permission of 755
    by default. If the root directory permission was other than 755,
    that does not get healed to the new brick leading to permission
    errors/inconsistencies.
    
    For choosing source of attr heal we can trust the subvols which
    have layouts with latest ctime(as part of missing directory heal,
    we heal the proper attr). In case none of the subvols have layout,
    return ESTALE to retrigger a fresh lookup.
    
    Note: This patch heals the permission of the root directories only.
    Since, permission healing of directory is not straight forward and
    required intrusive fix, those are not addressed here.
    
    Change-Id: If894e3895d070d46b62d2452e52c1eaafcf56c29
    BUG: 1368012
    Signed-off-by: Susant Palai <spalai@redhat.com>
    Reviewed-on: http://review.gluster.org/15195
    Smoke: Gluster Build System <jenkins@build.gluster.org>
    CentOS-regression: Gluster Build System <jenkins@build.gluster.org>
    NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
    Reviewed-by: Raghavendra G <rgowdapp@redhat.com>

Comment 8 Shyamsundar 2017-03-06 17:22:51 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.10.0, please open a new bug report.

glusterfs-3.10.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://lists.gluster.org/pipermail/gluster-users/2017-February/030119.html
[2] https://www.gluster.org/pipermail/gluster-users/


Note You need to log in before you can comment on or make changes to this bug.