Bug 1368053 - [geo-rep] Stopped geo-rep session gets started automatically once all the master nodes are upgraded
Summary: [geo-rep] Stopped geo-rep session gets started automatically once all the mas...
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: geo-replication
Version: 3.8.0
Hardware: x86_64
OS: Linux
unspecified
medium
Target Milestone: ---
Assignee: bugs@gluster.org
QA Contact:
URL:
Whiteboard:
Keywords: ZStream
Depends On: 1347625 1351071 1368055
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-08-18 08:47 UTC by Saravanakumar
Modified: 2016-08-24 10:21 UTC (History)
6 users (show)

(edit)
Clone Of: 1351071
(edit)
Last Closed: 2016-08-24 10:21:38 UTC


Attachments (Terms of Use)

Comment 1 Vijay Bellur 2016-08-18 08:47:37 UTC
REVIEW: http://review.gluster.org/15196 (glusterd/geo-rep: Handle empty monitor.status during upgrade) posted (#1) for review on release-3.8 by Saravanakumar Arumugam (sarumuga@redhat.com)

Comment 2 Vijay Bellur 2016-08-19 06:33:58 UTC
REVIEW: http://review.gluster.org/15196 (glusterd/geo-rep: Handle empty monitor.status during upgrade) posted (#2) for review on release-3.8 by Saravanakumar Arumugam (sarumuga@redhat.com)

Comment 3 Vijay Bellur 2016-08-19 10:46:55 UTC
COMMIT: http://review.gluster.org/15196 committed in release-3.8 by Aravinda VK (avishwan@redhat.com) 
------
commit 10d044b62e476e032e8bda59fe8fbb3b8b0576b4
Author: Saravanakumar Arumugam <sarumuga@redhat.com>
Date:   Wed Jun 29 15:36:06 2016 +0530

    glusterd/geo-rep: Handle empty monitor.status during upgrade
    
    Problem:
    Consider geo-replication is in Stopped state.
    Following which, glusterfs is upgraded (where monitor.status is the
    new status file).
    
    Now, When geo-replication status command is run,
    empty monitor status file gets created.
    
    Now, if glusterd is restarted, it reads empty monitor status
    and  starts geo-replication session. This is incorrect as session
    was in Stopped state earlier.
    
    Solution:
    If monitor status is empty, error out and avoid
    starting geo-replication session.
    
    Note: if monitor status is empty, geo-rep session is displayed
    as Stopped state.
    
    Change-Id: Ifb3db896e5ed92b927764cf1163503765cb08bb4
    BUG: 1368053
    Signed-off-by: Saravanakumar Arumugam <sarumuga@redhat.com>
    > Reviewed-on: http://review.gluster.org/14830
    > Smoke: Gluster Build System <jenkins@build.gluster.org>
    > CentOS-regression: Gluster Build System <jenkins@build.gluster.org>
    > NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
    > Reviewed-by: Jeff Darcy <jdarcy@redhat.com>
    (cherry picked from commit f938b3a26ffab9482d5f910ee76d2bb2b370517f)
    Reviewed-on: http://review.gluster.org/15196
    NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
    Smoke: Gluster Build System <jenkins@build.gluster.org>
    CentOS-regression: Gluster Build System <jenkins@build.gluster.org>
    Reviewed-by: Aravinda VK <avishwan@redhat.com>

Comment 4 Niels de Vos 2016-08-24 10:21:38 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.8.3, please open a new bug report.

glusterfs-3.8.3 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://www.gluster.org/pipermail/announce/2016-August/000059.html
[2] https://www.gluster.org/pipermail/gluster-users/


Note You need to log in before you can comment on or make changes to this bug.