Bug 1368055 - [geo-rep] Stopped geo-rep session gets started automatically once all the master nodes are upgraded
Summary: [geo-rep] Stopped geo-rep session gets started automatically once all the mas...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: geo-replication
Version: 3.7.0
Hardware: x86_64
OS: Linux
unspecified
medium
Target Milestone: ---
Assignee: Saravanakumar
QA Contact:
URL:
Whiteboard:
Depends On: 1347625 1351071
Blocks: 1368053
TreeView+ depends on / blocked
 
Reported: 2016-08-18 08:49 UTC by Saravanakumar
Modified: 2016-09-01 09:33 UTC (History)
5 users (show)

Fixed In Version: glusterfs-3.7.15
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 1351071
Environment:
Last Closed: 2016-09-01 09:22:29 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Comment 1 Vijay Bellur 2016-08-18 08:50:12 UTC
REVIEW: http://review.gluster.org/15197 (glusterd/geo-rep: Handle empty monitor.status during upgrade) posted (#1) for review on release-3.7 by Saravanakumar Arumugam (sarumuga@redhat.com)

Comment 2 Vijay Bellur 2016-08-19 06:35:37 UTC
REVIEW: http://review.gluster.org/15197 (glusterd/geo-rep: Handle empty monitor.status during upgrade) posted (#2) for review on release-3.7 by Saravanakumar Arumugam (sarumuga@redhat.com)

Comment 3 Vijay Bellur 2016-08-19 10:47:47 UTC
COMMIT: http://review.gluster.org/15197 committed in release-3.7 by Aravinda VK (avishwan@redhat.com) 
------
commit 26c153bec24c0c0a37e788707f6ca793890279f0
Author: Saravanakumar Arumugam <sarumuga@redhat.com>
Date:   Wed Jun 29 15:36:06 2016 +0530

    glusterd/geo-rep: Handle empty monitor.status during upgrade
    
    Problem:
    Consider geo-replication is in Stopped state.
    Following which, glusterfs is upgraded (where monitor.status is the new status file).
    
    Now, When geo-replication status command is run,
    empty monitor status file gets created.
    
    Now, if glusterd is restarted, it reads empty monitor status
    and  starts geo-replication session. This is incorrect as session
    was in Stopped state earlier.
    
    Solution:
    If monitor status is empty, error out and avoid
    starting geo-replication session.
    
    Note: if monitor status is empty, geo-rep session is displayed
    as Stopped state.
    
    Change-Id: Ifb3db896e5ed92b927764cf1163503765cb08bb4
    BUG: 1368055
    Signed-off-by: Saravanakumar Arumugam <sarumuga@redhat.com>
    > Reviewed-on: http://review.gluster.org/14830
    > Smoke: Gluster Build System <jenkins@build.gluster.org>
    > CentOS-regression: Gluster Build System <jenkins@build.gluster.org>
    > NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
    > Reviewed-by: Jeff Darcy <jdarcy@redhat.com>
    (cherry picked from commit f938b3a26ffab9482d5f910ee76d2bb2b370517f)
    Reviewed-on: http://review.gluster.org/15197
    NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
    CentOS-regression: Gluster Build System <jenkins@build.gluster.org>
    Smoke: Gluster Build System <jenkins@build.gluster.org>
    Reviewed-by: Aravinda VK <avishwan@redhat.com>

Comment 4 Kaushal 2016-09-01 09:22:29 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.7.15, please open a new bug report.

glusterfs-3.7.15 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] https://www.gluster.org/pipermail/gluster-devel/2016-September/050714.html
[2] https://www.gluster.org/pipermail/gluster-users/

Comment 5 Kaushal 2016-09-01 09:33:49 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.7.15, please open a new bug report.

glusterfs-3.7.15 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] https://www.gluster.org/pipermail/gluster-devel/2016-September/050714.html
[2] https://www.gluster.org/pipermail/gluster-users/


Note You need to log in before you can comment on or make changes to this bug.