Bug 1368218 - [RFE] Permit usage of multiple and raw disks as Swift backend
Summary: [RFE] Permit usage of multiple and raw disks as Swift backend
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-tripleo-heat-templates
Version: 10.0 (Newton)
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: 10.0 (Newton)
Assignee: Giulio Fidente
QA Contact: Mike Abrams
URL:
Whiteboard:
: 1276691 1320185 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-08-18 17:39 UTC by Giulio Fidente
Modified: 2016-12-14 15:52 UTC (History)
14 users (show)

Fixed In Version: openstack-tripleo-heat-templates-5.0.0-1.2.el7ost
Doc Type: Enhancement
Doc Text:
With this update, you can now configure Object Storage service (swift) with additional raw disks by deploying the overcloud with an additional environment file, for example: parameter_defaults: ExtraConfig: SwiftRawDisks: sdb: byte_size: 2048 mnt_base_dir: /src/sdb sdc: byte_size: 2048 As a result, the Object Storage service is not limited by the local node `root` filesystem.
Clone Of:
Environment:
Last Closed: 2016-12-14 15:52:16 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2016:2948 normal SHIPPED_LIVE Red Hat OpenStack Platform 10 enhancement update 2016-12-14 19:55:27 UTC
OpenStack gerrit 350841 None None None 2016-08-18 17:39:27 UTC
OpenStack gerrit 390925 None None None 2016-10-27 08:49:52 UTC

Description Giulio Fidente 2016-08-18 17:39:27 UTC
Description of problem:

it should be possible to provide a list of additional(raw) disks to be used as Swift backends

Comment 4 Giulio Fidente 2016-10-10 09:02:03 UTC
To specify multiple raw disks to be used as Swift backends, deploy using an additional environment file:

parameter_defaults:
  ExtraConfig:
    SwiftRawDisks:
      sdb: {}
      sdc: {}

It is also possible to customize the byte_size and mount point to use for each disk, for example:

parameter_defaults:
  ExtraConfig:
    SwiftRawDisks:
      sdb:
        byte_size: 2048
        mnt_base_dir: /src/sdb
      sdc:
        byte_size: 2048

It is also possible to provide node-specific disk maps with node-specific hiera, as described in [1]

1. http://tripleo.org/advanced_deployment/node_specific_hieradata.html

Comment 6 Christian Schwede (cschwede) 2016-10-17 09:10:55 UTC
This didn't work for me as expected - I opened a bug upstream and proposed a fix:

https://bugs.launchpad.net/tripleo/+bug/1634051
https://review.openstack.org/387278

Comment 7 Giulio Fidente 2016-10-17 09:40:46 UTC
Thanks Christian, the fix you posted looks good to me, thanks!

I think best thing to do would be to move the BZ back in ON_DEV and link to your submission from it as well.

Comment 9 Steve Linabery 2016-10-24 18:24:31 UTC
The fix cschwede proposed has failed upstream CI on HA. https://review.openstack.org/387278

Comment 11 Christian Schwede (cschwede) 2016-11-02 13:09:43 UTC
Patches merged on master and stable/newton, moving to POST.

Comment 12 Christian Schwede (cschwede) 2016-11-02 13:11:17 UTC
Moving to MODIFIED; included in latest build from yesterday evening.

Comment 14 Christian Schwede (cschwede) 2016-11-08 09:54:00 UTC
*** Bug 1276691 has been marked as a duplicate of this bug. ***

Comment 22 Christian Schwede (cschwede) 2016-11-30 07:39:36 UTC
*** Bug 1320185 has been marked as a duplicate of this bug. ***

Comment 24 errata-xmlrpc 2016-12-14 15:52:16 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2016-2948.html


Note You need to log in before you can comment on or make changes to this bug.