Bug 136873 - system-config-display doesn't read driver from xorg.conf
system-config-display doesn't read driver from xorg.conf
Status: CLOSED DUPLICATE of bug 133764
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: system-config-display (Show other bugs)
4.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Paul Nasrat
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-10-22 15:39 EDT by John A. Hull
Modified: 2007-11-30 17:07 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 14:06:34 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description John A. Hull 2004-10-22 15:39:00 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1)

Description of problem:
When starting system-config-display, it probes the video card and 
then automatically chooses a driver based on the card type. This is a 
problem when using the closed-source nvidia or ati drivers, because 
it will automatically replace that driver with an open-source driver. 
This prevents users from starting system-config-display and using it 
to configure their monitor and resolutions only, since it will change 
their X driver to something else. 

redhat-config-display was more useful in this regard, since it would 
change the driver only if the user chose to probe or pick a new video 
card. If would be useful if this functionality was included is some 
form in system-config-display also. 

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Set the video driver in xorg.conf for an nvidia card from "nv" 
to "nvidia"
2. Start system-config-display
3. Press "OK"
4. Look in xorg.conf. Driver has changed back to nv
    

Expected Results:  system-config-display should not change the driver 
used unless explicitly told to do so. 

Additional info:
Comment 1 Paul Nasrat 2004-10-23 05:55:49 EDT
Already fixed in rawhide

*** This bug has been marked as a duplicate of 133764 ***
Comment 2 Red Hat Bugzilla 2006-02-21 14:06:34 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.