Bug 1369690 - [Docs] Add some notes regarding HE networking to SHE Migration Guide (reference to KBase #2292861)
Summary: [Docs] Add some notes regarding HE networking to SHE Migration Guide (referen...
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: Documentation
Version: 3.6.8
Hardware: x86_64
OS: Linux
Target Milestone: ovirt-3.6.11
: ---
Assignee: Emma Heftman
QA Contact: Byron Gravenorst
: 1449547 (view as bug list)
Depends On:
TreeView+ depends on / blocked
Reported: 2016-08-24 07:15 UTC by Germano Veit Michel
Modified: 2021-08-30 12:01 UTC (History)
12 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Last Closed: 2017-08-30 08:16:39 UTC
oVirt Team: Docs
Target Upstream Version:
lsvaty: testing_plan_complete-

Attachments (Terms of Use)

System ID Private Priority Status Summary Last Updated
Red Hat Issue Tracker RHV-43191 0 None None None 2021-08-30 12:01:29 UTC
Red Hat Knowledge Base (Solution) 2292861 0 None None None 2016-09-20 01:41:56 UTC

Description Germano Veit Michel 2016-08-24 07:15:20 UTC
Description of problem:

The procedure described here:

Ends up in a broken state in two scenarios:
A. If the management network is not set as a VM Network in the Original Setup
B. If it's a upgrade from pre-3.6, where the management network is rhevm. Hosted-Engine --deploy has a default of 'ovirtmgmt', which later won't match the DB.

A. There will be no rhevm/ovirtmgmt bridge to attach the HE VM to if it's not a VM network.
B. --deploy default network is ovirtmgmt, but in 3.5 and below it's rhevm. So if setup was upgraded, the network name won't match the DB and things go south.

In both scenarios the HostedEngine vm.conf, after the system is up, ends up with incorrect/missing configuration in it's network section. Example:


results in

<interface address="None" type="bridge">
      <mac address="00:16:3e:1e:cd:f5"/>
      <model type="virtio"/>
      <source bridge="None"/>
      <link state="up"/>

Which results in:

libvirtError: Cannot get interface MTU on 'None': No such device

I don't think it's a software bug. In my opinion this is just incorrect configuration for these two cases.

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1. Install RHEV 3.5- with non-VM network rhevm
2. Upgrade to 3.6
3. Migrate to Hosted-Engine

Actual results:
HostedEngine faces multiple issues, not able to start on second reboot, missing NIC, missing bridge...

Expected results:

Additional info:

I haven't tested yet, but I believe this is also the case in RHV 4.0, where possibly more customers will probably think of migrating to SHE. And some of they may come from pre-3.6 installs.

- Problem A is easily solved with a Note in the documentation:
  * Please configure the management network as a VM network prior to Migrating to SHE.
- Problem B is slightly more complex, but possibly solved by appending an additional config to hosted-engine --deploy. See below:

# cat /tmp/answers-rhevm.conf
# hosted-engine --deploy --config-append=/tmp/answers-rhevm.conf

Comment 1 Yaniv Lavi 2017-01-10 12:39:31 UTC
Can you help with updating the KBase?

Comment 3 Marina Kalinin 2017-01-31 19:54:50 UTC
Documentation team, please handle this bug soon.

Action required:
For both 3.6 and 4.0 guides add the following to
Procedure 5.1. Migrating to a Self-Hosted Environment

Part A:
"Step 13: Creating a Backup of BareMetal-Manager"
Either modify that step with a NOTE or add a new step before it.
The instruction should be:
"Make sure the management network is configured as a VM network prior to taking the backup. If it is not, configure it, as per [optional link to the admin guide where we should how to do that]"

Part B:
"Step 1: Initiating a Self-Hosted Engine Deployment"

Add a Note on top of the step saying:
"If your original installation was done on earlier RHEV version then 3.6 and your current management network name is rhevm, when running hosted-engine --deploy, provide it with a modified answering file as [below/stated in this KCS]:

# cat /tmp/answers-rhevm.conf
# hosted-engine --deploy --config-append=/tmp/answers-rhevm.conf

Comments on B:
It sounds reasonable to me to create a KCS for this and reference to a KCS.
However, I am not sure this solution would work on RHEV-H. And that's why it can be indeed better to reference to KCS and once we find that solution to modify the KCS (if that solution exists, of course). Or we can state that we only support RHEL hosts in such a case.

Comment 5 Marina Kalinin 2017-01-31 21:47:31 UTC
Here is the KCS:

However, I do not think we should link it to the documentation on Part B. The suggested wording should be enough.

Comment 7 Dan Kenigsberg 2017-05-25 12:40:36 UTC
As reported in bug 1454998, we should also document that currently Self-hosted Engine cannot use VM-FEX.

Comment 8 Yaniv Lavi 2017-05-29 07:27:12 UTC
Can you review this bug and the linked documentation and recommended on the needed additions and changes?

Comment 10 Yaniv Lavi 2017-07-11 07:58:40 UTC
Lucy, let's reference:

Comment 11 Lucy Bopf 2017-07-13 05:45:15 UTC
Assigning to Emma for review.

Comment 12 Emma Heftman 2017-07-13 10:54:23 UTC

In https://bugzilla.redhat.com/show_bug.cgi?id=1369690#c3 Marina said that she doesn't think that the note should link to this KB article.

However, Yaniv suggested that we should link to it. 

Can you please confirm that what you think should appear in the guide.

Also, the article only mentions 3.5 to 3.6.

I am updating only the 4.0 and 4.1 guides, so does it still make sense to reference a 3.6 article?
Has the solution been confirmed for 4.0 and 4.1?

Comment 13 Emma Heftman 2017-07-13 11:07:58 UTC
Marina, does this issue only occur when migrating to a self-hosted from a 3.5 environment? 
If so, I don't think it is even relevant for 4.x and we are no longer updating 3.6.

Comment 14 Emma Heftman 2017-07-16 14:30:59 UTC
(In reply to Emma Heftman from comment #13)
> Marina, does this issue only occur when migrating to a self-hosted from a
> 3.5 environment? 
> If so, I don't think it is even relevant for 4.x and we are no longer
> updating 3.6.
Hi Marina, after speaking to Lucy, I understand that we will update the 3.6 where required.

Comment 19 Simone Tiraboschi 2017-08-02 12:24:26 UTC
*** Bug 1449547 has been marked as a duplicate of this bug. ***

Comment 28 Emma Heftman 2017-08-30 08:16:39 UTC
The 4.1 Self-Hosted Engine Guide is available on the Customer Portal:


Note You need to log in before you can comment on or make changes to this bug.