Bug 1449547 - ovirt-hosted-engine-setup assumes ovirtmgmt as management bridge even when upgrading
Summary: ovirt-hosted-engine-setup assumes ovirtmgmt as management bridge even when up...
Status: CLOSED DUPLICATE of bug 1369690
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-hosted-engine-setup
Version: 4.0.7
Hardware: x86_64
OS: Linux
high
high
Target Milestone: ovirt-4.1.5
: ---
Assignee: Simone Tiraboschi
QA Contact: meital avital
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-05-10 08:59 UTC by Andreas Bleischwitz
Modified: 2019-04-28 11:15 UTC (History)
5 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2017-08-02 12:24:26 UTC


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Bugzilla 1231799 None CLOSED [RFE] hosted-engine-setup should let its user choose the name of the bridge to be created (and have ovirtmgmt as default... 2019-04-04 16:30 UTC

Internal Trackers: 1231799

Description Andreas Bleischwitz 2017-05-10 08:59:09 UTC
Description of problem:
During an upgrade of RHEV-3.6.10 (upgraded since RHEV-3.3) and additionally migrating from out-of-band cluster for the manager to self-hosted, we ran into the issue that the manager was not able to add the hosted-engine host.


Version-Release number of selected component (if applicable):
* Running RHEV-3.6.10 with "rhevm" as management bridge
* Upgrading to RHV-4.0 by installing ovirt-hosted-engine-setup and bringing up a new engine, applying the backup from RHEV-3.6.10

How reproducible:
Always

Steps to Reproduce:
1. Install RHEV-manager with "rhevm" as management bridge (has been default until 3.5/3.6??)
2. Create backup of database
3. Install RHV-4 host with hosted-engine (a separated BZ will be filed because ovirt-hosted-engine-setup pulls in RHV-4.1 appliance during setup)
4. Restore backup from RHEV-3.6.10 on RHV-4.0 engine for upgrade
5. run "engine-setup"
6. shutdown engine as directed when engine-setup finished.
7. find ovirt-hosted-engine-setup starting the engine with "ovirtmgmt" as management interface whereas the hosts use "rhevm". 

Actual results:
ovirt-hosted-engine-setup creates unconditionally "ovirtmgmt" as bridge for the management interface.

Expected results:
ovirt-hosted-engine-setup asks if the installation is an upgrade and if so asks for the name of the currently used management bridge. Also the question about starting "engine-setup" could then be defaulting to "no".

Additional info:

Comment 3 Simone Tiraboschi 2017-08-02 12:24:26 UTC
There is a workaround for that described in https://access.redhat.com/solutions/2292861

*** This bug has been marked as a duplicate of bug 1369690 ***


Note You need to log in before you can comment on or make changes to this bug.