Bug 1369854 - Login page redirect
Summary: Login page redirect
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Management Console
Version: 3.2.0
Hardware: Unspecified
OS: Unspecified
unspecified
low
Target Milestone: ---
: ---
Assignee: Jordan Liggitt
QA Contact: Yadan Pei
URL:
Whiteboard:
: 1416710 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-08-24 14:34 UTC by Steven Walter
Modified: 2020-05-14 15:17 UTC (History)
10 users (show)

Fixed In Version:
Doc Type: No Doc Update
Doc Text:
undefined
Clone Of:
Environment:
Last Closed: 2017-04-12 19:06:26 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2017:0884 0 normal SHIPPED_LIVE Red Hat OpenShift Container Platform 3.5 RPM Release Advisory 2017-04-12 22:50:07 UTC

Description Steven Walter 2016-08-24 14:34:52 UTC
Description of problem:
When using the web console, navigating to:
myopenshifturl.com/console
Allows the user to enter credentials, and after log-in is redirected to the dashboard.
Navigating to:
myopenshifturl.com/
Redirects the user to:
myopenshifturl.com/login<and a bunch of other characters representing redirect info, etc>
which allows you to enter credentials and be redirected to the dashboard.
But if you navigate to:
myopenshifturl.com/login
directly, you can enter your credentials, but are "redirected" to a blank page. If you then visit myopenshifturl.com/console you are already successfully logged in. Of course, the redirect info is not present when accessing just /login and the intention is to have users access /console or just myopenshifturl.com, but it is not user-friendly to have a seemingly normal login page that does not work. Not sure if there is a way to have a sort of "default" redirect upon authentication that is not reliant on the redirect info being in the url.

Version-Release number of selected component (if applicable):
Reproduced on 3.2.0

How reproducible:
Easily

Steps to Reproduce:
1. navigate in web browser to myopenshifttestenvironment.com/login
2. type in credentials

Actual results:
Blank page

Expected results:
Dashboard

Comment 1 Juan Vallejo 2016-11-17 21:10:49 UTC
Related issue https://github.com/openshift/origin-web-console/issues/888

Comment 2 Jordan Liggitt 2016-11-17 21:38:48 UTC
Fixed in https://github.com/openshift/origin/pull/11961 upstream

Comment 3 Troy Dawson 2017-01-20 23:35:53 UTC
This has been merged into ocp and is in OCP v3.5.0.7 or newer.

Comment 4 Yanping Zhang 2017-01-22 04:00:33 UTC
Checked on OCP v3.5.0.7.
Navigation to url: https://<openshiftserverurl>/login, after login it will redirect to server root "/", which would forward to /console. 
The bug has been fixed, so move it to Verified.

Comment 5 Jordan Liggitt 2017-01-26 15:41:16 UTC
*** Bug 1416710 has been marked as a duplicate of this bug. ***

Comment 9 errata-xmlrpc 2017-04-12 19:06:26 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2017:0884


Note You need to log in before you can comment on or make changes to this bug.