Bug 1416710 - Logging into OpenShift with no 'then' field in the URL results in a blank page
Summary: Logging into OpenShift with no 'then' field in the URL results in a blank page
Keywords:
Status: CLOSED DUPLICATE of bug 1369854
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: apiserver-auth
Version: 3.4.0
Hardware: Unspecified
OS: Unspecified
medium
low
Target Milestone: ---
: ---
Assignee: Jordan Liggitt
QA Contact: Chuan Yu
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-01-26 10:01 UTC by Jaspreet Kaur
Modified: 2020-05-14 15:34 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-01-26 15:41:16 UTC
Target Upstream Version:


Attachments (Terms of Use)

Comment 1 Mark Chappell 2017-01-26 10:11:11 UTC
Stripping reference to private server

Description of problem: Login to the console first  and then logout and move to console the url would be something like as below :

https://master.example.com:8443/login?then=%2Foauth%2Fauthorize%3Fclient_id%3Dopenshift-web-console%26response_type%3Dtoken%26state%3D%257B%2522then%2522%253A%2522%252F%2522%252C%2522nonce%2522%253A%25221485424629696-1068234352303696885522349434961449915255959571781242161994712508926662531624843%2522%257D%26redirect_uri%3Dhttps%253A%252F%252Fmaster.example.com%253A8443%252Fconsole%252Foauth

Now remove the ?then field in the above url and resulting is as below:

https://master.example.com:8443/login

The console is correctly seen and now provide Username and password. It accepts the input but now it directs to the same page but is blank :

https://master.example.com:8443/login

This feels like a UX glitch.

After first visiting the platform, one of our users had bookmarked the login page https://master.example.com:8443/login (with no "?then=...").  When they subsequently tried to use the bookmark.  They logged in only to be presented with a blank page rather than the console.  This feels like a UX glitch.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results: It provides with a blank page


Expected results: It should have logged in the user.


Additional info:

Comment 2 Jordan Liggitt 2017-01-26 15:41:16 UTC

*** This bug has been marked as a duplicate of bug 1369854 ***


Note You need to log in before you can comment on or make changes to this bug.