Bug 136993 - ACPI S3 sleep errorsin_atomic():0, irqs_disabled():1
ACPI S3 sleep errorsin_atomic():0, irqs_disabled():1
Status: CLOSED DUPLICATE of bug 154046
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
4
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Jones
:
: 140073 (view as bug list)
Depends On:
Blocks: FCMETA_ACPI
  Show dependency treegraph
 
Reported: 2004-10-24 19:26 EDT by Paul Ionescu
Modified: 2015-01-04 17:11 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-10-02 17:41:48 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Paul Ionescu 2004-10-24 19:26:54 EDT
Description of problem:

Since I upgraded to kernel linux 2.6.9-1.640, I have this errors in dmesg:

Back to C!
Warning: CPU frequency is 1700000, cpufreq assumed 600000 kHz.
Debug: sleeping function called from invalid context at mm/slab.c:2059
in_atomic():0, irqs_disabled():1
 [<c011e898>] __might_sleep+0x98/0xa0
 [<c0151b93>] __kmalloc+0xa3/0xb0
 [<c0208825>] acpi_os_allocate+0xe/0x11
 [<c021cad6>] acpi_ut_allocate+0x38/0x5a
 [<c021ca61>] acpi_ut_initialize_buffer+0x43/0x80
 [<c02197c3>] acpi_rs_create_byte_stream+0x2a/0x47
 [<c021abf4>] acpi_rs_set_srs_method_data+0x1d/0xb1
 [<c0243bfb>] poke_blanked_console+0x7b/0xd0
 [<c0221113>] acpi_pci_link_set+0xe9/0x163
 [<c0221480>] acpi_pci_link_resume+0x1c/0x22
 [<c02214a1>] irqrouter_resume+0x1b/0x30
 [<c0221486>] irqrouter_resume+0x0/0x30
 [<c025bc43>] sysdev_resume+0x103/0x108
 [<c025f825>] device_power_up+0x5/0xa
 [<c0138996>] suspend_enter+0x36/0x50
 [<c0138a41>] enter_state+0x51/0x80
 [<c0138ba0>] state_store+0xa0/0xa8
 [<c019f79a>] subsys_attr_store+0x3a/0x40
 [<c019fa0b>] flush_write_buffer+0x3b/0x50
 [<c019fa80>] sysfs_write_file+0x60/0x70
 [<c01663ad>] vfs_write+0xed/0x160
 [<c01664f1>] sys_write+0x51/0x80
 [<c01070bd>] sysenter_past_esp+0x52/0x71
ACPI: PCI interrupt 0000:00:1f.1[A] -> GSI 5 (level, low) -> IRQ 5


Version-Release number of selected component (if applicable):
linux 2.6.9-1.640


How reproducible:
Allways on my IBM T40 and R50p

Steps to Reproduce:
1. echo 3 > /proc/acpi/sleep
2. dmesg to see them

  
Actual results:


Expected results:


Additional info:
Comment 1 Ed Hill 2004-11-10 09:55:33 EST
I'm getting what appears to be the same thing on a ThinkPad A22p with
FC3 and the default 2.6.9-1.667 kernel:

Nov 10 09:08:52 localhost kernel: zapping low mappings.
Nov 10 09:08:52 localhost kernel: Debug: sleeping function called from
invalid context at mm/slab.c:2063
Nov 10 09:08:52 localhost kernel: in_atomic():0[expected: 0],
irqs_disabled():1
Nov 10 09:08:52 localhost kernel:  [<0211c8b9>] __might_sleep+0x7d/0x88
Nov 10 09:08:52 localhost kernel:  [<0214bb57>] __kmalloc+0x42/0x7d
Nov 10 09:08:52 localhost kernel:  [<021f3c1d>] acpi_os_allocate+0xa/0xb
Nov 10 09:08:52 localhost kernel:  [<02207ad2>] acpi_ut_allocate+0x2e/0x52
Nov 10 09:08:52 localhost kernel:  [<02207a69>]
acpi_ut_initialize_buffer+0x41/0x7c
Nov 10 09:08:52 localhost kernel:  [<022047bc>]
acpi_rs_create_byte_stream+0x23/0x3b
Nov 10 09:08:52 localhost kernel:  [<02205cbe>]
acpi_rs_set_srs_method_data+0x1b/0x9d
Nov 10 09:08:52 localhost kernel:  [<0220d4a4>]
acpi_pci_link_set+0xfe/0x176
Nov 10 09:08:52 localhost kernel:  [<0220d828>] irqrouter_resume+0x1c/0x24
Nov 10 09:08:52 localhost kernel:  [<022427be>] sysdev_resume+0x3e/0xa5
Nov 10 09:08:52 localhost kernel:  [<022456b8>] device_power_up+0x5/0xa
Nov 10 09:08:52 localhost kernel:  [<0213d752>] suspend_enter+0x25/0x2d
Nov 10 09:08:52 localhost kernel:  [<0213d7c0>] enter_state+0x3f/0x5e
Nov 10 09:08:52 localhost kernel:  [<0213d8bf>] state_store+0x83/0x91
Nov 10 09:08:52 localhost kernel:  [<0213d83c>] state_store+0x0/0x91
Nov 10 09:08:52 localhost kernel:  [<021aad7b>]
subsys_attr_store+0x19/0x21
Nov 10 09:08:52 localhost kernel:  [<021aaeee>]
flush_write_buffer+0x1d/0x22
Nov 10 09:08:52 localhost kernel:  [<021aaf15>] sysfs_write_file+0x22/0x35
Nov 10 09:08:52 localhost kernel:  [<021656fa>] vfs_write+0xb6/0xe2
Nov 10 09:08:52 localhost kernel:  [<021657c4>] sys_write+0x3c/0x62
Nov 10 09:08:52 localhost kernel: ACPI: PCI interrupt 0000:00:05.0[A]
-> GSI 11 (level, low) -> IRQ 11
Nov 10 09:08:52 localhost kernel: Restarting tasks... done

Is this a serious error?  That is, should I be worried about memory or
FS corruption?  Other than this error message, the system does seem to
suspend and resume without any problems.

Ed 
Comment 2 wilksen 2004-11-17 14:19:44 EST
I can confirm that on a Thinkpad T42p running Fedora Core 3 with
kernel 2.6.9-1.667. For booting the kernel option acpi_sleep=s3_bios
is used. Without that option it would suspend and resume but not 
switching back on the LCD. Seen also on a R51.

Nov 17 09:28:42 localhost kernel: Warning: CPU frequency is 2000000,
cpufreq assumed 600000 kHz.
Nov 17 09:28:42 localhost kernel: Debug: sleeping function called from
invalid context at mm/slab.c:2063
Nov 17 09:28:42 localhost kernel: in_atomic():0[expected: 0],
irqs_disabled():1
Nov 17 09:28:42 localhost kernel:  [<0211c8b9>] __might_sleep+0x7d/0x88
Nov 17 09:28:42 localhost kernel:  [<0214bb57>] __kmalloc+0x42/0x7d
Nov 17 09:28:42 localhost kernel:  [<021f3c1d>] acpi_os_allocate+0xa/0xb
Nov 17 09:28:42 localhost kernel:  [<02207ad2>] acpi_ut_allocate+0x2e/0x52
Nov 17 09:28:42 localhost kernel:  [<02207a69>]
acpi_ut_initialize_buffer+0x41/0x7c
Nov 17 09:28:42 localhost kernel:  [<022047bc>]
acpi_rs_create_byte_stream+0x23/0x3b
Nov 17 09:28:42 localhost kernel:  [<02205cbe>]
acpi_rs_set_srs_method_data+0x1b/0x9d
Nov 17 09:28:42 localhost kernel:  [<42ba385a>]
_ieee80211_crypto_delkey+0x7c/0xa9 [wlan]
Nov 17 09:28:42 localhost kernel:  [<0211ae71>]
recalc_task_prio+0x128/0x133
Nov 17 09:28:42 localhost kernel:  [<0220d4a4>]
acpi_pci_link_set+0xfe/0x176
Nov 17 09:28:42 localhost kernel:  [<0220d828>] irqrouter_resume+0x1c/0x24
Nov 17 09:28:42 localhost kernel:  [<022427be>] sysdev_resume+0x3e/0xa5
Nov 17 09:28:42 localhost kernel:  [<022456b8>] device_power_up+0x5/0xa
Nov 17 09:28:42 localhost kernel:  [<0213d752>] suspend_enter+0x25/0x2d
Nov 17 09:28:42 localhost kernel:  [<0213d7c0>] enter_state+0x3f/0x5e
Nov 17 09:28:42 localhost kernel:  [<0220a09c>] acpi_suspend+0x28/0x34
Nov 17 09:28:42 localhost kernel:  [<0220ab0c>]
acpi_system_write_sleep+0x5c/0x6d
Nov 17 09:28:42 localhost kernel:  [<021656fa>] vfs_write+0xb6/0xe2
Nov 17 09:28:42 localhost kernel:  [<021657c4>] sys_write+0x3c/0x62
Nov 17 09:28:42 localhost kernel: ACPI: PCI interrupt 0000:00:1d.7[D]
-> GSI 11 (level, low) -> IRQ 11
Nov 17 09:28:42 localhost kernel: ACPI: PCI interrupt 0000:00:1f.1[A]
-> GSI 11 (level, low) -> IRQ 11
Nov 17 09:28:42 localhost kernel: ACPI: PCI interrupt 0000:00:1f.5[B]
-> GSI 11 (level, low) -> IRQ 11
Nov 17 09:28:42 localhost kernel: ACPI: PCI interrupt 0000:00:1f.6[B]
-> GSI 11 (level, low) -> IRQ 11
Nov 17 09:28:42 localhost kernel: PCI: Enabling device 0000:02:01.0
(0000 -> 0003)
Nov 17 09:28:42 localhost kernel: ACPI: PCI interrupt 0000:02:01.0[A]
-> GSI 11 (level, low) -> IRQ 11
Nov 17 09:28:42 localhost kernel: ACPI: PCI interrupt 0000:02:02.0[A]
-> GSI 11 (level, low) -> IRQ 11
Nov 17 09:28:42 localhost kernel: Restarting tasks... done
Comment 3 Len Brown 2004-11-18 01:17:24 EST
This is from ACPI allocating memory with interrupts disabled.
This traceback is a warning that if the memory allocation
had caused a sleep, then the system would have hanged.
Comment 4 Ed Hill 2004-11-19 09:48:49 EST
Just upgraded to the newer 2.6.9-1.678_FC3 kernel and this bug is
still present on a ThinkPad A22p.
Comment 5 Len Brown 2004-11-20 04:43:09 EST
*** Bug 140073 has been marked as a duplicate of this bug. ***
Comment 6 Artem Veremey 2004-11-25 17:26:35 EST
Same here:
TPad X31 running 2.6.9-1.681_FC3 on Fedora 3:
--
Nov 25 14:10:22 localhost kernel: Debug: sleeping function called from
invalid context at mm/slab.c:2063
Nov 25 14:10:22 localhost kernel: in_atomic():0[expected: 0],
irqs_disabled():1
Nov 25 14:10:22 localhost kernel:  [<0211cbe7>] __might_sleep+0x82/0x8c
Nov 25 14:10:22 localhost kernel:  [<0214c6b1>] __kmalloc+0x42/0x7d
Nov 25 14:10:22 localhost kernel:  [<021f5b55>] acpi_os_allocate+0xa/0xb
Nov 25 14:10:22 localhost kernel:  [<022096e7>] acpi_ut_allocate+0x34/0x57
Nov 25 14:10:22 localhost kernel:  [<02209678>]
acpi_ut_initialize_buffer+0x42/0x7d
Nov 25 14:10:22 localhost kernel:  [<02206526>]
acpi_rs_create_byte_stream+0x23/0x39
Nov 25 14:10:23 localhost kernel:  [<022078e6>]
acpi_rs_set_srs_method_data+0x1b/0x9d
Nov 25 14:10:23 localhost kernel:  [<0211b11a>]
recalc_task_prio+0x128/0x133
Nov 25 14:10:23 localhost kernel:  [<0220f04d>]
acpi_pci_link_set+0xde/0x155
Nov 25 14:10:23 localhost kernel:  [<0220f3d1>] irqrouter_resume+0x1c/0x30
Nov 25 14:10:23 localhost kernel:  [<0224459e>] sysdev_resume+0x3e/0xc7
Nov 25 14:10:23 localhost kernel:  [<022475c4>] device_power_up+0x5/0xa
Nov 25 14:10:23 localhost kernel:  [<0213e0b6>] suspend_enter+0x25/0x2d
Nov 25 14:10:23 localhost kernel:  [<0213e124>] enter_state+0x3f/0x5e
Nov 25 14:10:23 localhost kernel:  [<0220bc34>] acpi_suspend+0x25/0x35
Nov 25 14:10:23 localhost kernel:  [<0215f602>] get_user_size+0x2e/0x55
Nov 25 14:10:23 localhost kernel:  [<0220c6cb>]
acpi_system_write_sleep+0x5f/0x70
Nov 25 14:10:23 localhost kernel:  [<021664d6>] vfs_write+0xb8/0xe4
Nov 25 14:10:23 localhost kernel:  [<021665a0>] sys_write+0x3c/0x62
Nov 25 14:10:23 localhost kernel: ACPI: PCI interrupt 0000:00:1f.1[A]
-> GSI 11 (level, low) -> IRQ 11
Nov 25 14:10:23 localhost kernel: ACPI: PCI interrupt 0000:00:1f.5[B]
-> GSI 11 (level, low) -> IRQ 11
Nov 25 14:10:23 localhost kernel: ACPI: PCI interrupt 0000:00:1f.6[B]
-> GSI 11 (level, low) -> IRQ 11
Nov 25 14:10:23 localhost kernel: ACPI: PCI interrupt 0000:02:00.2[C]
-> GSI 11 (level, low) -> IRQ 11
Nov 25 14:10:23 localhost kernel: hub 1-0:1.0: reactivate --> -22
Nov 25 14:10:23 localhost kernel: hub 1-0:1.0: reactivate --> -22
Nov 25 14:10:23 localhost kernel: hub 2-0:1.0: reactivate --> -22
Nov 25 14:10:23 localhost kernel: hub 3-0:1.0: reactivate --> -22
Nov 25 14:10:23 localhost kernel: hub 4-0:1.0: reactivate --> -22
Nov 25 14:10:23 localhost kernel: Restarting tasks... done
Comment 7 Len Brown 2005-04-07 18:03:19 EDT
This bug is tracked upstream here:
http://bugzilla.kernel.org/show_bug.cgi?id=3469
And the fix has been under test in the mm
tree for the last few weeks.
Comment 8 Geoff Gustafson 2005-05-16 17:18:36 EDT
Ping - looks like it's fixed upstream in the bug Len listed.
Comment 9 Dave Jones 2005-07-15 15:30:31 EDT
An update has been released for Fedora Core 3 (kernel-2.6.12-1.1372_FC3) which
may contain a fix for your problem.   Please update to this new kernel, and
report whether or not it fixes your problem.

If you have updated to Fedora Core 4 since this bug was opened, and the problem
still occurs with the latest updates for that release, please change the version
field of this bug to 'fc4'.

Thank you.
Comment 10 Paul Ionescu 2005-07-15 15:49:46 EDT
Yes, I upgraded to FC4 and I have the bellow error with latest kernel
(2.6.12-1.1390) 


Back to C!
Debug: sleeping function called from invalid context at mm/slab.c:2126
in_atomic():0, irqs_disabled():1
 [<c016a1e6>] kmem_cache_alloc+0x3c/0x49
 [<c027d9d6>] acpi_pci_link_set+0x3f/0x17f
 [<c027de20>] irqrouter_resume+0x14/0x28
 [<c029c13d>] sysdev_resume+0x3d/0xb5
 [<c02a0283>] device_power_up+0x5/0xa
 [<c014aa1b>] suspend_enter+0x46/0x48
 [<c014aa8f>] enter_state+0x49/0x54
 [<c027ae9a>] acpi_system_write_sleep+0x66/0x78
 [<c027ae34>] acpi_system_write_sleep+0x0/0x78
 [<c0189744>] vfs_write+0x9e/0x110
 [<c0189861>] sys_write+0x41/0x6a
 [<c0103a61>] syscall_call+0x7/0xb
hub 2-0:1.0: resubmit --> -108
hub 3-0:1.0: resubmit --> -108
hub 4-0:1.0: resubmit --> -108
PCI: Enabling device 0000:00:1d.0 (0000 -> 0001)
ACPI: PCI Interrupt 0000:00:1d.0[A] -> Link [LNKA] -> GSI 5 (level, low) -> IRQ 5
Comment 11 Dave Jones 2005-07-15 17:06:56 EDT
[This comment has been added as a mass update for all FC4 kernel bugs.
 If you have migrated this bug from an FC3 bug today, ignore this comment.]

Please retest your problem with todays 2.6.12-1.1398_FC4 update.

If your problem involved being unable to boot, or some hardware not being
detected correctly, please make sure your /etc/modprobe.conf is correct *BEFORE*
installing any kernel updates.
If in doubt, you can recreate this file using..

mv /etc/sysconfig/hwconf /etc/sysconfig/hwconf.bak
mv /etc/modprobe.conf /etc/modprobe.conf.bak
kudzu


Thank you.
Comment 12 Tim Pepper 2005-08-29 14:11:34 EDT
2.6.12-1.1398_FC4 on T42p still gives this for me:

Debug: sleeping function called from invalid context at mm/slab.c:2126
in_atomic():0, irqs_disabled():1
 [<c015c376>] kmem_cache_alloc+0x3c/0x49
 [<c0248562>] acpi_pci_link_set+0x3f/0x17f
 [<c02489ac>] irqrouter_resume+0x14/0x28
 [<c0287c5e>] sysdev_resume+0x3d/0xb5
 [<c028bd57>] device_power_up+0x5/0xa
 [<c014a8cb>] suspend_enter+0x44/0x46
 [<c014a859>] suspend_prepare+0x57/0x85
 [<c014a93e>] enter_state+0x49/0x54
 [<c0245a26>] acpi_system_write_sleep+0x5a/0x6c
 [<c02459cc>] acpi_system_write_sleep+0x0/0x6c
 [<c017b9e4>] vfs_write+0x9e/0x110
 [<c017bb01>] sys_write+0x41/0x6a
 [<c0103a51>] syscall_call+0x7/0xb
Comment 13 Dave Jones 2005-09-30 02:07:44 EDT
Mass update to all FC4 bugs:

An update has been released (2.6.13-1.1526_FC4) which rebases to a new upstream
kernel (2.6.13.2). As there were ~3500 changes upstream between this and the
previous kernel, it's possible your bug has been fixed already.

Please retest with this update, and update this bug if necessary.

Thanks.
Comment 14 Paul Ionescu 2005-10-02 07:46:13 EDT
In 2.6.13-1.1526_FC4 I still have at S3 suspend the following:

Back to C!
Debug: sleeping function called from invalid context at mm/slab.c:2129
in_atomic():0, irqs_disabled():1
 [<c0176913>] kmem_cache_alloc+0x3c/0x4e
 [<c029927a>] acpi_pci_link_set+0x3f/0x17f
 [<c02997e2>] irqrouter_resume+0x1e/0x3c
 [<c02e792d>] sysdev_resume+0x3d/0xb5
 [<c02ec261>] device_power_up+0x5/0xa
 [<c015eaf8>] suspend_enter+0x44/0x46
 [<c015ea5a>] suspend_prepare+0x63/0xbd
 [<c015eb6e>] enter_state+0x49/0x54
 [<c015ec69>] state_store+0x81/0x8f
 [<c015ebe8>] state_store+0x0/0x8f
 [<c020f24a>] subsys_attr_store+0x1e/0x22
 [<c020f454>] flush_write_buffer+0x22/0x28
 [<c020f4a8>] sysfs_write_file+0x4e/0x73
 [<c020f45a>] sysfs_write_file+0x0/0x73
 [<c01a1017>] vfs_write+0xa2/0x15a
 [<c01a117a>] sys_write+0x41/0x6a
 [<c0104465>] syscall_call+0x7/0xb
PCI: Enabling device 0000:00:1d.0 (0000 -> 0001)
Comment 15 Dave Jones 2005-10-02 17:41:48 EDT


*** This bug has been marked as a duplicate of 154046 ***

Note You need to log in before you can comment on or make changes to this bug.