Bug 137016 - [xcin] should accept MODIFIERS keys when preedit is not empty
Summary: [xcin] should accept MODIFIERS keys when preedit is not empty
Status: CLOSED DUPLICATE of bug 136643
Alias: None
Product: Fedora
Classification: Fedora
Component: iiimf-le-xcin   
(Show other bugs)
Version: rawhide
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Leon Ho
QA Contact:
URL:
Whiteboard:
Keywords: i18n
Depends On:
Blocks: IIIMF
TreeView+ depends on / blocked
 
Reported: 2004-10-25 07:00 UTC by Lawrence Lim
Modified: 2014-03-26 00:51 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 19:06:36 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Lawrence Lim 2004-10-25 07:00:35 UTC
Description of problem:
Currently, when there is contents in the pre-edit buffer, the LE does
not accept any other keystroke except [a-z] and [0-9]. Please include
MODIFIERS keys into the list of xcin so that it accepts ctrl-space or
shift-space when there are contents in the preedit buffer.

Version-Release number of selected component (if applicable):
iiimf-le-xcin-0.1.7-9

How reproducible:
Always

Steps to Reproduce:
1.in gdm login as normal user with traditional chinese/ gnome session
2.after run gnome, press alt-f2 to run dialog
3.toggle on LE (ctrl-space)
4.enter a  
5.toggle off LE (ctrl-space)

Actual results:
Not responding to toggle off

Expected results:
Should respond by toggling off the empty preedit buffer

Additional info:

Comment 1 Leon Ho 2004-11-01 13:47:07 UTC
Same problem as #136643. 

*** This bug has been marked as a duplicate of 136643 ***

Comment 2 Red Hat Bugzilla 2006-02-21 19:06:36 UTC
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.


Note You need to log in before you can comment on or make changes to this bug.