Bug 136643 - can't deactivate IM when there is something in the preedit buffer
Summary: can't deactivate IM when there is something in the preedit buffer
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: im-sdk   
(Show other bugs)
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Akira TAGOH
QA Contact:
URL:
Whiteboard:
Keywords: i18n
: 137016 (view as bug list)
Depends On:
Blocks: IIIMF 137149
TreeView+ depends on / blocked
 
Reported: 2004-10-21 13:41 UTC by Akira TAGOH
Modified: 2007-11-30 22:10 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-11-04 18:12:27 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Akira TAGOH 2004-10-21 13:41:34 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; ja-JP; rv:1.7.3)
Gecko/20041007 Debian/1.7.3-5

Description of problem:
XIM server could be deactivated even if there is the strings in the
preedit buffer. but IIIMF can't.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.input something but don't commit it
2.press ctrl+space
3.
    

Actual Results:  ctrl+space seems to be ignored

Expected Results:  IM is deactivated

Additional info:

Comment 1 Warren Togami 2004-10-21 21:14:29 UTC
I consider this to be similar to Bug #136367 in purpose, however not a
duplicate.

Comment 2 Warren Togami 2004-10-21 21:14:59 UTC
Oops... I mean Bug #135039.

Comment 3 Akira TAGOH 2004-10-21 21:55:15 UTC
Technically, it's a different bug. Bug#135039 is caused due to Escape
key isn't assigned as the hotkey to close. however this isn't related
the hotkey, since you can deactivate IM if the strings isn't in the
preedit buffer.

Comment 4 Akira TAGOH 2004-10-21 22:01:34 UTC
I should look at #135039 first ;) I meant for Bug#136628.
for Bug#135039, since all of keyevent passes through cannaserver on
Canna LE to process the key events. and Escape key wasn't just
assigned a facility to close. FYI :)


Comment 5 Lawrence Lim 2004-10-25 03:43:51 UTC
Version-Release number of selected component (if applicable):
im-sdk-12.1-2

Comment 6 Yu Shao 2004-10-25 03:53:04 UTC
Are all LEs have this problem right now?

Comment 7 Lawrence Lim 2004-10-25 05:12:36 UTC
Not all LE are affected by this problem, but each LEs behave differently.

chinput: 
accepts ctrl-space by switching off but pre-edit buffer is not clear
so next when it is switch on anything that was entered before will be
displayed. bug 132612

xcin and CannaLE:
does not accept ctrl-space

hangul
does not toggle off the LE but it commit the char and move to the next
position.

Comment 8 Lawrence Lim 2004-10-25 05:20:01 UTC
Moving component to CannaLE, will file another bug for xcin LE.


Thanks.

Comment 9 Akira TAGOH 2004-10-25 07:38:30 UTC
Huh? the conversion on/off is notified by
SC_TRIGGER_ON_NOTIFY/SC_TRIGGER_OFF_NOTIFY. I'm saying it's not
delivered if the preedit buffer has something. instead, the hotkey
such as ctrl+space is sent as the usual key event. we could fix this
on LEs. but IMHO it doesn't make sense. what the component should be
fixed is iiimsf.

Comment 10 Leon Ho 2004-11-01 13:47:14 UTC
*** Bug 137016 has been marked as a duplicate of this bug. ***

Comment 12 Akira TAGOH 2004-11-04 09:44:12 UTC
should be fixed in 12.1-5.

Comment 13 Leon Ho 2004-11-04 18:12:27 UTC
Confirmed fixed in 12.1-5


Note You need to log in before you can comment on or make changes to this bug.