Bug 1370410 - [granular entry sh] - Provide a CLI to enable/disable the feature that checks that there are no heals pending before allowing the operation
Summary: [granular entry sh] - Provide a CLI to enable/disable the feature that checks...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: replicate
Version: mainline
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Krutika Dhananjay
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks: 1385474 1398500 1398501
TreeView+ depends on / blocked
 
Reported: 2016-08-26 08:49 UTC by Krutika Dhananjay
Modified: 2017-03-06 17:23 UTC (History)
2 users (show)

Fixed In Version: glusterfs-3.10.0
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1385474 1398500 1398501 (view as bug list)
Environment:
Last Closed: 2017-03-06 17:23:44 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Description Krutika Dhananjay 2016-08-26 08:49:20 UTC
Description of problem:

Same as Summary.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 1 Worker Ant 2016-10-28 07:18:58 UTC
REVIEW: http://review.gluster.org/15747 (cluster/afr: CLI for granular entry heal enablement/disablement) posted (#1) for review on master by Krutika Dhananjay (kdhananj@redhat.com)

Comment 2 Worker Ant 2016-10-28 07:28:03 UTC
REVIEW: http://review.gluster.org/15747 (cluster/afr: CLI for granular entry heal enablement/disablement) posted (#2) for review on master by Krutika Dhananjay (kdhananj@redhat.com)

Comment 3 Worker Ant 2016-11-15 12:10:29 UTC
REVIEW: http://review.gluster.org/15747 (cluster/afr: CLI for granular entry heal enablement/disablement) posted (#3) for review on master by Krutika Dhananjay (kdhananj@redhat.com)

Comment 4 Worker Ant 2016-11-15 12:58:23 UTC
REVIEW: http://review.gluster.org/15747 (cluster/afr: CLI for granular entry heal enablement/disablement) posted (#4) for review on master by Krutika Dhananjay (kdhananj@redhat.com)

Comment 5 Worker Ant 2016-11-17 07:29:43 UTC
REVIEW: http://review.gluster.org/15747 (cluster/afr: CLI for granular entry heal enablement/disablement) posted (#5) for review on master by Krutika Dhananjay (kdhananj@redhat.com)

Comment 6 Worker Ant 2016-11-18 08:03:03 UTC
REVIEW: http://review.gluster.org/15747 (cluster/afr: CLI for granular entry heal enablement/disablement) posted (#6) for review on master by Krutika Dhananjay (kdhananj@redhat.com)

Comment 7 Worker Ant 2016-11-18 10:33:37 UTC
REVIEW: http://review.gluster.org/15747 (cluster/afr: CLI for granular entry heal enablement/disablement) posted (#7) for review on master by Krutika Dhananjay (kdhananj@redhat.com)

Comment 8 Worker Ant 2016-11-18 10:33:40 UTC
REVIEW: http://review.gluster.org/15880 (cluster/afr: Delete granular entry indices of already healed directories during crawl) posted (#1) for review on master by Krutika Dhananjay (kdhananj@redhat.com)

Comment 9 Worker Ant 2016-11-18 16:50:19 UTC
REVIEW: http://review.gluster.org/15747 (cluster/afr: CLI for granular entry heal enablement/disablement) posted (#8) for review on master by Krutika Dhananjay (kdhananj@redhat.com)

Comment 10 Worker Ant 2016-11-21 09:02:24 UTC
REVIEW: http://review.gluster.org/15880 (features/index: Delete granular entry indices of already healed directories during crawl) posted (#2) for review on master by Krutika Dhananjay (kdhananj@redhat.com)

Comment 11 Worker Ant 2016-11-22 05:59:21 UTC
REVIEW: http://review.gluster.org/15747 (cluster/afr: CLI for granular entry heal enablement/disablement) posted (#9) for review on master by Krutika Dhananjay (kdhananj@redhat.com)

Comment 12 Worker Ant 2016-11-23 09:52:21 UTC
REVIEW: http://review.gluster.org/15880 (features/index: Delete granular entry indices of already healed directories during crawl) posted (#3) for review on master by Krutika Dhananjay (kdhananj@redhat.com)

Comment 13 Worker Ant 2016-11-24 08:38:13 UTC
REVIEW: http://review.gluster.org/15880 (features/index: Delete granular entry indices of already healed directories during crawl) posted (#4) for review on master by Krutika Dhananjay (kdhananj@redhat.com)

Comment 14 Worker Ant 2016-11-25 03:03:18 UTC
COMMIT: http://review.gluster.org/15880 committed in master by Pranith Kumar Karampuri (pkarampu@redhat.com) 
------
commit e966fcbc2808eb474ccf83290fe488eb2f10c9d1
Author: Krutika Dhananjay <kdhananj@redhat.com>
Date:   Fri Nov 18 15:38:00 2016 +0530

    features/index: Delete granular entry indices of already healed directories during crawl
    
    If granular name indices are already in existence for a volume, and
    before they are healed, granular entry heal be disabled, a crawl on
    indices/xattrop will clear the changelogs on these directories. When
    their corresponding entry-changes indices are crawled subsequently,
    if it is found that the directories don't need heal anymore, the
    granular indices are not cleaned up.
    This patch fixes that problem by ensuring that the zero-xattrop
    also deletes the stale indices at the level of index translator.
    
    Change-Id: Ifbaa6bec2a14e3041addfee4054131babbf4d35e
    BUG: 1370410
    Signed-off-by: Krutika Dhananjay <kdhananj@redhat.com>
    Reviewed-on: http://review.gluster.org/15880
    Smoke: Gluster Build System <jenkins@build.gluster.org>
    NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
    Reviewed-by: Pranith Kumar Karampuri <pkarampu@redhat.com>
    CentOS-regression: Gluster Build System <jenkins@build.gluster.org>

Comment 15 Worker Ant 2016-11-25 07:32:16 UTC
REVIEW: http://review.gluster.org/15747 (cluster/afr: CLI for granular entry heal enablement/disablement) posted (#10) for review on master by Krutika Dhananjay (kdhananj@redhat.com)

Comment 16 Worker Ant 2016-11-28 07:02:36 UTC
REVIEW: http://review.gluster.org/15747 (cluster/afr: CLI for granular entry heal enablement/disablement) posted (#11) for review on master by Krutika Dhananjay (kdhananj@redhat.com)

Comment 17 Worker Ant 2016-11-28 11:56:38 UTC
COMMIT: http://review.gluster.org/15747 committed in master by Atin Mukherjee (amukherj@redhat.com) 
------
commit 6dfc90fcd36956dcc4f624b3912bfb8e9c95757f
Author: Krutika Dhananjay <kdhananj@redhat.com>
Date:   Thu Sep 22 16:48:54 2016 +0530

    cluster/afr: CLI for granular entry heal enablement/disablement
    
    When there are already existing non-granular indices created that are
    yet to be healed, if granular-entry-heal option is toggled from 'off' to
    'on', AFR self-heal whenever it kicks in, will try to look for granular
    indices in 'entry-changes'. Because of the absence of name indices,
    granular entry healing logic will fail to heal these directories, and
    worse yet unset pending extended attributes with the assumption that
    are no entries that need heal.
    
    To get around this, a new CLI is introduced which will invoke glfsheal
    program to figure whether at the time an attempt is made to enable
    granular entry heal, there are pending heals on the volume OR there
    are one or more bricks that are down. If either of them is true, the
    command will be failed with the appropriate error.
    
    New CLI: gluster volume heal <VOL> granular-entry-heal {enable,disable}
    
    Change-Id: I1f4fe8162813b9068e198965d94169fee4adc099
    BUG: 1370410
    Signed-off-by: Krutika Dhananjay <kdhananj@redhat.com>
    Reviewed-on: http://review.gluster.org/15747
    Smoke: Gluster Build System <jenkins@build.gluster.org>
    Reviewed-by: Pranith Kumar Karampuri <pkarampu@redhat.com>
    NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
    CentOS-regression: Gluster Build System <jenkins@build.gluster.org>
    Reviewed-by: Atin Mukherjee <amukherj@redhat.com>

Comment 18 Shyamsundar 2017-03-06 17:23:44 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.10.0, please open a new bug report.

glusterfs-3.10.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://lists.gluster.org/pipermail/gluster-users/2017-February/030119.html
[2] https://www.gluster.org/pipermail/gluster-users/


Note You need to log in before you can comment on or make changes to this bug.