Bug 1398501 - [granular entry sh] - Provide a CLI to enable/disable the feature that checks that there are no heals pending before allowing the operation
Summary: [granular entry sh] - Provide a CLI to enable/disable the feature that checks...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: replicate
Version: 3.8
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: bugs@gluster.org
QA Contact:
URL:
Whiteboard:
Depends On: 1370410
Blocks: 1385474 1398500
TreeView+ depends on / blocked
 
Reported: 2016-11-25 03:32 UTC by Krutika Dhananjay
Modified: 2016-12-21 23:21 UTC (History)
2 users (show)

Fixed In Version: glusterfs-3.8.7
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 1370410
Environment:
Last Closed: 2016-12-14 07:12:39 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Description Krutika Dhananjay 2016-11-25 03:32:49 UTC
+++ This bug was initially created as a clone of Bug #1370410 +++

Description of problem:

Same as Summary.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

--- Additional comment from Worker Ant on 2016-10-28 03:18:58 EDT ---

REVIEW: http://review.gluster.org/15747 (cluster/afr: CLI for granular entry heal enablement/disablement) posted (#1) for review on master by Krutika Dhananjay (kdhananj@redhat.com)

--- Additional comment from Worker Ant on 2016-10-28 03:28:03 EDT ---

REVIEW: http://review.gluster.org/15747 (cluster/afr: CLI for granular entry heal enablement/disablement) posted (#2) for review on master by Krutika Dhananjay (kdhananj@redhat.com)

--- Additional comment from Worker Ant on 2016-11-15 07:10:29 EST ---

REVIEW: http://review.gluster.org/15747 (cluster/afr: CLI for granular entry heal enablement/disablement) posted (#3) for review on master by Krutika Dhananjay (kdhananj@redhat.com)

--- Additional comment from Worker Ant on 2016-11-15 07:58:23 EST ---

REVIEW: http://review.gluster.org/15747 (cluster/afr: CLI for granular entry heal enablement/disablement) posted (#4) for review on master by Krutika Dhananjay (kdhananj@redhat.com)

--- Additional comment from Worker Ant on 2016-11-17 02:29:43 EST ---

REVIEW: http://review.gluster.org/15747 (cluster/afr: CLI for granular entry heal enablement/disablement) posted (#5) for review on master by Krutika Dhananjay (kdhananj@redhat.com)

--- Additional comment from Worker Ant on 2016-11-18 03:03:03 EST ---

REVIEW: http://review.gluster.org/15747 (cluster/afr: CLI for granular entry heal enablement/disablement) posted (#6) for review on master by Krutika Dhananjay (kdhananj@redhat.com)

--- Additional comment from Worker Ant on 2016-11-18 05:33:37 EST ---

REVIEW: http://review.gluster.org/15747 (cluster/afr: CLI for granular entry heal enablement/disablement) posted (#7) for review on master by Krutika Dhananjay (kdhananj@redhat.com)

--- Additional comment from Worker Ant on 2016-11-18 05:33:40 EST ---

REVIEW: http://review.gluster.org/15880 (cluster/afr: Delete granular entry indices of already healed directories during crawl) posted (#1) for review on master by Krutika Dhananjay (kdhananj@redhat.com)

--- Additional comment from Worker Ant on 2016-11-18 11:50:19 EST ---

REVIEW: http://review.gluster.org/15747 (cluster/afr: CLI for granular entry heal enablement/disablement) posted (#8) for review on master by Krutika Dhananjay (kdhananj@redhat.com)

--- Additional comment from Worker Ant on 2016-11-21 04:02:24 EST ---

REVIEW: http://review.gluster.org/15880 (features/index: Delete granular entry indices of already healed directories during crawl) posted (#2) for review on master by Krutika Dhananjay (kdhananj@redhat.com)

--- Additional comment from Worker Ant on 2016-11-22 00:59:21 EST ---

REVIEW: http://review.gluster.org/15747 (cluster/afr: CLI for granular entry heal enablement/disablement) posted (#9) for review on master by Krutika Dhananjay (kdhananj@redhat.com)

--- Additional comment from Worker Ant on 2016-11-23 04:52:21 EST ---

REVIEW: http://review.gluster.org/15880 (features/index: Delete granular entry indices of already healed directories during crawl) posted (#3) for review on master by Krutika Dhananjay (kdhananj@redhat.com)

--- Additional comment from Worker Ant on 2016-11-24 03:38:13 EST ---

REVIEW: http://review.gluster.org/15880 (features/index: Delete granular entry indices of already healed directories during crawl) posted (#4) for review on master by Krutika Dhananjay (kdhananj@redhat.com)

--- Additional comment from Worker Ant on 2016-11-24 22:03:18 EST ---

COMMIT: http://review.gluster.org/15880 committed in master by Pranith Kumar Karampuri (pkarampu@redhat.com) 
------
commit e966fcbc2808eb474ccf83290fe488eb2f10c9d1
Author: Krutika Dhananjay <kdhananj@redhat.com>
Date:   Fri Nov 18 15:38:00 2016 +0530

    features/index: Delete granular entry indices of already healed directories during crawl
    
    If granular name indices are already in existence for a volume, and
    before they are healed, granular entry heal be disabled, a crawl on
    indices/xattrop will clear the changelogs on these directories. When
    their corresponding entry-changes indices are crawled subsequently,
    if it is found that the directories don't need heal anymore, the
    granular indices are not cleaned up.
    This patch fixes that problem by ensuring that the zero-xattrop
    also deletes the stale indices at the level of index translator.
    
    Change-Id: Ifbaa6bec2a14e3041addfee4054131babbf4d35e
    BUG: 1370410
    Signed-off-by: Krutika Dhananjay <kdhananj@redhat.com>
    Reviewed-on: http://review.gluster.org/15880
    Smoke: Gluster Build System <jenkins@build.gluster.org>
    NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
    Reviewed-by: Pranith Kumar Karampuri <pkarampu@redhat.com>
    CentOS-regression: Gluster Build System <jenkins@build.gluster.org>

Comment 1 Worker Ant 2016-11-25 03:35:06 UTC
REVIEW: http://review.gluster.org/15927 (features/index: Delete granular entry indices of already healed directories during crawl) posted (#1) for review on release-3.8 by Krutika Dhananjay (kdhananj@redhat.com)

Comment 2 Worker Ant 2016-11-26 12:19:11 UTC
COMMIT: http://review.gluster.org/15927 committed in release-3.8 by Pranith Kumar Karampuri (pkarampu@redhat.com) 
------
commit d557d097851d335effe0a2e810ca3f664c30e93f
Author: Krutika Dhananjay <kdhananj@redhat.com>
Date:   Fri Nov 18 15:38:00 2016 +0530

    features/index: Delete granular entry indices of already healed directories during crawl
    
            Backport of: http://review.gluster.org/15880
    
    If granular name indices are already in existence for a volume, and
    before they are healed, granular entry heal be disabled, a crawl on
    indices/xattrop will clear the changelogs on these directories. When
    their corresponding entry-changes indices are crawled subsequently,
    if it is found that the directories don't need heal anymore, the
    granular indices are not cleaned up.
    This patch fixes that problem by ensuring that the zero-xattrop
    also deletes the stale indices at the level of index translator.
    
    Change-Id: Iae0a560c1c9d37b083cad89f16d3dcf83c4f7dc7
    BUG: 1398501
    Signed-off-by: Krutika Dhananjay <kdhananj@redhat.com>
    Reviewed-on: http://review.gluster.org/15927
    Smoke: Gluster Build System <jenkins@build.gluster.org>
    NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
    CentOS-regression: Gluster Build System <jenkins@build.gluster.org>
    Reviewed-by: Pranith Kumar Karampuri <pkarampu@redhat.com>

Comment 3 Worker Ant 2016-11-28 10:13:13 UTC
REVIEW: http://review.gluster.org/15942 (cluster/afr: CLI for granular entry heal enablement/disablement) posted (#1) for review on release-3.8 by Krutika Dhananjay (kdhananj@redhat.com)

Comment 4 Worker Ant 2016-11-29 10:52:28 UTC
COMMIT: http://review.gluster.org/15942 committed in release-3.8 by Pranith Kumar Karampuri (pkarampu@redhat.com) 
------
commit e06f4590616dfe7b93e8ac147ed812756df4f22d
Author: Krutika Dhananjay <kdhananj@redhat.com>
Date:   Thu Sep 22 16:48:54 2016 +0530

    cluster/afr: CLI for granular entry heal enablement/disablement
    
            Backport of: http://review.gluster.org/15747
    When there are already existing non-granular indices created that are
    yet to be healed, if granular-entry-heal option is toggled from 'off' to
    'on', AFR self-heal whenever it kicks in, will try to look for granular
    indices in 'entry-changes'. Because of the absence of name indices,
    granular entry healing logic will fail to heal these directories, and
    worse yet unset pending extended attributes with the assumption that
    are no entries that need heal.
    
    To get around this, a new CLI is introduced which will invoke glfsheal
    program to figure whether at the time an attempt is made to enable
    granular entry heal, there are pending heals on the volume OR there
    are one or more bricks that are down. If either of them is true, the
    command will be failed with the appropriate error.
    
    New CLI: gluster volume heal <VOL> granular-entry-heal {enable,disable}
    
    Change-Id: I342e0390f847fcb015a50ef58aedfcbcb58f4ed3
    BUG: 1398501
    Signed-off-by: Krutika Dhananjay <kdhananj@redhat.com>
    Reviewed-on: http://review.gluster.org/15942
    NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
    Smoke: Gluster Build System <jenkins@build.gluster.org>
    CentOS-regression: Gluster Build System <jenkins@build.gluster.org>
    Reviewed-by: Pranith Kumar Karampuri <pkarampu@redhat.com>

Comment 5 Niels de Vos 2016-12-14 07:12:39 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.8.7, please open a new bug report.

glusterfs-3.8.7 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://www.gluster.org/pipermail/packaging/2016-December/000226.html
[2] https://www.gluster.org/pipermail/gluster-users/

Comment 6 Worker Ant 2016-12-21 23:20:56 UTC
REVIEW: http://review.gluster.org/16239 (features/index: Delete granular entry indices of already healed directories during crawl) posted (#1) for review on release-3.8-fb by Kevin Vigor (kvigor@fb.com)

Comment 7 Worker Ant 2016-12-21 23:21:13 UTC
REVIEW: http://review.gluster.org/16243 (cluster/afr: CLI for granular entry heal enablement/disablement) posted (#1) for review on release-3.8-fb by Kevin Vigor (kvigor@fb.com)


Note You need to log in before you can comment on or make changes to this bug.