Bug 137051 - speedstep driver update
speedstep driver update
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: kernel (Show other bugs)
3.0
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Brian Maly
Brian Brock
: FutureFeature
: 137187 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-10-25 11:57 EDT by Brian Long
Modified: 2007-11-30 17:07 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-04-27 15:00:40 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
lspci -vv output from IBM Thinkpad T42 (8.94 KB, text/plain)
2004-10-25 11:58 EDT, Brian Long
no flags Details

  None (edit)
Description Brian Long 2004-10-25 11:57:05 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.2)
Gecko/20040815

Description of problem:
I would like to request an update of the speedstep driver for power
management on newer laptops.  The current speedstep driver is dated
1/2/03 and has not changed between U2, U3 or U4 beta.  I would like to
request an update for U4 final or even U5 kernel such that newer
Centrino-based latops like the IBM Thinkpad T40 and T42 would be
supported.

The FC2 2.6.x kernel speedstep driver works well on these laptops, but
we'd like RHEL 3's speedstep driver to also work.

Version-Release number of selected component (if applicable):
kernel-2.4.21-21.EL

How reproducible:
Always

Steps to Reproduce:
1. modprobe speedstep
2.
3.
    

Actual Results:  dmesg shows
cpufreq: Intel(R) SpeedStep(TM) for this chipset not (yet) available

Expected Results:  # lsmod | grep speedstep
speedstep               4652   0 (unused)


Additional info:

Older laptops like the IBM Thinkpad T30 work just fine.
Comment 1 Brian Long 2004-10-25 11:58:03 EDT
Created attachment 105730 [details]
lspci -vv output from IBM Thinkpad T42
Comment 2 Ernie Petrides 2004-10-25 16:47:11 EDT
This is a feature request.  U4 is closed (and in beta), by the way.
Comment 3 Suzanne Hillman 2004-10-26 12:11:17 EDT
Internal RFE bug #137187 entered; will be considered for future releases.
Comment 6 Brian Long 2005-01-10 12:20:06 EST
Since I cannot see bug #137187, can I get an update?  Is the speedstep
driver being updated in RHEL 3 Update 5?  Thanks.
Comment 7 Ernie Petrides 2005-01-10 20:36:32 EST
Brian, I've just added you to the cc: list of Featurezilla 137187.
I don't think anyone in Product Management has yet evaluated it.
Comment 8 Brian Long 2005-01-13 11:13:29 EST
Thanks Ernie.  I saw the CC and asked for an update in the FeatureZilla.  :)  Do
you want to mark this BZ closed?
Comment 9 Ernie Petrides 2005-01-13 19:02:41 EST
Good question.  Rob/Suzanne, are we supposed to close BZs that get
associated FZs?  Should I close this as a dup of 137187?
Comment 11 Ernie Petrides 2005-01-17 18:46:06 EST
Brian, I've just learned that our general practice is to keep
bugzilla reports open as long as their associated featurezilla
requests have not yet been resolved.
Comment 12 Brian Long 2005-03-22 08:25:04 EST
What is the status of this BZ?  Did a speedstep update get included in Update 5?
Comment 13 Suzanne Hillman 2005-03-22 11:31:45 EST
Brian - if this is something for which you have urgency, you would be much
better off going through support, as bugzilla is for bug tracking and is not an
avenue for technical assistance or support.

To access support, please go to http://www.redhat.com/support or call 800-REDHAT1
Comment 14 Marty Wesley 2005-05-26 02:41:37 EDT
PM ACK for U6
Comment 15 Brian Maly 2005-06-10 13:36:56 EDT
devel NAK for U6

likely there will be numerous TSC issues to work out, too involved and time
consuming to be done by U6

Comment 16 Brian Maly 2005-06-10 13:46:14 EDT
INFO: there is a 2.4.21 patchset that includes cpufreq for centrino. its for the
mainstream kernel but can probably be used to generate a RHEL3 patch

http://kernel.org/pub/linux/kernel/people/alan/linux-2.4/2.4.21/patch-2.4.21-ac2.gz
Comment 18 Ernie Petrides 2006-05-12 13:32:02 EDT
*** Bug 137187 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.