Bug 137187 - RHEL3 U5: speedstep driver update
Summary: RHEL3 U5: speedstep driver update
Status: CLOSED DUPLICATE of bug 137051
Alias: None
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: kernel   
(Show other bugs)
Version: 3.0
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Daniel Riek
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-10-26 16:10 UTC by Suzanne Hillman
Modified: 2007-11-30 22:07 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-05-12 17:29:21 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
lspci -vv output from IBM Thinkpad T42 (8.94 KB, text/plain)
2004-10-26 16:10 UTC, Suzanne Hillman
no flags Details

Description Suzanne Hillman 2004-10-26 16:10:15 UTC
Opened by Brian Long  	 on 2004-10-25 11:57 EST  	[reply]

From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.2)
Gecko/20040815

Description of problem:
I would like to request an update of the speedstep driver for power
management on newer laptops.  The current speedstep driver is dated
1/2/03 and has not changed between U2, U3 or U4 beta.  I would like to
request an update for U4 final or even U5 kernel such that newer
Centrino-based latops like the IBM Thinkpad T40 and T42 would be
supported.

The FC2 2.6.x kernel speedstep driver works well on these laptops, but
we'd like RHEL 3's speedstep driver to also work.

Version-Release number of selected component (if applicable):
kernel-2.4.21-21.EL

How reproducible:
Always

Steps to Reproduce:
1. modprobe speedstep
2.
3.
    

Actual Results:  dmesg shows
cpufreq: Intel(R) SpeedStep(TM) for this chipset not (yet) available

Expected Results:  # lsmod | grep speedstep
speedstep               4652   0 (unused)


Additional info:

Older laptops like the IBM Thinkpad T30 work just fine.

Comment 1 Suzanne Hillman 2004-10-26 16:10:48 UTC
Created attachment 105799 [details]
lspci -vv output from IBM Thinkpad T42

Comment 2 Brian Long 2005-01-13 16:08:41 UTC
Thank you for adding me to the CC list.  Is this feature being planned for the
U5 kernel or is the U5 kernel already frozen?

Comment 3 Ernie Petrides 2005-01-13 23:59:23 UTC
Kernel changes are still being made to U5, although I'm not sure whether the
U5 requirements are now frozen.  Rob/Peter, could you please follow up here?


Comment 4 Robert Perkins 2005-01-18 15:42:13 UTC
I am reassigning to dff; this is a laptop issue.  But, in general, the info at
http://lacrosse.corp.redhat.com/rhs/pm/docs/prodmgmt/process/feature_template_v2.txt
has a guide that should provide the needed info.  

Comment 5 David Lawrence 2006-03-03 18:38:21 UTC
The bug status ASSIGN_TO_PM has been deprecated. In the future please use
ASSIGNED and either add the PM to the Cc list or re-assign report to them.

Comment 6 Brian Long 2006-05-12 12:02:48 UTC
Feel free to close this bug since we dropped this RFE in favor of using RHEL 4.

Comment 7 Ernie Petrides 2006-05-12 17:29:21 UTC
Closing as WONTFIX based on last comment.

Comment 8 Ernie Petrides 2006-05-12 17:31:29 UTC

*** This bug has been marked as a duplicate of 137051 ***


Note You need to log in before you can comment on or make changes to this bug.