Bug 137166 - xorg and machine crash with ati radeon 7000 driver
xorg and machine crash with ati radeon 7000 driver
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
3
i686 Linux
medium Severity high
: ---
: ---
Assigned To: X/OpenGL Maintenance List
: Triaged
Depends On:
Blocks: FC4Target
  Show dependency treegraph
 
Reported: 2004-10-26 09:26 EDT by Stefano Ruberti
Modified: 2007-11-30 17:10 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-02-07 20:30:06 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
xorg.conf (2.80 KB, text/plain)
2004-11-11 04:18 EST, Stefano Ruberti
no flags Details
Xorg.0.log (38.67 KB, text/plain)
2004-11-11 04:20 EST, Stefano Ruberti
no flags Details
messages (180.20 KB, text/plain)
2004-11-11 04:22 EST, Stefano Ruberti
no flags Details

  None (edit)
Description Stefano Ruberti 2004-10-26 09:26:03 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; rv:1.7.3) Gecko/20041020
Firefox/0.10.1

Description of problem:
Every time I boot my machine in gaphic modo (xdm or with startx
command)  , the machine crash. 
I'm uograde my linux box form fedora core 2 to fedora core 3 test 3
upgraded with the testing packages from a following repository:
baseurl=http://testing.fedora.redhat.com/tree//$basearch/os/

Before upgrading the system with the testing packages gnome crash
every time, but kde it worked correctly.  Now the machine crash with
whichever window manager. I try to use kde, gnome  and xfce.

Now I use my linux box with build-in Intel graphic card without any
problem.



Version-Release number of selected component (if applicable):
xorg-x11-6.8.1-12

How reproducible:
Always

Steps to Reproduce:
1. boot
2. login at runlevel 3 and run startx command,
3. or start at runlevel 5 and login 
    

Actual Results:  The linux box (HP Compaq d530 CMT) crash every time I
try to use a radeon 7000 graphic card

Additional info:
Comment 1 Ronny Buchmann 2004-11-09 13:41:40 EST
What kernel do you use?

I have the same symptoms, but only with SMP kernel (2.6.9-1.677
currently). With UP kernel there are no problems.

graphics is a Radeon 7000 VE.

There are no messages from kernel or X11. Alt-Sysrq is not working
(even from serial console).
Comment 2 Stefano Ruberti 2004-11-10 02:42:53 EST
I try till kernel-smp-2.6.9-1.649.
I would have to try the last version distributed with the definitive
version of fedora Core 3 (kernel-smp-2.6.9-1.667)

I have tried also some snaphoot versions of the radeon driver
downloaded from www.freedektop.org till the version
radeon-20041105-linux.i386.tar.bz2

Comment 3 Stefano Ruberti 2004-11-10 04:15:08 EST
I try now the latest snapshhot driver radeon-20041109-linux.i386.tar.bz2 
on fedora core 3 official release with kernel-smp-2.6.9-1.667, but the
problem persist.

Comment 4 Ronny Buchmann 2004-11-10 13:25:47 EST
Did you try with non-SMP kernel?

Please change component to kernel, as it seems clearly a kernel bug.
Comment 5 Mike A. Harris 2004-11-10 18:00:15 EST
Stefano:

Please attach your X server config file, log file, and
/var/log/messages file from a failed X session to the bug
report as individual uncompressed file attachments.  Once
we've reviewed this info, we'll try to diagnose the issue,
and if it turns out to be a kernel related issue we'll
reassign it to the kernel at that stage.

When doing this testing, make absolutely sure you are using
the Fedora Core 3 kernel binary, and Red Hat supplied xorg-x11
rpms and drivers.  Do not use 3rd party drivers as indicated
above.

Thanks in advance.
Comment 6 Stefano Ruberti 2004-11-11 04:18:12 EST
Created attachment 106481 [details]
xorg.conf
Comment 7 Stefano Ruberti 2004-11-11 04:20:07 EST
Created attachment 106482 [details]
Xorg.0.log
Comment 8 Stefano Ruberti 2004-11-11 04:22:20 EST
Created attachment 106483 [details]
messages
Comment 9 Stefano Ruberti 2004-11-11 04:23:24 EST
Confirm that I use a binary kernel distribiuted bye Fedora Core 3.
Now I test my radeon card with the official driver distribiuted with
xorg-x11 rpms in fedora Core 3.

Comment 10 Stefano Ruberti 2004-11-11 04:24:37 EST
The problem persist again.
Comment 11 Ronny Buchmann 2004-11-11 16:05:35 EST
If I disable dri, smp kernel works fine.

Only interesting logs before crash with dri enabled:
Nov 11 21:22:25 bserv kernel: mtrr: 0xe0000000,0x2000000 overlaps
existing 0xe0000000,0x200000
Nov 11 21:22:25 bserv kernel: mtrr: 0xe0000000,0x2000000 overlaps
existing 0xe0000000,0x200000
Nov 11 21:22:25 bserv kernel: agpgart: Found an AGP 3.0 compliant
device at 0000:00:00.0.
Nov 11 21:22:25 bserv kernel: agpgart: Device is in legacy mode,
falling back to 2.x
Nov 11 21:22:25 bserv kernel: agpgart: Putting AGP V2 device at
0000:00:00.0 into 4x mode
Nov 11 21:22:25 bserv kernel: agpgart: Putting AGP V2 device at
0000:01:00.0 into 4x mode

but the crash is several seconds later (with varying delays)
Comment 12 Ronny Buchmann 2004-11-11 16:37:39 EST
http://news.gw.com/freebsd.x11/769 sounds similar
Comment 13 Ronny Buchmann 2004-12-07 13:47:35 EST
X with dri works fine for me with xorg-x11-6.8.1-12.FC3.21 and 
kernel-smp-2.6.9-1.698_FC3.
Comment 14 Ronny Buchmann 2004-12-11 17:32:55 EST
My last comment was a bit too early, freeze has happend after 4 days
running X.
Comment 15 Mike A. Harris 2005-02-01 05:53:37 EST
Please ensure your system is fully updated with all released
Fedora Core 3 updates, including the kernel, and that you're
rebooted into our most recent kernel update.  After this, please
update to the xorg-x11-6.8.1.903 or later rpms from rawhide, and
see if they resolve the issue, as this will soon become 6.8.2,
which we will be releasing as an update for FC3.

If this issue turns out to still be reproduceable in the latest
rawhide xorg-x11, please file a bug report in the X.Org
bugzilla located at http://bugs.freedesktop.org in the "xorg"
component.

Once you've filed your bug report to X.Org, if you paste the new
bug URL here, Red Hat will continue to track the issue in the
centralized X.Org bug tracker, and will review any bug fixes that
become available for consideration in future updates.
Comment 16 Mike A. Harris 2005-02-01 05:57:36 EST
Setting status to "NEEDINFO", awaiting rawhide xorg testing, and
upstream bug URL.
Comment 17 Ronny Buchmann 2005-02-01 13:43:15 EST
My system is now fully stable with kernel-smp-2.6.10-1.741_FC3 and
xorg-x11-6.8.1-12.FC3.21.

I can also try to check xorg-x11 from rawhide if you want.
Comment 18 Ronny Buchmann 2005-02-02 02:37:06 EST
xorg-x11-6.8.1.903-2 is OK too.
Comment 19 Stefano Ruberti 2005-02-02 05:05:43 EST
Also on my system with kernel-smp-2.6.10-1.741_FC3 and
xorg-x11-6.8.1-12.FC3.21 It's work fine. :-)

Best regards.
Comment 20 Mike A. Harris 2005-02-07 20:30:06 EST
Ok, thanks for testing and providing updates.  Setting status
to "RAWHIDE".
Comment 21 Patrick Monnerat 2005-04-20 16:31:30 EDT
Please, reopen the bug, because it happens with the following update RPMS:
kernel-smp-2.6.11-1.14_FC3
xorg-x11-6.8.2-1.FC3.13
and Video board
01:00.0 VGA compatible controller: ATI Technologies Inc Radeon RV100 QY [Radeon
7000/VE]

as stated above, if I use the non-smp kernel, or disable DRI, it is OK.
Else it freezes at the end of Gnome login (initialisation) sequence.
The mouse cursor is freezed (interrupts off?)
Kernel has probably panicked , but I cant see the text mode console at this time...
Comment 22 Mike A. Harris 2005-04-21 00:04:31 EDT
The original reporter stated in comment #19 the problem he reported is
resolved.  Unless he is experiencing the issue again in the same
version you've indicated you're having a problem with, then your issue
has perhaps similar symptoms, but is likely a separate unrelated
issue.

Upgrade to xorg-x11 from rawhide, which has numerous additional
Radeon driver fixes also reported to fix issues similar in nature.
If the problem still persists in rawhide xorg-x11, then please
file a new bug report in X.Org bugzilla at http://bugs.freedesktop.org
in the "xorg" component, and include all relevant details in the X.Org bug
report.  If you paste the URL here, we will track the issue in your upstream
X.Org bug report and review any fixes that become available for possible
inclusion in future updates.

Hope this helps.

Note You need to log in before you can comment on or make changes to this bug.