Bug 1372052 - Unable to search certificate requests using the latest request ID
Summary: Unable to search certificate requests using the latest request ID
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: pki-core
Version: 7.3
Hardware: Unspecified
OS: Unspecified
high
unspecified
Target Milestone: rc
: ---
Assignee: RHCS Maintainers
QA Contact: Asha Akkiangady
Petr Bokoc
URL:
Whiteboard:
Depends On:
Blocks: 1417064
TreeView+ depends on / blocked
 
Reported: 2016-08-31 19:33 UTC by Matthew Harmsen
Modified: 2020-10-04 21:14 UTC (History)
12 users (show)

Fixed In Version: pki-core-10.4.0-1.el7
Doc Type: Bug Fix
Doc Text:
CA web interface no longer shows a blank certificate request page if there is only one entry Previously, when the certificate request page in the CA web user interface only contained one entry, it displayed an empty page instead of showing the single entry. This update fixes the web user interface, and the certificate request page now correctly shows entries in all circumstances.
Clone Of:
: 1417064 (view as bug list)
Environment:
Last Closed: 2017-08-01 22:46:01 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github dogtagpki pki issues 2570 0 None None None 2020-10-04 21:14:28 UTC
Red Hat Product Errata RHBA-2017:2110 0 normal SHIPPED_LIVE pki-core bug fix and enhancement update 2017-08-01 19:36:59 UTC

Description Matthew Harmsen 2016-08-31 19:33:51 UTC
The List Requests page in the CA UI for agents is supposed to show the list of requests given the starting request number. However, if the starting request number is set to the latest request ID, the page will return no results.

Steps to reproduce:

  1. Install CA as usual.
  2. Initialize PKI client: pki -c Secret123 client-init
  3. Request a certificate: pki -c Secret123 client-cert-request uid=testuser
  4. Go to CA UI for agents and open the List Requests page.
  5. Enter the request ID obtained from step #3 as the starting request number,
     then click Find. 

Actual result: The page says No Matching Request Records Found.

Expected result: The page should show the normal list of requests showing just the latest request.

Note: If a smaller request number is entered in step #5, the page will show the normal list of requests.

Comment 1 Matthew Harmsen 2016-08-31 19:35:25 UTC
Per PKI Bug Council of 08/31/2016:
* Consider this bug for a RHEL 7.3 Batch 1 Update Candidate

Comment 2 Matthew Harmsen 2016-11-30 17:50:55 UTC
please provide RHEL 7.3.Z ZStream flag and justification

Comment 3 Nathan Kinder 2016-11-30 19:17:23 UTC
(In reply to Matthew Harmsen from comment #2)
> please provide RHEL 7.3.Z ZStream flag and justification

This issue is being encountered by Booz-Allen Hamilton.  They are hoping for a fix as a z-stream update since it affects their operations.  This does seem like something we should address before RHEL 7.4.

Comment 4 Endi Sukma Dewata 2017-01-27 02:49:44 UTC
Fixed in master:
* 755fb2834d22131628ad1929c1bd4b1cd7592203

Fixed in DOGTAG_10_3_BRANCH:
* 196ae21e55a3210ef9db1ad6b8c84d64d4d1959e

Comment 6 Geetika Kapoor 2017-02-02 07:50:04 UTC
Testing Environment:
-------------------

rpm -qa pki-ca
pki-ca-10.3.3-17.el7_3.noarch

Test Steps:
---------

1. Generate one certificate request from either cli or EE page.
Here my request id's  are "7","8","9".
2. Import the right cert used to login into CA Agent page.
3. Goto list requests.
4. Set Request type "show enrollment request"
5. Set request Status "show Pending Request"
 

Test Cases:
----------

1. Set Stating request number as "7".

Expected:It should show all 7 and above.
Actual: It shows 7,8,9 in CA Agent page.

2. Set starting request number as "8"

Expected:It should show all 8 and above.
Actual:It shows 8,9 in CA Agent page

3. set Starting request number as "9"

Expected: it should only show 9 
Actual:it only shows 9 in CA Agent Page

4. Set Starting request number as "20" which doesn't exist.

Expected: No records match should come.
Actual: CA Agent page shows last pending request in queue i.e 9.
        This is not expected.Putting BZ in needinfo

Comment 7 Geetika Kapoor 2017-02-02 07:51:14 UTC
Could you please have a look on my test case 4 :


4. Set Starting request number as "20" which doesn't exist.

Expected: No records match should come.
Actual: CA Agent page shows last pending request in queue i.e 9.
        This is not expected.Putting BZ in needinfo

Comment 8 Endi Sukma Dewata 2017-02-16 18:07:24 UTC
I responded to this question in bug #1417064.

I believe the behavior shown in test case #4 (showing too many results) is an existing issue, not a regression. The changes in comment #3 fixed test case #3 (showing no results) which was the primary issue reported in this bug. Test cases #1 and #2 have always been working correctly.

Geetika already opened a new ticket for test case #4:
https://bugzilla.redhat.com/show_bug.cgi?id=1422799

Comment 10 Geetika Kapoor 2017-05-03 05:44:04 UTC
performed test cases as mentioned in comment #6. All worked as expected with an exception for which BZ https://bugzilla.redhat.com/show_bug.cgi?id=1422799 is raised.

Test builds:
rpm -qa pki-ca
pki-ca-10.4.1-2.el7.noarch

Comment 11 errata-xmlrpc 2017-08-01 22:46:01 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2017:2110


Note You need to log in before you can comment on or make changes to this bug.