Bug 1417064 - Unable to search certificate requests using the latest request ID
Summary: Unable to search certificate requests using the latest request ID
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: pki-core
Version: 7.3
Hardware: Unspecified
OS: Unspecified
high
unspecified
Target Milestone: rc
: ---
Assignee: RHCS Maintainers
QA Contact: Asha Akkiangady
URL:
Whiteboard:
Depends On: 1372052
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-01-27 07:21 UTC by Jaroslav Reznik
Modified: 2017-03-02 17:26 UTC (History)
13 users (show)

Fixed In Version: pki-core-10.3.3-17.el7_3
Doc Type: No Doc Update
Doc Text:
undefined
Clone Of: 1372052
Environment:
Last Closed: 2017-03-02 17:26:42 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2017:0389 0 normal SHIPPED_LIVE pki-core bug fix and enhancement update 2017-03-02 22:06:41 UTC

Description Jaroslav Reznik 2017-01-27 07:21:04 UTC
This bug has been copied from bug #1372052 and has been proposed
to be backported to 7.3 z-stream (EUS).

Comment 3 Matthew Harmsen 2017-01-28 01:53:10 UTC
Cherry-picked to DOGTAG_10_3_RHEL_BRANCH from DOGTAG_10_3_BRANCH:
* e1ae89e9f110cf4af75f6ea82a38a9ce085617ac

Cherry-picked to DOGTAG_10_3_RHEL_UNRELEASED_BRANCH from DOGTAG_10_3_BRANCH:
* 323f3dc856eb7ed397e3b2f429851ac9a5b6dd20

Comment 5 Geetika Kapoor 2017-02-03 06:21:00 UTC

Testing Environment:
-------------------

rpm -qa pki-ca
pki-ca-10.3.3-17.el7_3.noarch

Test Steps:
---------

1. Generate one certificate request from either cli or EE page.
Here my request id's  are "7","8","9".
2. Import the right cert used to login into CA Agent page.
3. Goto list requests.
4. Set Request type "show enrollment request"
5. Set request Status "show Pending Request"
 

Test Cases:
----------

1. Set Stating request number as "7".

Expected:It should show all 7 and above.
Actual: It shows 7,8,9 in CA Agent page.

2. Set starting request number as "8"

Expected:It should show all 8 and above.
Actual:It shows 8,9 in CA Agent page

3. set Starting request number as "9"

Expected: it should only show 9 
Actual:it only shows 9 in CA Agent Page

4. Set Starting request number as "20" which doesn't exist.

Expected: No records match should come.
Actual: CA Agent page shows last pending request in queue i.e 9.
        This is not expected.Putting BZ in needinfo


Could you please have a look on my test case 4 :


4. Set Starting request number as "20" which doesn't exist.

Expected: No records match should come.
Actual: CA Agent page shows last pending request in queue i.e 9.
        This is not expected.Putting BZ in needinfo

Comment 6 Endi Sukma Dewata 2017-02-15 18:05:28 UTC
I believe the behavior shown in test case #4 (showing too many results) is an existing issue, not a regression. The changes in comment #3 fixed test case #3 (showing no results) which was the primary issue reported in this bug. Test cases #1 and #2 have always been working correctly.

I'd suggest opening a separate bug for test case #4 for a future release since the problem is not as bad.

Comment 7 Geetika Kapoor 2017-02-16 09:45:20 UTC
Thanks Endi!!I will mark this bug verified and raise a separate bug for test Case#4.  
https://bugzilla.redhat.com/show_bug.cgi?id=1422799

Comment 9 errata-xmlrpc 2017-03-02 17:26:42 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2017-0389.html


Note You need to log in before you can comment on or make changes to this bug.