Bug 1372134 - [RFE] hosted-engine deployment should support IPv6
Summary: [RFE] hosted-engine deployment should support IPv6
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-hosted-engine-setup
Version: 4.0.0
Hardware: x86_64
OS: Linux
high
medium
Target Milestone: ovirt-4.3.0
: ---
Assignee: Simone Tiraboschi
QA Contact: Michael Burman
URL:
Whiteboard:
Depends On: 1571216 1618676
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-09-01 01:45 UTC by Tom Gamull
Modified: 2020-08-03 15:34 UTC (History)
14 users (show)

Fixed In Version: ovirt-hosted-engine-setup-2.3.0
Doc Type: Enhancement
Doc Text:
The current release of the self-hosted engine supports deployment with static IPv6.
Clone Of:
Environment:
Last Closed: 2019-05-08 12:32:03 UTC
oVirt Team: Integration
Target Upstream Version:
lsvaty: testing_plan_complete-


Attachments (Terms of Use)
RHVH using self-hosted, tried GUI and command line (6.13 MB, application/x-xz)
2016-09-01 01:45 UTC, Tom Gamull
no flags Details
vdsm logs from RHEL7.2 same issue (77.60 KB, application/zip)
2016-09-01 01:49 UTC, Tom Gamull
no flags Details


Links
System ID Private Priority Status Summary Last Updated
oVirt gerrit 93367 0 master MERGED ipv6: support support pure ipv6 deployments 2020-03-09 10:09:43 UTC
oVirt gerrit 96119 0 master MERGED ipv6: configure the ipv6 bootstrap network as an isolated one 2020-03-09 10:09:43 UTC

Description Tom Gamull 2016-09-01 01:45:51 UTC
Created attachment 1196574 [details]
RHVH using self-hosted, tried GUI and command line

Description of problem:
using either RHEL7.2 or RHV4H, the hosted-engine --deploy will stall on "Waiting for VDSM to reply" on certain servers. In this case an HP DL180SE G6 using a single NIC.

Version-Release number of selected component (if applicable):
RHV 4.0
otopi-1.5.1-3.el7ev

How reproducible:
run hosted-engine --deploy following instructions for self-hosted engine (same result on RHEL 7.2 and RHVH)

Steps to Reproduce:
1. Install RHEL7.2 (register system, disable repos all, enable repos, yum update, reboot)
2. yum install ovirt-hosted-engine-setup
3. yum install rheum-appliance
4. hosted-engine --deploy

Actual results:
[root@virt01 ~]# hosted-engine --deploy
/usr/lib/python2.7/site-packages/ovirt_hosted_engine_ha/lib/storage_backends.py:15: DeprecationWarning: vdscli uses xmlrpc. since ovirt 3.6 xmlrpc is deprecated, please use vdsm.jsonrpcvdscli
  import vdsm.vdscli
[ INFO  ] Stage: Initializing
[ INFO  ] Generating a temporary VNC password.
[ INFO  ] Stage: Environment setup
          During customization use CTRL-D to abort.
          Continuing will configure this host for serving as hypervisor and create a VM where you have to install the engine afterwards.
          Are you sure you want to continue? (Yes, No)[Yes]: 
          It has been detected that this program is executed through an SSH connection without using screen.
          Continuing with the installation may lead to broken installation if the network connection fails.
          It is highly recommended to abort the installation and run it inside a screen session using command "screen".
          Do you want to continue anyway? (Yes, No)[No]: Yes
[ INFO  ] Hardware supports virtualization
          Configuration files: []
          Log file: /var/log/ovirt-hosted-engine-setup/ovirt-hosted-engine-setup-20160831185022-gspw2x.log
          Version: otopi-1.5.1 (otopi-1.5.1-3.el7ev)
[ INFO  ] Stage: Environment packages setup
[ INFO  ] Stage: Programs detection
[ INFO  ] Stage: Environment setup
[ INFO  ] Waiting for VDSM to reply
[ INFO  ] Waiting for VDSM to reply
[ INFO  ] Waiting for VDSM to reply
^C[ ERROR ] Failed to execute stage 'Environment setup': SIG2
[ INFO  ] Stage: Clean up
[ INFO  ] Generating answer file '/var/lib/ovirt-hosted-engine-setup/answers/answers-20160831185041.conf'
[ INFO  ] Stage: Pre-termination
[ INFO  ] Stage: Termination
[ ERROR ] Hosted Engine deployment failed
          Log file is located at /var/log/ovirt-hosted-engine-setup/ovirt-hosted-engine-setup-20160831185022-gspw2x.log



Expected results:
[root@virt01 ~]# hosted-engine --deploy
/usr/lib/python2.7/site-packages/ovirt_hosted_engine_ha/lib/storage_backends.py:15: DeprecationWarning: vdscli uses xmlrpc. since ovirt 3.6 xmlrpc is deprecated, please use vdsm.jsonrpcvdscli
  import vdsm.vdscli
[ INFO  ] Stage: Initializing
[ INFO  ] Generating a temporary VNC password.
[ INFO  ] Stage: Environment setup
          During customization use CTRL-D to abort.
          Continuing will configure this host for serving as hypervisor and create a VM where you have to install the engine afterwards.
          Are you sure you want to continue? (Yes, No)[Yes]: 
          It has been detected that this program is executed through an SSH connection without using screen.
          Continuing with the installation may lead to broken installation if the network connection fails.
          It is highly recommended to abort the installation and run it inside a screen session using command "screen".
          Do you want to continue anyway? (Yes, No)[No]: Yes
[ INFO  ] Hardware supports virtualization
          Configuration files: []
          Log file: /var/log/ovirt-hosted-engine-setup/ovirt-hosted-engine-setup-20160831214326-ef4m1v.log
          Version: otopi-1.5.1 (otopi-1.5.1-3.el7ev)
[ INFO  ] Stage: Environment packages setup
[ INFO  ] Stage: Programs detection
[ INFO  ] Stage: Environment setup
[WARNING] Cannot locate gluster packages, Hyper Converged setup support will be disabled.
[ INFO  ] Please abort the setup and install vdsm-gluster, gluster-server >= 3.7.2 and restart vdsmd service in order to gain Hyper Converged setup support.
[ INFO  ] Stage: Environment customization
         
          --== STORAGE CONFIGURATION ==--
         
          Please specify the storage you would like to use (glusterfs, iscsi, fc, nfs3, nfs4)[nfs3]: 

Additional info:
Disabling IPV6 on all interfaces via sysctl.conf is a workaround.
Same method succeed on older AMD servers
Attached is an SOS from a RHVH4 install I ran sosreport on.  I have logs for RHEL7.2 also available.
Seems identical to this - http://lists.ovirt.org/pipermail/users/2016-July/041110.html

Comment 1 Tom Gamull 2016-09-01 01:49:20 UTC
Created attachment 1196575 [details]
vdsm logs from RHEL7.2 same issue

Comment 5 Michael Burman 2019-02-27 09:18:30 UTC
Verified on - ovirt-hosted-engine-setup-2.3.5-1.el7ev.noarch
ovirt-hosted-engine-ha-2.3.1-1.el7ev.noarch
ovirt-ansible-hosted-engine-setup-1.0.11-1.el7ev.noarch
4.3.1.1-0.1.el7
vdsm-4.30.9-1.el7ev.x86_64
using rhvh-4.3.0.5-0.20190225.0+1 and rhvm-appliance-4.3-20190220.2.el7.x86_64

Verified with and over an IPv6 static address only

Comment 7 errata-xmlrpc 2019-05-08 12:32:03 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2019:1050


Note You need to log in before you can comment on or make changes to this bug.