Bug 137261 - Evolution fails to prompt for new POP server password
Summary: Evolution fails to prompt for new POP server password
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: evolution   
(Show other bugs)
Version: 3
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Dave Malcolm
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-10-27 01:06 UTC by Phil Schaffner
Modified: 2007-11-30 22:10 UTC (History)
1 user (show)

Fixed In Version: 2.0.4-4
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-09-19 13:05:25 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Phil Schaffner 2004-10-27 01:06:37 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.3)
Gecko/20040922

Description of problem:
When using "Remember password" setting and password is changed on pop
server, evolution returns immediately with no error message or
indication of authentication failure.

Version-Release number of selected component (if applicable):
evolution-2.0.2-1

How reproducible:
Always

Steps to Reproduce:
1. Change password on pop server
2. Check mail with evolution
3.
    

Actual Results:  Fails to fetch new mail, indicate error, or prompt
for new password.

Expected Results:  Should prompt for new pop server password.


Additional info:

Work-around is to delete the line for the server in
~/.gnome2_private/Evolution

Comment 1 Colin Charles 2004-11-08 01:33:13 UTC
It does give an error message, but nothing along the lines of "your
password is wrong". It just says the operation is currently in
progress, which doesn't tell me its a bad password

This bug is present in FC3

Comment 2 Phil Schaffner 2004-11-10 15:35:57 UTC
I get no error message.  Progress window pops up like it is checking
mail, successfully checks another server, but returns immediately for
the one with the changed password.  Now running evolution-2.0.2-3


Comment 3 Dave Malcolm 2005-08-23 01:18:50 UTC
I'm sorry that this bug has gone for so long without activity.

Are you still experiencing this problem?  Have you tried more recent versions of
Evolution?

Comment 4 Colin Charles 2005-08-23 07:32:02 UTC
Looks fixed in FC-4:

Unable to connect to POP server my.mail.server.
Error sending password: -ERR Login failed.

Please enter the POP password for byte on host my.mail.server

Enter the new password, and alls well. Toggle for Remember this password is also
present. Kudos.

I'll wait for OR to report back, before closing it out

Comment 5 Phil Schaffner 2005-09-19 13:05:25 UTC
Sorry to be slow getting back.  Still playing catchup after summer vacation and
other absences.  I'll be happy if this makes it into RHEL4.  It does now work on
a custom rebuild of FC3 2.0.4 on the RHEL4-rebuild I'm currently running (after
jumping off the Fedora ship due to the rapid pace of change) so changing to
RESOLVED/CURRENTRELEASE.


Note You need to log in before you can comment on or make changes to this bug.