Bug 137279 - up2date --help gives traceback
up2date --help gives traceback
Status: CLOSED DUPLICATE of bug 138451
Product: Fedora
Classification: Fedora
Component: up2date (Show other bugs)
3
All Linux
medium Severity high
: ---
: ---
Assigned To: Adrian Likins
Max Spevack
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-10-27 03:37 EDT by Folke Lemaitre
Modified: 2007-11-30 17:10 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 14:06:38 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Folke Lemaitre 2004-10-27 03:37:11 EDT
Description of problem:

When issuing "up2date --help", the a traceback is displayed, due to a
typo in /usr/sbin/up2date, line 89.
Fix by changing:
OptionParser.print_help(self, file) -> OptionParser.print_help(self,
filed)

Version-Release number of selected component (if applicable):
4.3.46-1

How reproducible:
always

Steps to Reproduce:
1. up2date --help
2.
3.
  
Actual results:
Traceback (most recent call last):
  File "/usr/sbin/up2date", line 1248, in ?
    sys.exit(main() or 0)
  File "/usr/sbin/up2date", line 355, in main
    (options, pkgNames) = optparser.parse_args()
  File "/usr/lib/python2.3/optparse.py", line 1129, in parse_args
    stop = self._process_args(largs, rargs, values)
  File "/usr/lib/python2.3/optparse.py", line 1169, in _process_args
    self._process_long_opt(rargs, values)
  File "/usr/lib/python2.3/optparse.py", line 1244, in _process_long_opt
    option.process(opt, value, values, self)
  File "/usr/lib/python2.3/optparse.py", line 611, in process
    return self.take_action(
  File "/usr/lib/python2.3/optparse.py", line 632, in take_action
    parser.print_help()
  File "/usr/sbin/up2date", line 89, in print_help
    OptionParser.print_help(self, file)
  File "/usr/lib/python2.3/optparse.py", line 1370, in print_help
    file.write(self.format_help())
TypeError: descriptor 'write' requires a 'file' object but received a
'str'


Expected results:
usage: up2date [OPTIONS] [<packages>]

options:
  --configure           configure Update Agent options
  -d, --download        download packages only, even if configuration
says to
                        install
  -i, --install         install packages, even if configuration says to
                        download only
  --src                 Download src packages as well as binary rpms
  --nosrc               Do not download src packages (overrides config
setting
                        if set)
  --dbpath=<dir>        Specify a path where an alternate rpm db is found
  -f, --force           Force package installation, overriding package
and file
                        skip list
  --justdb              Only add packages to database, do not install
to the
                        filesystem
  -l, --list            list packages available for retrieval
  --dry-run             Do everything but download and install
packages (show
                        dependencies  needed, etc)
  -?, --usage           Briefly describe the options
  -k<dir>, --packagedir=<dir>
                        colon separated path of directories to look in for
                        packages
  --nosig               do not use GPG to check package signatures
  --nox                 do not attempt to use X
  -p, --packages        update packages associated with this System
Profile on
                        Red Hat Network
  --hardware            up2date hardware profile associated with this
System
                        Profile on Red Hat Network
  --register            register the system (or reregister it, if need be)
  --showall             List all packages available for download
  --show-available      List all packages available that are not currently
                        installed
  --show-orphans        List all packages currently installed that are
not in
                        channels the system is subscribed to
  --show-groups         List all the install components available to
install
  --solvedeps=<deps>    finds, downloads, and installs the packages
needed to
                        solve the list of dependencies
  --tmpdir=<temp-dir>   where to store temporary files / RPMs
  --undo                undo the last package set update
  -u, --update          update system with all relevant packages
  --version             show program version information
  -v, --verbose         Show additional output
  --show-channels       Show the channel names along with the package name
                        where approriate
  --list-rollbacks      Show the rpm rollbacks available
  --whatprovides=<deps>
                        Show the packages which solve the comma
separated list
                        of dependencies
  --installall          Install all available packages. Used with
--channel
  --exclude=<pkg>       List of packages to exlude from being installed or
                        updated
  --channel=<channel>   Specify which channels to use by channel label
  --gpg-flags           Show the flags that gpg will be invoked with (the
                        keyring, etc)
  --nodownload          Do not download packages at all. For testing
purposes
  --uuid=<uuid>         Pass in a uuid that the applet generates
  --proxy=<proxyurl>    Specify an http proxy to use
  --proxyUser=<proxy userid>
                        Specify a username to use with an
authenticated http
                        proxy
  --proxyPassword=<proxy password>
                        Specify a password to use with an
authenticated http
                        proxy
  --serverUrl=<url>     Specify what server url to use
  --show-package-dialog
                        Show the package installation dialog in gui mode
  --get                 Fetch the package specified without resolving
                        dependencies
  --get-source          Fetch the source package for the specified package
                        without resolving dependencies
  --arch=ARCH           Force up2date to install this arch of the
package. Not
                        valid with -u, --list, or --dry-run
  --upgrade-to-release=<release-version>
                        Upgrade to the channel specified
  -h, --help            show this help message and exit

When operating in command line mode, specifying package names as
arguments to the program will attempt to retrieve (and possibly
install, based on your configuration) those packages.  Version,
release, and architecture details will be determined by the Update
Agent automatically.


Additional info:
Comment 1 Max Spevack 2004-12-07 17:59:54 EST

*** This bug has been marked as a duplicate of 138451 ***
Comment 2 Red Hat Bugzilla 2006-02-21 14:06:38 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.