Bug 1373091 - Adding an auth indicator from the CLI creates an extra check box in the UI
Summary: Adding an auth indicator from the CLI creates an extra check box in the UI
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: ipa
Version: 7.3
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: Pavel Picka
QA Contact: Pavel Picka
URL:
Whiteboard:
: 1421118 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-09-05 07:06 UTC by Aneta Šteflová Petrová
Modified: 2017-08-01 09:39 UTC (History)
5 users (show)

Fixed In Version: ipa-4.5.0-1.el7
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-08-01 09:39:54 UTC
Target Upstream Version:


Attachments (Terms of Use)
output (5.64 KB, image/jpeg)
2017-06-05 15:53 UTC, Pavel Picka
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2017:2304 normal SHIPPED_LIVE ipa bug fix and enhancement update 2017-08-01 12:41:35 UTC

Description Aneta Šteflová Petrová 2016-09-05 07:06:16 UTC
Created attachment 1197790 [details]
otp check box

Description of problem:
When adding an authentication indicator from the command line, the corresponding check box in the UI is not checked. Instead, a completely new (and unchecked) check box appears.

Version-Release number of selected component (if applicable):


How reproducible:
Always.

Steps to Reproduce:
1. ipa host-mod server.example.com --auth-ind=otp
2.Output of ipa host-show shows this:
    ...
    Authentication Indicators: otp
    ...

Actual results:
A new check box appears in the host entry page in the UI: "otp" (next to "OTP" and "RADIUS"). None of the check boxes are actually checked. See the attached screenshot.


Expected results:
The "OTP" check box gets checked in the UI, no new extra check box is created.


Additional info:

Comment 3 Petr Vobornik 2016-09-05 17:18:34 UTC
I've reproduce the bug with any uppercase auth indicator, e.g.:
  ipa host-mod server.example.com --auth-ind=ABC

The mentioned 
  ipa host-mod server.example.com --auth-ind=otp
Works OK.


There is a bug in Web UI that internally transforms the values to lower case - therefore 'OTP' is checked in Web UI when 'otp' is set in CLI. And 'otp' is saved to LDAP when 'OTP is checked in Web UI.

Comment 4 Petr Vobornik 2016-09-07 14:57:13 UTC
Upstream ticket:
https://fedorahosted.org/freeipa/ticket/6308

Comment 5 Petr Vobornik 2016-09-07 15:00:18 UTC
Authentication indicators feaure in RHEL 7.3 by default uses only two indicators: "otp" and "radius". Web UI works with those. 

CLI and WebUI allows to define also custom indicators which requires special third party plugin. CLI works with those well but Web UI doesn't handle uppercase characters(this bug). This part is not supported workflow, therefore moving to 7.4.

Comment 6 Luc de Louw 2016-11-23 09:49:26 UTC
It is even worse. When deleting the flag in the WebUI, its not flagged anymore but still in the database. The only way to get rid of it via CLI.

This should be fixed in 7.3 or at least documented in a KB how to work around this issue.

Comment 7 Petr Vobornik 2017-02-28 09:00:23 UTC
*** Bug 1421118 has been marked as a duplicate of this bug. ***

Comment 10 Pavel Picka 2017-06-05 15:53:08 UTC
Created attachment 1285080 [details]
output

# ipa host-mod $(hostname) --auth-ind=otp
...
Authentication Indicators: otp
...

ipa-server-4.5.0-13.el7.x86_64

Verified

Comment 11 errata-xmlrpc 2017-08-01 09:39:54 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2017:2304


Note You need to log in before you can comment on or make changes to this bug.