Bug 1421118 - WebUI - Host Tab - authentication identificator
Summary: WebUI - Host Tab - authentication identificator
Keywords:
Status: CLOSED DUPLICATE of bug 1373091
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: ipa
Version: 7.3
Hardware: x86_64
OS: Linux
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: IPA Maintainers
QA Contact: Kaleem
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-02-10 12:02 UTC by Pavel Picka
Modified: 2017-02-28 09:00 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-02-28 09:00:23 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Pavel Picka 2017-02-10 12:02:00 UTC
Description of problem:
auth ident cannot be undone (cannot remove added auth-ident - empty does not work)

Version-Release number of selected component (if applicable):


How reproducible:
always


Steps to Reproduce:
1. in WebUI add in Host tab auth-ident to host 
2. try to remove it [unclick / set empty]

Actual results:
Cant remove


Expected results:
Remove or clear


Additional info:
Testet with early build of firefox52

Comment 3 Martin Babinsky 2017-02-10 13:29:13 UTC
So the problem is that once Auth Indicator is added to WebUI, it can not be removed?

Nathainel, is the removal of auth-indicators even supported? I have skimmed through the upstream design page (http://www.freeipa.org/page/V4/Authentication_Indicators) and the corresponding test plan (http://www.freeipa.org/page/V4/Authentication_Indicators/Test_Plan) but did not find much info on this, only that you can (re)-select the required indicators.

Comment 4 Nathaniel McCallum 2017-02-10 14:17:11 UTC
I presume that this is referring to the AI filters on services. If so, then yes we should support removing the AI filter.

Comment 5 Petr Vobornik 2017-02-10 14:37:43 UTC
Pavel, could you describe in more details what is the issue?

What do you imaging under term "remove"? 

Presence of authentication indicator is indicated by checked checkbox. Absence by un-checked checkbox. This seems to work for me on master branch.

Comment 6 Pavel Picka 2017-02-14 16:04:47 UTC
I cannot do in webui 'remove' like in CLI :

ipa host-mod --auth-ind='' hostname

to have default (so can use otp/radius/password) way to authentication 

so when I add otp or OTP (both will be taken) they will stay there until remove host

Comment 7 Petr Vobornik 2017-02-14 17:06:46 UTC
What do you mean under terms "stay there"? Like checked checkbox? If you run `ipa host-show $HOST` is the auth indicator present? Could you show us a screenshot or meet us in person?

Is it issue only with 'OTP' there was a bug with uppercase chars in Web UI.

What version of IPA do you use?

Comment 8 Petr Vobornik 2017-02-17 17:13:32 UTC
Pavel, aren't you hitting bug 1373091 ?

Comment 9 Pavel Picka 2017-02-28 08:41:54 UTC
Petr, yes hitting that bug.

Comment 10 Petr Vobornik 2017-02-28 09:00:23 UTC

*** This bug has been marked as a duplicate of bug 1373091 ***


Note You need to log in before you can comment on or make changes to this bug.