Bug 1373372 - [abrt] virt-manager: INT_cairo_surface_reference(): python2.7 killed by SIGABRT
Summary: [abrt] virt-manager: INT_cairo_surface_reference(): python2.7 killed by SIGABRT
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: mutter
Version: 25
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Florian Müllner
QA Contact: Fedora Extras Quality Assurance
URL: https://retrace.fedoraproject.org/faf...
Whiteboard: abrt_hash:5d49ac1504fac0bd55817d3ffbd...
Keywords:
: 1373668 1374409 (view as bug list)
Depends On:
Blocks: WaylandRelated F25BetaBlocker
TreeView+ depends on / blocked
 
Reported: 2016-09-06 06:39 UTC by Joachim Frieben
Modified: 2016-09-09 21:49 UTC (History)
12 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2016-09-09 21:49:10 UTC


Attachments (Terms of Use)
File: backtrace (121.33 KB, text/plain)
2016-09-06 06:39 UTC, Joachim Frieben
no flags Details
File: cgroup (242 bytes, text/plain)
2016-09-06 06:39 UTC, Joachim Frieben
no flags Details
File: core_backtrace (11.66 KB, text/plain)
2016-09-06 06:39 UTC, Joachim Frieben
no flags Details
File: dso_list (23.77 KB, text/plain)
2016-09-06 06:39 UTC, Joachim Frieben
no flags Details
File: environ (1.03 KB, text/plain)
2016-09-06 06:39 UTC, Joachim Frieben
no flags Details
File: limits (1.29 KB, text/plain)
2016-09-06 06:39 UTC, Joachim Frieben
no flags Details
File: maps (110.43 KB, text/plain)
2016-09-06 06:39 UTC, Joachim Frieben
no flags Details
File: mountinfo (3.60 KB, text/plain)
2016-09-06 06:39 UTC, Joachim Frieben
no flags Details
File: namespaces (102 bytes, text/plain)
2016-09-06 06:39 UTC, Joachim Frieben
no flags Details
File: open_fds (2.30 KB, text/plain)
2016-09-06 06:39 UTC, Joachim Frieben
no flags Details
File: proc_pid_status (1.11 KB, text/plain)
2016-09-06 06:39 UTC, Joachim Frieben
no flags Details
File: var_log_messages (28 bytes, text/plain)
2016-09-06 06:39 UTC, Joachim Frieben
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
GNOME Bugzilla 770952 None None None 2016-09-06 14:23 UTC

Description Joachim Frieben 2016-09-06 06:39:18 UTC
Version-Release number of selected component:
virt-manager-1.4.0-3.fc25

Additional info:
reporter:       libreport-2.7.2
backtrace_rating: 4
cmdline:        /usr/bin/python2 /usr/share/virt-manager/virt-manager
crash_function: INT_cairo_surface_reference
executable:     /usr/bin/python2.7
global_pid:     4145
kernel:         4.8.0-0.rc4.git0.1.fc25.x86_64
pkg_fingerprint: 4089 D8F2 FDB1 9C98
pkg_vendor:     Fedora Project
runlevel:       N 5
type:           CCpp
uid:            1000

Truncated backtrace:
Thread no. 0 (8 frames)
 #4 INT_cairo_surface_reference at cairo-surface.c:928
 #5 _gdk_wayland_cursor_get_buffer at gdkcursor-wayland.c:257
 #6 gdk_wayland_device_update_window_cursor at gdkdevice-wayland.c:408
 #7 gdk_wayland_device_ungrab at gdkdevice-wayland.c:809
 #8 gdk_display_pointer_ungrab at gdkdisplay.c:528
 #9 gdk_pointer_ungrab at gdkdeprecated.c:44
 #10 button_event at spice-widget.c:1924
 #11 _gtk_marshal_BOOLEAN__BOXEDv at gtkmarshalers.c:131

Comment 1 Joachim Frieben 2016-09-06 06:39:28 UTC
Created attachment 1198085 [details]
File: backtrace

Comment 2 Joachim Frieben 2016-09-06 06:39:30 UTC
Created attachment 1198086 [details]
File: cgroup

Comment 3 Joachim Frieben 2016-09-06 06:39:32 UTC
Created attachment 1198087 [details]
File: core_backtrace

Comment 4 Joachim Frieben 2016-09-06 06:39:34 UTC
Created attachment 1198088 [details]
File: dso_list

Comment 5 Joachim Frieben 2016-09-06 06:39:35 UTC
Created attachment 1198089 [details]
File: environ

Comment 6 Joachim Frieben 2016-09-06 06:39:37 UTC
Created attachment 1198090 [details]
File: limits

Comment 7 Joachim Frieben 2016-09-06 06:39:40 UTC
Created attachment 1198091 [details]
File: maps

Comment 8 Joachim Frieben 2016-09-06 06:39:41 UTC
Created attachment 1198092 [details]
File: mountinfo

Comment 9 Joachim Frieben 2016-09-06 06:39:43 UTC
Created attachment 1198093 [details]
File: namespaces

Comment 10 Joachim Frieben 2016-09-06 06:39:45 UTC
Created attachment 1198094 [details]
File: open_fds

Comment 11 Joachim Frieben 2016-09-06 06:39:46 UTC
Created attachment 1198095 [details]
File: proc_pid_status

Comment 12 Joachim Frieben 2016-09-06 06:39:48 UTC
Created attachment 1198096 [details]
File: var_log_messages

Comment 13 Kamil Páral 2016-09-06 08:01:17 UTC
I have the same issue. I can't use my VMs, at all. Every time I run virt-manager, open the window for my (already running) VM, and click inside, virt-manager crashes.

Comment 14 Kamil Páral 2016-09-06 08:05:30 UTC
Proposing as a Beta blocker:
"The release must be able host virtual guest instances of the same release. 
...when using Fedora's recommended virtualization technology, that is. This criterion applies only to the recommended Fedora virtualization tools - the qemu/kvm - libvirt - virt-manager stack."
https://fedoraproject.org/wiki/Fedora_25_Beta_Release_Criteria#Self_hosting_virtualization

Comment 15 Kamil Páral 2016-09-06 08:09:12 UTC
virt-viewer crashes as well, but abrt didn't allow me to create a report. Seems to be the same issue.

Comment 16 Kamil Páral 2016-09-06 08:37:20 UTC
This is the update that breaks virt-manager:

Command Line   : distro-sync gtk3*
Transaction performed with:
    Installed     dnf-1.1.10-1.fc25.noarch        @@commandline
    Installed     rpm-4.13.0-0.rc1.46.fc25.x86_64 @@commandline
Packages Altered:
    Upgraded gtk3-3.21.4-2.fc25.x86_64       @fedora
    Upgrade       3.21.5-1.fc25.x86_64       @updates-testing
    Upgraded gtk3-devel-3.21.4-2.fc25.x86_64 @fedora
    Upgrade             3.21.5-1.fc25.x86_64 @updates-testing

So this is technically not a blocker if the package is not pushed stable.

Comment 17 Kalev Lember 2016-09-06 14:13:43 UTC
https://bugzilla.gnome.org/show_bug.cgi?id=770952 should fix this

Comment 18 Kamil Páral 2016-09-07 10:03:32 UTC
(In reply to Kamil Páral from comment #13)
> I have the same issue. I can't use my VMs, at all. Every time I run
> virt-manager, open the window for my (already running) VM, and click inside,
> virt-manager crashes.

To clarify the reproducer, the crash occurs when you click into a VM which is in graphical mode (tested with GNOME). If you click inside a VM which is in text mode, the crash doesn't occur.

Comment 19 Kamil Páral 2016-09-07 10:07:57 UTC
*** Bug 1373668 has been marked as a duplicate of this bug. ***

Comment 20 Kamil Páral 2016-09-07 10:08:41 UTC
The same issue seems to occur in libreoffice, see bug 1373668.

Comment 21 Kalev Lember 2016-09-08 11:25:37 UTC
After further debugging this turned out to be a mutter issue. Should be fixed in mutter-3.21.91-2.fc25

Comment 22 Fedora Update System 2016-09-08 12:23:54 UTC
PackageKit-1.1.4-0.3.20160901.fc25 adwaita-icon-theme-3.21.91-1.fc25 at-spi2-atk-2.21.91-1.fc25 atomix-3.21.91-1.fc25 clutter-gtk-1.8.0-2.fc25 cogl-1.22.2-1.fc25 devhelp-3.21.91-1.fc25 evolution-3.21.91-2.fc25 evolution-data-server-3.21.91-1.fc25 evolution-ews-3.21.91-1.fc25 evolution-mapi-3.21.91-1.fc25 five-or-more-3.21.91-1.fc25 fwupd-0.7.3-2.fc25 gdk-pixbuf2-2.35.4-1.fc25 gdm-3.21.91-2.fc25 geary-0.11.2-1.fc25 gitg-3.21.91-1.fc25 glib2-2.49.6-1.fc25 gnome-2048-3.21.91-1.fc25 gnome-autoar-0.1.1-1.fc25 gnome-backgrounds-3.21.91-1.fc25 gnome-calendar-3.21.91-1.fc25 gnome-clocks-3.21.2-1.fc25 gnome-color-manager-3.21.91-1.fc25 gnome-disk-utility-3.21.91-1.fc25 gnome-documents-3.21.90-2.fc25 gnome-initial-setup-3.21.91-2.fc25 gnome-klotski-3.21.91-1.fc25 gnome-maps-3.21.91-1.fc25 gnome-mines-3.21.91-1.fc25 gnome-multi-writer-3.21.91-1.fc25 gnome-nibbles-3.21.91-1.fc25 gnome-online-accounts-3.21.91-1.fc25 gnome-online-miners-3.21.91-1.fc25 gnome-packagekit-3.21.91-1.fc25 gnome-photos-3.21.91-1.fc25 gnome-power-manager-3.21.91-1.fc25 gnome-robots-3.21.91-1.fc25 gnome-settings-daemon-3.21.90-1.fc25 gnome-shell-3.21.91-1.fc25 gnome-shell-extension-background-logo-3.21.91-1.fc25 gnome-shell-extensions-3.21.91-1.fc25 gnome-software-3.21.91-1.fc25 gnome-system-monitor-3.21.91-1.fc25 gnome-taquin-3.21.91-1.fc25 gnome-tweak-tool-3.21.91-1.fc25 gnome-user-share-3.18.2-1.fc25 gtk3-3.21.5-1.fc25 gvfs-1.29.91-1.fc25 iagno-3.21.91-1.fc25 libappstream-glib-0.6.3-1.fc25 libgepub-0.4-1.fc25 libgnome-games-support-1.1.91-1.fc25 libgweather-3.20.3-1.fc25 lightsoff-3.21.91-1.fc25 mutter-3.21.91-2.fc25 nautilus-3.21.91.1-1.fc25 orca-3.21.91-1.fc25 pango-1.40.2-1.fc25 polari-3.21.91-1.fc25 pygobject3-3.21.91-1.fc25 rygel-0.31.5-1.fc25 simple-scan-3.21.90-1.fc25 sushi-3.21.91-1.fc25 swell-foop-3.21.91-1.fc25 sysprof-3.21.91-1.fc25 totem-3.21.91-1.fc25 webkitgtk4-2.13.90-1.fc25 xdg-desktop-portal-0.3-1.fc25 xdg-desktop-portal-gtk-0.3-1.fc25 has been submitted as an update to Fedora 25. https://bodhi.fedoraproject.org/updates/FEDORA-2016-c565698917

Comment 23 Fedora Update System 2016-09-08 12:24:20 UTC
PackageKit-1.1.4-0.3.20160901.fc25 adwaita-icon-theme-3.21.91-1.fc25 at-spi2-atk-2.21.91-1.fc25 atomix-3.21.91-1.fc25 clutter-gtk-1.8.0-2.fc25 cogl-1.22.2-1.fc25 devhelp-3.21.91-1.fc25 evolution-3.21.91-2.fc25 evolution-data-server-3.21.91-1.fc25 evolution-ews-3.21.91-1.fc25 evolution-mapi-3.21.91-1.fc25 five-or-more-3.21.91-1.fc25 fwupd-0.7.3-2.fc25 gdk-pixbuf2-2.35.4-1.fc25 gdm-3.21.91-2.fc25 geary-0.11.2-1.fc25 gitg-3.21.91-1.fc25 glib2-2.49.6-1.fc25 gnome-2048-3.21.91-1.fc25 gnome-autoar-0.1.1-1.fc25 gnome-backgrounds-3.21.91-1.fc25 gnome-calendar-3.21.91-1.fc25 gnome-clocks-3.21.2-1.fc25 gnome-color-manager-3.21.91-1.fc25 gnome-disk-utility-3.21.91-1.fc25 gnome-documents-3.21.90-2.fc25 gnome-initial-setup-3.21.91-2.fc25 gnome-klotski-3.21.91-1.fc25 gnome-maps-3.21.91-1.fc25 gnome-mines-3.21.91-1.fc25 gnome-multi-writer-3.21.91-1.fc25 gnome-nibbles-3.21.91-1.fc25 gnome-online-accounts-3.21.91-1.fc25 gnome-online-miners-3.21.91-1.fc25 gnome-packagekit-3.21.91-1.fc25 gnome-photos-3.21.91-1.fc25 gnome-power-manager-3.21.91-1.fc25 gnome-robots-3.21.91-1.fc25 gnome-settings-daemon-3.21.90-1.fc25 gnome-shell-3.21.91-1.fc25 gnome-shell-extension-background-logo-3.21.91-1.fc25 gnome-shell-extensions-3.21.91-1.fc25 gnome-software-3.21.91-1.fc25 gnome-system-monitor-3.21.91-1.fc25 gnome-taquin-3.21.91-1.fc25 gnome-tweak-tool-3.21.91-1.fc25 gnome-user-share-3.18.2-1.fc25 gtk3-3.21.5-1.fc25 gvfs-1.29.91-1.fc25 iagno-3.21.91-1.fc25 libappstream-glib-0.6.3-1.fc25 libgepub-0.4-1.fc25 libgnome-games-support-1.1.91-1.fc25 libgweather-3.20.3-1.fc25 lightsoff-3.21.91-1.fc25 mutter-3.21.91-2.fc25 nautilus-3.21.91.1-1.fc25 orca-3.21.91-1.fc25 pango-1.40.2-1.fc25 polari-3.21.91-1.fc25 pygobject3-3.21.91-1.fc25 rygel-0.31.5-1.fc25 simple-scan-3.21.90-1.fc25 sushi-3.21.91-1.fc25 swell-foop-3.21.91-1.fc25 sysprof-3.21.91-1.fc25 totem-3.21.91-1.fc25 webkitgtk4-2.13.90-1.fc25 xdg-desktop-portal-0.3-1.fc25 xdg-desktop-portal-gtk-0.3-1.fc25 has been submitted as an update to Fedora 25. https://bodhi.fedoraproject.org/updates/FEDORA-2016-c565698917

Comment 24 Kamil Páral 2016-09-08 13:16:20 UTC
(In reply to Kalev Lember from comment #21)
> After further debugging this turned out to be a mutter issue. Should be
> fixed in mutter-3.21.91-2.fc25

Looks good, no more crashes.

Comment 25 Fedora Update System 2016-09-09 06:29:54 UTC
PackageKit-1.1.4-0.3.20160901.fc25, adwaita-icon-theme-3.21.91-1.fc25, at-spi2-atk-2.21.91-1.fc25, atomix-3.21.91-1.fc25, clutter-gtk-1.8.0-2.fc25, cogl-1.22.2-1.fc25, devhelp-3.21.91-1.fc25, evolution-3.21.91-2.fc25, evolution-data-server-3.21.91-1.fc25, evolution-ews-3.21.91-1.fc25, evolution-mapi-3.21.91-1.fc25, five-or-more-3.21.91-1.fc25, fwupd-0.7.3-2.fc25, gdk-pixbuf2-2.35.4-1.fc25, gdm-3.21.91-2.fc25, geary-0.11.2-1.fc25, gitg-3.21.91-1.fc25, glib2-2.49.6-1.fc25, gnome-2048-3.21.91-1.fc25, gnome-autoar-0.1.1-1.fc25, gnome-backgrounds-3.21.91-1.fc25, gnome-calendar-3.21.91-1.fc25, gnome-clocks-3.21.2-1.fc25, gnome-color-manager-3.21.91-1.fc25, gnome-disk-utility-3.21.91-1.fc25, gnome-documents-3.21.90-2.fc25, gnome-initial-setup-3.21.91-2.fc25, gnome-klotski-3.21.91-1.fc25, gnome-maps-3.21.91-1.fc25, gnome-mines-3.21.91-1.fc25, gnome-multi-writer-3.21.91-1.fc25, gnome-nibbles-3.21.91-1.fc25, gnome-online-accounts-3.21.91-1.fc25, gnome-online-miners-3.21.91-1.fc25, gnome-packagekit-3.21.91-1.fc25, gnome-photos-3.21.91-1.fc25, gnome-power-manager-3.21.91-1.fc25, gnome-robots-3.21.91-1.fc25, gnome-settings-daemon-3.21.90-1.fc25, gnome-shell-3.21.91-1.fc25, gnome-shell-extension-background-logo-3.21.91-1.fc25, gnome-shell-extensions-3.21.91-1.fc25, gnome-software-3.21.91-1.fc25, gnome-system-monitor-3.21.91-1.fc25, gnome-taquin-3.21.91-1.fc25, gnome-tweak-tool-3.21.91-1.fc25, gnome-user-share-3.18.2-1.fc25, gtk3-3.21.5-1.fc25, gvfs-1.29.91-1.fc25, iagno-3.21.91-1.fc25, libappstream-glib-0.6.3-1.fc25, libgepub-0.4-1.fc25, libgnome-games-support-1.1.91-1.fc25, libgweather-3.20.3-1.fc25, lightsoff-3.21.91-1.fc25, mutter-3.21.91-2.fc25, nautilus-3.21.91.1-1.fc25, orca-3.21.91-1.fc25, pango-1.40.2-1.fc25, polari-3.21.91-1.fc25, pygobject3-3.21.91-1.fc25, rygel-0.31.5-1.fc25, simple-scan-3.21.90-1.fc25, sushi-3.21.91-1.fc25, swell-foop-3.21.91-1.fc25, sysprof-3.21.91-1.fc25, totem-3.21.91-1.fc25, webkitgtk4-2.13.90-1.fc25, xdg-desktop-portal-0.3-1.fc25, xdg-desktop-portal-gtk-0.3-1.fc25 has been pushed to the Fedora 25 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-c565698917

Comment 26 Kalev Lember 2016-09-09 07:06:09 UTC
*** Bug 1374409 has been marked as a duplicate of this bug. ***

Comment 27 Fedora Update System 2016-09-09 21:48:49 UTC
PackageKit-1.1.4-0.3.20160901.fc25, adwaita-icon-theme-3.21.91-1.fc25, at-spi2-atk-2.21.91-1.fc25, atomix-3.21.91-1.fc25, clutter-gtk-1.8.0-2.fc25, cogl-1.22.2-1.fc25, devhelp-3.21.91-1.fc25, evolution-3.21.91-2.fc25, evolution-data-server-3.21.91-1.fc25, evolution-ews-3.21.91-1.fc25, evolution-mapi-3.21.91-1.fc25, five-or-more-3.21.91-1.fc25, fwupd-0.7.3-2.fc25, gdk-pixbuf2-2.35.4-1.fc25, gdm-3.21.91-2.fc25, geary-0.11.2-1.fc25, gitg-3.21.91-1.fc25, glib2-2.49.6-1.fc25, gnome-2048-3.21.91-1.fc25, gnome-autoar-0.1.1-1.fc25, gnome-backgrounds-3.21.91-1.fc25, gnome-calendar-3.21.91-1.fc25, gnome-clocks-3.21.2-1.fc25, gnome-color-manager-3.21.91-1.fc25, gnome-disk-utility-3.21.91-1.fc25, gnome-documents-3.21.90-2.fc25, gnome-initial-setup-3.21.91-2.fc25, gnome-klotski-3.21.91-1.fc25, gnome-maps-3.21.91-1.fc25, gnome-mines-3.21.91-1.fc25, gnome-multi-writer-3.21.91-1.fc25, gnome-nibbles-3.21.91-1.fc25, gnome-online-accounts-3.21.91-1.fc25, gnome-online-miners-3.21.91-1.fc25, gnome-packagekit-3.21.91-1.fc25, gnome-photos-3.21.91-1.fc25, gnome-power-manager-3.21.91-1.fc25, gnome-robots-3.21.91-1.fc25, gnome-settings-daemon-3.21.90-1.fc25, gnome-shell-3.21.91-1.fc25, gnome-shell-extension-background-logo-3.21.91-1.fc25, gnome-shell-extensions-3.21.91-1.fc25, gnome-software-3.21.91-1.fc25, gnome-system-monitor-3.21.91-1.fc25, gnome-taquin-3.21.91-1.fc25, gnome-tweak-tool-3.21.91-1.fc25, gnome-user-share-3.18.2-1.fc25, gtk3-3.21.5-1.fc25, gvfs-1.29.91-1.fc25, iagno-3.21.91-1.fc25, libappstream-glib-0.6.3-1.fc25, libgepub-0.4-1.fc25, libgnome-games-support-1.1.91-1.fc25, libgweather-3.20.3-1.fc25, lightsoff-3.21.91-1.fc25, mutter-3.21.91-2.fc25, nautilus-3.21.91.1-1.fc25, orca-3.21.91-1.fc25, pango-1.40.2-1.fc25, polari-3.21.91-1.fc25, pygobject3-3.21.91-1.fc25, rygel-0.31.5-1.fc25, simple-scan-3.21.90-1.fc25, sushi-3.21.91-1.fc25, swell-foop-3.21.91-1.fc25, sysprof-3.21.91-1.fc25, totem-3.21.91-1.fc25, webkitgtk4-2.13.90-1.fc25, xdg-desktop-portal-0.3-1.fc25, xdg-desktop-portal-gtk-0.3-1.fc25 has been pushed to the Fedora 25 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.