Bug 1374409 - [abrt] gnome-boxes: INT_cairo_surface_reference(): gnome-boxes killed by SIGABRT
Summary: [abrt] gnome-boxes: INT_cairo_surface_reference(): gnome-boxes killed by SIGABRT
Keywords:
Status: CLOSED DUPLICATE of bug 1373372
Alias: None
Product: Fedora
Classification: Fedora
Component: mutter
Version: 25
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Florian Müllner
QA Contact: Fedora Extras Quality Assurance
URL: https://retrace.fedoraproject.org/faf...
Whiteboard: abrt_hash:99dd7eeb887d6ebb1ffe54ce20d...
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-09-08 15:38 UTC by Joachim Frieben
Modified: 2016-09-09 07:06 UTC (History)
10 users (show)

Fixed In Version: mutter-3.21.91-2.fc25
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-09-09 07:06:09 UTC


Attachments (Terms of Use)
File: backtrace (39.24 KB, text/plain)
2016-09-08 15:38 UTC, Joachim Frieben
no flags Details
File: cgroup (353 bytes, text/plain)
2016-09-08 15:38 UTC, Joachim Frieben
no flags Details
File: core_backtrace (6.46 KB, text/plain)
2016-09-08 15:38 UTC, Joachim Frieben
no flags Details
File: dso_list (19.92 KB, text/plain)
2016-09-08 15:38 UTC, Joachim Frieben
no flags Details
File: environ (1.08 KB, text/plain)
2016-09-08 15:38 UTC, Joachim Frieben
no flags Details
File: limits (1.29 KB, text/plain)
2016-09-08 15:38 UTC, Joachim Frieben
no flags Details
File: maps (100.32 KB, text/plain)
2016-09-08 15:38 UTC, Joachim Frieben
no flags Details
File: mountinfo (3.62 KB, text/plain)
2016-09-08 15:38 UTC, Joachim Frieben
no flags Details
File: namespaces (102 bytes, text/plain)
2016-09-08 15:38 UTC, Joachim Frieben
no flags Details
File: open_fds (3.56 KB, text/plain)
2016-09-08 15:38 UTC, Joachim Frieben
no flags Details
File: proc_pid_status (1.11 KB, text/plain)
2016-09-08 15:38 UTC, Joachim Frieben
no flags Details
File: var_log_messages (6.87 KB, text/plain)
2016-09-08 15:38 UTC, Joachim Frieben
no flags Details

Description Joachim Frieben 2016-09-08 15:38:06 UTC
Version-Release number of selected component:
gnome-boxes-3.21.3-1.fc25

Additional info:
reporter:       libreport-2.7.2
backtrace_rating: 4
cmdline:        /usr/bin/gnome-boxes --gapplication-service
crash_function: INT_cairo_surface_reference
executable:     /usr/bin/gnome-boxes
global_pid:     2994
kernel:         4.8.0-0.rc4.git0.1.fc25.x86_64
pkg_fingerprint: 4089 D8F2 FDB1 9C98
pkg_vendor:     Fedora Project
runlevel:       N 5
type:           CCpp
uid:            1000

Truncated backtrace:
Thread no. 1 (10 frames)
 #4 INT_cairo_surface_reference at cairo-surface.c:928
 #5 _gdk_wayland_cursor_get_buffer at gdkcursor-wayland.c:257
 #6 gdk_wayland_device_update_window_cursor at gdkdevice-wayland.c:408
 #7 pointer_handle_leave at gdkdevice-wayland.c:1512
 #8 ffi_call_unix64 at ../src/x86/unix64.S:76
 #9 ffi_call at ../src/x86/ffi64.c:525
 #10 wl_closure_invoke at src/connection.c:935
 #11 dispatch_event at src/wayland-client.c:1310
 #12 dispatch_queue at src/wayland-client.c:1456
 #13 wl_display_dispatch_queue_pending at src/wayland-client.c:1698

Comment 1 Joachim Frieben 2016-09-08 15:38:17 UTC
Created attachment 1199150 [details]
File: backtrace

Comment 2 Joachim Frieben 2016-09-08 15:38:19 UTC
Created attachment 1199151 [details]
File: cgroup

Comment 3 Joachim Frieben 2016-09-08 15:38:21 UTC
Created attachment 1199152 [details]
File: core_backtrace

Comment 4 Joachim Frieben 2016-09-08 15:38:23 UTC
Created attachment 1199153 [details]
File: dso_list

Comment 5 Joachim Frieben 2016-09-08 15:38:25 UTC
Created attachment 1199154 [details]
File: environ

Comment 6 Joachim Frieben 2016-09-08 15:38:26 UTC
Created attachment 1199155 [details]
File: limits

Comment 7 Joachim Frieben 2016-09-08 15:38:29 UTC
Created attachment 1199157 [details]
File: maps

Comment 8 Joachim Frieben 2016-09-08 15:38:31 UTC
Created attachment 1199158 [details]
File: mountinfo

Comment 9 Joachim Frieben 2016-09-08 15:38:32 UTC
Created attachment 1199159 [details]
File: namespaces

Comment 10 Joachim Frieben 2016-09-08 15:38:34 UTC
Created attachment 1199160 [details]
File: open_fds

Comment 11 Joachim Frieben 2016-09-08 15:38:36 UTC
Created attachment 1199161 [details]
File: proc_pid_status

Comment 12 Joachim Frieben 2016-09-08 15:38:37 UTC
Created attachment 1199162 [details]
File: var_log_messages

Comment 13 Christophe Fergeau 2016-09-08 15:49:27 UTC
Someone on Debian reported a similar crash, downgrading gtk+ to the 3.20 version helped.

Comment 14 Christophe Fergeau 2016-09-08 15:49:47 UTC
It also does not happen with GDK_BACKEND=x11

Comment 15 Kalev Lember 2016-09-09 07:06:09 UTC

*** This bug has been marked as a duplicate of bug 1373372 ***


Note You need to log in before you can comment on or make changes to this bug.