Bug 1373530 - Minor improvements and cleanup for the build system
Summary: Minor improvements and cleanup for the build system
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: build
Version: 3.8
Hardware: Unspecified
OS: Unspecified
low
low
Target Milestone: ---
Assignee: Niels de Vos
QA Contact:
URL:
Whiteboard:
Depends On: 1198849
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-09-06 14:15 UTC by Niels de Vos
Modified: 2016-09-16 18:28 UTC (History)
1 user (show)

Fixed In Version: glusterfs-3.8.4
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 1198849
Environment:
Last Closed: 2016-09-16 18:28:44 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Description Niels de Vos 2016-09-06 14:15:56 UTC
+++ This bug was initially created as a clone of Bug #1198849 +++

Use this bug to file changes that affect the build tools and configuration. Real bugs (problem reports) should have their own bugzilla entry for related patches.

Acceptable changes include:

- improve readability
- minor checkpatch.pl changes
- cleanup in Makefile.am files or configure.ac
- ...

Comment 1 Worker Ant 2016-09-06 14:19:06 UTC
REVIEW: http://review.gluster.org/15410 (build: correctly format some (s)size_t messages) posted (#1) for review on release-3.8 by Niels de Vos (ndevos@redhat.com)

Comment 2 Worker Ant 2016-09-07 14:00:51 UTC
COMMIT: http://review.gluster.org/15410 committed in release-3.8 by Kaleb KEITHLEY (kkeithle@redhat.com) 
------
commit 020787a93f997f4fd2e16818e73d030b3ef4e4e8
Author: Niels de Vos <ndevos@redhat.com>
Date:   Tue Sep 6 16:13:25 2016 +0200

    build: correctly format some (s)size_t messages
    
    On 32-bit builds the are are warnings like these:
    
        posix.c:6438: warning: format '%ld' expects type 'long int', but argument 11 has type 'ssize_t'
    
    Instead of using "%l" for (signed) size_t variables, "%z" should be
    used.
    
    Cherry picked from commit 3af889f02722f4636d2ea30570de6477e8b5a3a9:
    > BUG: 1198849
    > Change-Id: I6f57b5e8ea174dd9e3056aff5da685e497894ccf
    > Signed-off-by: Niels de Vos <ndevos@redhat.com>
    > Reviewed-on: http://review.gluster.org/14933
    > NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
    > CentOS-regression: Gluster Build System <jenkins@build.gluster.org>
    > Reviewed-by: Kaleb KEITHLEY <kkeithle@redhat.com>
    > Smoke: Gluster Build System <jenkins@build.gluster.org>
    
    This patch is not really recommended for backporting, but we do have a
    new smoke test that fails when these warnings pop-up. It is cleaner to
    correct the code in the release-3.7 branch then to modify the smoke test
    to skip this branch.
    
    Change-Id: I6f57b5e8ea174dd9e3056aff5da685e497894ccf
    BUG: 1373530
    Signed-off-by: Niels de Vos <ndevos@redhat.com>
    Reviewed-on: http://review.gluster.org/15410
    Reviewed-by: Kaleb KEITHLEY <kkeithle@redhat.com>
    Smoke: Gluster Build System <jenkins@build.gluster.org>
    NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
    CentOS-regression: Gluster Build System <jenkins@build.gluster.org>

Comment 3 Niels de Vos 2016-09-12 05:39:32 UTC
All 3.8.x bugs are now reported against version 3.8 (without .x). For more information, see http://www.gluster.org/pipermail/gluster-devel/2016-September/050859.html

Comment 4 Niels de Vos 2016-09-16 18:28:44 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.8.4, please open a new bug report.

glusterfs-3.8.4 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] https://www.gluster.org/pipermail/announce/2016-September/000060.html
[2] https://www.gluster.org/pipermail/gluster-users/


Note You need to log in before you can comment on or make changes to this bug.