Bug 1373725 - A dialog box pops up and can't be closed normally when drag a file into guest with filetransfer disabled.
Summary: A dialog box pops up and can't be closed normally when drag a file into guest...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: spice
Version: 7.3
Hardware: x86_64
OS: All
medium
medium
Target Milestone: rc
: ---
Assignee: Default Assignee for SPICE Bugs
QA Contact: SPICE QE bug list
URL:
Whiteboard:
: 1446142 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-09-07 04:37 UTC by Fangge Jin
Modified: 2018-04-10 13:54 UTC (History)
12 users (show)

Fixed In Version: spice-0.13.90-1.el7
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1373830 (view as bug list)
Environment:
Last Closed: 2018-04-10 13:52:38 UTC
Target Upstream Version:


Attachments (Terms of Use)
The screenshot of virt-viewer (786.70 KB, image/png)
2016-09-07 08:40 UTC, Fangge Jin
no flags Details


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2018:0802 0 None None None 2018-04-10 13:54:48 UTC

Description Fangge Jin 2016-09-07 04:37:07 UTC
DDescription of problem:
Disable spice filetransfer for guest, start guest, open remote-viewer, try to drag a file into guest from host, a "File transfer" dialog box pops up, but it can't be closed by click "X" or "cancel" or "right click + close"

Version-Release number of selected component:
libvirt-2.0.0-6.el7.x86_64
virt-viewer-2.0-11.el7.x86_64
spice-gtk3-0.31-5.el7.x86_64
spice-server-0.12.4-18.el7.x86_64

How reproducible:
100%

Steps to Reproduce:
1. Prepare a guest with spice graphic and filetransfer enable='no':
# virsh edit rhel7.3-0817
...
    <graphics type='spice' autoport='yes' listen='0.0.0.0'>
      <listen type='address' address='0.0.0.0'/>
      <filetransfer enable='no'/>
    </graphics>

2. Start guest
# virsh start rhel7.3-0817

3. Connect to guest by remote-viewer:
# remote-viewer spice://<ip>:<port>

4. Drag a file from host into guest.

5. Try to close the "File transfer" diglog

Actual results:
The "File transfer" dialog can't be closed

Expected results:
The "File transfer" dialog can be closed normally

Comment 2 Pavel Grunt 2016-09-07 08:35:08 UTC
There are two problems:
 1. the dialog showing up & transfer going on - spice server should tell spice-gtk, that file transfer is disabled
 2. the dialog window cannot be closed - that is virt-viewer's problem

Comment 3 Fangge Jin 2016-09-07 08:40:38 UTC
Created attachment 1198587 [details]
The screenshot of virt-viewer

Comment 4 Pavel Grunt 2016-09-07 08:44:02 UTC
(In reply to Pavel Grunt from comment #2)
> There are two problems:
>  1. the dialog showing up & transfer going on - spice server should tell
> spice-gtk, that file transfer is disabled
>  2. the dialog window cannot be closed - that is virt-viewer's problem

I opened the bug 1373830 for 2.

Comment 5 Fangge Jin 2016-09-07 08:49:47 UTC
(In reply to Pavel Grunt from comment #2)
> There are two problems:
>  1. the dialog showing up & transfer going on - spice server should tell
> spice-gtk, that file transfer is disabled
>  2. the dialog window cannot be closed - that is virt-viewer's problem

The dialog showing up, but the transfer has no progress, which can be seen from the screenshot

Comment 6 Pavel Grunt 2016-09-07 08:53:44 UTC
(In reply to JinFangge from comment #5)
> (In reply to Pavel Grunt from comment #2)
> > There are two problems:
> >  1. the dialog showing up & transfer going on - spice server should tell
> > spice-gtk, that file transfer is disabled
> >  2. the dialog window cannot be closed - that is virt-viewer's problem
> 
> The dialog showing up, but the transfer has no progress, which can be seen
> from the screenshot

Yes, it has no progress because the file transfer is disabled in spice-server.

Comment 10 Pavel Grunt 2016-12-21 15:07:46 UTC
Patch posted - for server to tell spice-gtk that file transfer should not happen
https://lists.freedesktop.org/archives/spice-devel/2016-December/034736.html

Comment 12 Pavel Grunt 2017-04-27 10:54:05 UTC
*** Bug 1446142 has been marked as a duplicate of this bug. ***

Comment 13 Victor Toso 2017-05-30 11:53:57 UTC
Fix did not get upstream, moving to 7.5

Comment 14 Victor Toso 2017-07-03 12:23:34 UTC
All should be upstream now:

* Spice-protocol
Shortlog: agent: Add capability for disabled file transfer
Commit  : 3f27d410b45262829897227abf64d57a81ff4910
Pavel Grunt on Fri, 10 Mar 2017 10:43:21 +0100

Shortlog: agent: Add macro for clearing capability
Commit  : b9bfbd2f7bc14274bb84364e9fd75e1448e3eaf5
Pavel Grunt on Fri, 3 Mar 2017 13:00:36 +0000

* Spice
Shortlog: reds: Adjust agent capabilites to disabled features
Commit  : 366b5b96c21579156b6ef5601d6d458899269d99
Pavel Grunt on Tue, 6 Jun 2017 17:53:42 +0100

* Spice-gtk
Shortlog: main: Handle disabled file transfer
Commit  : 40b0dbf3175ed8c5dba7f5a8058774c3aec93d9c
Pavel Grunt on Fri, 10 Mar 2017 16:24:28 +0100

Comment 15 Christophe Fergeau 2017-09-25 15:57:46 UTC
Fixed as part of the rebase, should be fixed client-side with the rebase to spice-gtk 0.34.

Comment 20 errata-xmlrpc 2018-04-10 13:52:38 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2018:0802


Note You need to log in before you can comment on or make changes to this bug.