This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 137377 - Badness in scsi_device_set_state
Badness in scsi_device_set_state
Status: CLOSED DUPLICATE of bug 136997
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
3
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Jones
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-10-27 17:26 EDT by John P Dwyer
Modified: 2015-01-04 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 14:06:39 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
text of kernel oops from dmesg (3.04 KB, text/plain)
2004-10-27 17:29 EDT, John P Dwyer
no flags Details

  None (edit)
Description John P Dwyer 2004-10-27 17:26:47 EDT
Description of problem:
Badness in scsi_device_set_state; followed by kernel oops.
Afterwards, usb devices do not work.


Version-Release number of selected component (if applicable):
kernel version: 2.6.8-1.541

How reproducible:
Always

Steps to Reproduce:
1. Plug in usb connected DVD-R/RW
2. Unplug usb connected DVD-R/RW
3. check kernel dump with dmesg or /var/log/messages
  
Actual results:
Kernel badness followed by kernel oops

Expected results:
kernel handles disconnect correctly; USB continues to work

Additional info:
Comment 1 John P Dwyer 2004-10-27 17:29:19 EDT
Created attachment 105870 [details]
text of kernel oops from dmesg

In addition to the kernel oops, lsmod shows that usb-storage has a usage count
of 4294967294
Comment 2 Bill Nottingham 2004-10-27 22:34:43 EDT

*** This bug has been marked as a duplicate of 136997 ***
Comment 3 Red Hat Bugzilla 2006-02-21 14:06:39 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.