Bug 136997 - Removal of USB CDRW causes kernel panic
Removal of USB CDRW causes kernel panic
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
i686 Linux
medium Severity high
: ---
: ---
Assigned To: Pete Zaitcev
:
: 137377 138732 (view as bug list)
Depends On:
Blocks: FC3Target 135876 FC4Target
  Show dependency treegraph
 
Reported: 2004-10-24 21:47 EDT by Antti Andreimann
Modified: 2007-11-30 17:10 EST (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-12-21 12:11:21 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Oops message (3.02 KB, text/plain)
2004-10-24 21:48 EDT, Antti Andreimann
no flags Details
Oops from system log (4.12 KB, text/plain)
2004-12-13 16:48 EST, Andre Robatino
no flags Details

  None (edit)
Description Antti Andreimann 2004-10-24 21:47:57 EDT
Description of problem:
Kernel panic when removing USB CDRW drive.

Version-Release number of selected component (if applicable):
kernel-2.6.9-1.640

How reproducible:
Always

Steps to Reproduce:
1. Plug in USB CD drive
2. Unplug USB CD drive

Actual Results:  Kernel OOPS. See attatchment.

Expected Results:  Safe removal.

Additional info:
Comment 1 Antti Andreimann 2004-10-24 21:48:50 EDT
Created attachment 105710 [details]
Oops message
Comment 2 Bill Nottingham 2004-10-25 17:42:36 EDT
Was it mounted at the time? (either manually, or by HAL)
Comment 3 Antti Andreimann 2004-10-25 21:31:22 EDT
No.
Comment 4 Bill Nottingham 2004-10-27 22:34:57 EDT
*** Bug 137377 has been marked as a duplicate of this bug. ***
Comment 5 Antti Andreimann 2004-11-04 19:37:57 EST
The same Oops with 2.6.10-rc1, seems to work fine with 2.6.10-rc1-bk14
(tried multiple plug in/outs in a row). However hal in FC3 doesn't
work with 2.6.10-rc1-bk14, it will not recognize USB devices :(
Comment 6 Bill Nottingham 2004-11-10 16:48:55 EST
*** Bug 138732 has been marked as a duplicate of this bug. ***
Comment 7 Jason Baron 2004-11-12 14:50:41 EST
*** Bug 138095 has been marked as a duplicate of this bug. ***
Comment 8 Greg Kroah-Hartman 2004-11-22 12:25:50 EST
Hm, scsi bug, not a usb-storage bug.
Comment 9 Jason Baron 2004-12-02 18:09:46 EST
Can you re-test this with the latest rhel4 kernel at: 

http://people.redhat.com/davej/kernels/RHEL4/RPMS.kernel/
Comment 14 Andre Robatino 2004-12-13 16:44:44 EST
  My father has almost the same problem, except that it seems to only
happen with the latest (681) kernel, and not 678 or earlier.  Also,
the Oops happens upon shutdown, not immediately upon removing the USB
device.  If the device is left attached until after shutdown, the Oops
doesn't happen.  Below is a system log attachment.  The device is
pulled at 14:07:31, and then the shutdown is started at 14:07:36, when
the Oops happens.  The machine hangs, and at 14:08:09 a Ctrl-Alt-Del
successfully reboots the machine (sometimes the machine is totally
hung and this doesn't work).  His machine is FC3 with all standard
updates applied.
Comment 15 Andre Robatino 2004-12-13 16:48:24 EST
Created attachment 108471 [details]
Oops from system log
Comment 16 Antti Andreimann 2004-12-18 20:16:00 EST
Still had issues with older releases, but the latest RHEL4 test kernel
(2.6.9-1.906_EL) works like a charm. Thank You davej! Running on it
right now.
Comment 17 Jay Turner 2004-12-21 12:11:21 EST
Closing out based on feedback from comment 16.

Note You need to log in before you can comment on or make changes to this bug.