Bug 1373933 - object selection and edit freezes libreoffice for several seconds
Summary: object selection and edit freezes libreoffice for several seconds
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: libreoffice
Version: 25
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Caolan McNamara
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: AcceptedBlocker
Keywords:
: 1373809 (view as bug list)
Depends On:
Blocks: WaylandRelated F25FinalBlocker
TreeView+ depends on / blocked
 
Reported: 2016-09-07 13:05 UTC by Kamil Páral
Modified: 2016-12-29 23:00 UTC (History)
14 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2016-09-27 00:33:20 UTC


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Debian BTS 837356 None None None 2016-09-16 08:58 UTC
Red Hat Bugzilla 1373809 None None None Never

Internal Trackers: 1373809

Description Kamil Páral 2016-09-07 13:05:29 UTC
Description of problem:
This problem seems to affect all libreoffice apps, but is mostly visible in Impress and Draw. Any time you select an object (a shape, a block of text, etc), the app freezes for several seconds, using 100% CPU. If you want to edit the object (a block of text), again the app freezes for a few seconds, and then the selection is changed to an edit cursor and you can finally type text.

With this slow speed, Impress and Draw are completely unusable for any serious work (try it).

Tested on several computers, both bare metal and VMs. (Please note that in VMs libreoffice frequently crashes with bug 1373372, which is unrelated.)

Version-Release number of selected component (if applicable):
clutter-1.26.0-1.fc25.x86_64
clutter-gst2-2.0.18-1.fc25.x86_64
clutter-gst3-3.0.18-1.fc25.x86_64
clutter-gtk-1.8.0-2.fc25.x86_64
cogl-1.22.2-1.fc25.x86_64
gtk3-3.21.4-2.fc25.x86_64
libreoffice-calc-5.2.1.2-1.fc25.x86_64
libreoffice-core-5.2.1.2-1.fc25.x86_64
libreoffice-data-5.2.1.2-1.fc25.noarch
libreoffice-draw-5.2.1.2-1.fc25.x86_64
libreoffice-emailmerge-5.2.1.2-1.fc25.x86_64
libreoffice-filters-5.2.1.2-1.fc25.x86_64
libreoffice-graphicfilter-5.2.1.2-1.fc25.x86_64
libreoffice-gtk2-5.2.1.2-1.fc25.x86_64
libreoffice-gtk3-5.2.1.2-1.fc25.x86_64
libreoffice-impress-5.2.1.2-1.fc25.x86_64
libreoffice-langpack-cs-5.2.1.2-1.fc25.x86_64
libreoffice-langpack-en-5.2.1.2-1.fc25.x86_64
libreoffice-math-5.2.1.2-1.fc25.x86_64
libreoffice-ogltrans-5.2.1.2-1.fc25.x86_64
libreoffice-opensymbol-fonts-5.2.1.2-1.fc25.noarch
libreoffice-pdfimport-5.2.1.2-1.fc25.x86_64
libreoffice-pyuno-5.2.1.2-1.fc25.x86_64
libreoffice-ure-5.2.1.2-1.fc25.x86_64
libreoffice-writer-5.2.1.2-1.fc25.x86_64
libreoffice-x11-5.2.1.2-1.fc25.x86_64
libreoffice-xsltfilter-5.2.1.2-1.fc25.x86_64
mesa-dri-drivers-12.0.2-1.fc25.x86_64
mutter-3.21.90-3.fc25.x86_64

How reproducible:
always

Steps to Reproduce:
1. run Impress (or Draw)
2. click on text areas to enter text (title, body)
3. draw a shape (a circle, a star)
4. switch selection between different objects (text areas, shapes)

Actual results:
object selection is extremely slow

Expected results:
should be fast

Additional info:
This doesn't seem to be wayland related. It's slow as well on X11.

Comment 1 Kamil Páral 2016-09-07 13:07:29 UTC
Proposing as a blocker:
"All applications that can be launched using the standard graphical mechanism of a release-blocking desktop after a default installation of that desktop must start successfully and withstand a basic functionality test. "
https://fedoraproject.org/wiki/Fedora_25_Final_Release_Criteria#Default_application_functionality

Currently it's not really possible to work normally in Impress or Draw. It's unbearably slow.

Comment 2 Adam Williamson 2016-09-12 18:04:55 UTC
confirming, I see this on my regular F25 desktop (with X11). sometimes I can't even get the selection to trigger at all, but it clearly renders Impress effectively unusable.

Comment 3 Geoffrey Marr 2016-09-13 02:18:19 UTC
Discussed during the 2016-09-12 blocker review meeting: [1]

The decision to classify this as an AcceptedBlocker was made as this constitutes a violation of "All applications that can be launched using the standard graphical mechanism of a release-blocking desktop after a default installation of that desktop must start successfully and withstand a basic functionality test", as it's impossible to do basic work in Impress or Draw applications.

[1] https://meetbot.fedoraproject.org/fedora-blocker-review/2016-09-12/f25-blocker-review.2016-09-12-16.01.txt

Comment 4 Caolan McNamara 2016-09-15 16:09:29 UTC
If you have both libreoffice-gtk2 and libreoffice-gtk3 installed, does it make a difference to use

export SAL_USE_VCLPLUGIN=gtk
before launching e.g. 
libreoffice --writer

Comment 5 Kamil Páral 2016-09-16 07:06:22 UTC
(In reply to Caolan McNamara from comment #4)
> export SAL_USE_VCLPLUGIN=gtk
> before launching e.g. 
> libreoffice --writer

Yes, the problems are gone and object selection is now immediate.

Comment 6 Caolan McNamara 2016-09-16 08:02:50 UTC
If I selectively upgrade gtk3 on a F24 box I appear to see this too so looks like a change in gtk3 has triggered it.

I see an icon flying around on the clicks, so that would indicate drag and drop is active.

Comment 7 Caolan McNamara 2016-09-16 10:09:24 UTC
Things went wrong for us with gtk3 change of

commit 0f116135f4a5033ce4e9dfa19f10624701fa615c
Author: Matthias Clasen <mclasen@redhat.com>
Date:   Fri May 6 10:12:14 2016 -0400

    Avoid emitting ::style-set by name
    
    GtkStyle is deprecated, but we still emit ::style-set quite
    a bit, so lets at least not be slow while doing it.

Comment 8 Kamil Páral 2016-09-16 11:39:21 UTC
In the mean time, I found that if I use gtk3-3.21.1-1.fc25 on F24, everything works OK, but if I use gtk3-3.21.4-1.fc25, Impress becomes slow and lagging. Probably too late, though, you've already found the exact commit.

Comment 9 Fedora Update System 2016-09-18 19:58:39 UTC
libreoffice-5.2.2.1-2.fc25 has been submitted as an update to Fedora 25. https://bodhi.fedoraproject.org/updates/FEDORA-2016-6d6718e947

Comment 10 Caolan McNamara 2016-09-19 08:46:22 UTC
Yeah, the issue can be reproduced on F24 by using the F25 gtk3. There's a load of these style-set signals. I changed over to style-updated and there is less of them, but still a surprising amount of those too so I've a follow up commit to do less work on style-updated

Comment 11 Kamil Páral 2016-09-19 12:09:26 UTC
(In reply to Fedora Update System from comment #9)
> libreoffice-5.2.2.1-2.fc25 has been submitted as an update to Fedora 25.
> https://bodhi.fedoraproject.org/updates/FEDORA-2016-6d6718e947

This build fixes the slowness issue for me.

Comment 12 Kamil Páral 2016-09-19 12:38:13 UTC
*** Bug 1373809 has been marked as a duplicate of this bug. ***

Comment 13 Fedora Update System 2016-09-20 20:00:01 UTC
libreoffice-5.2.2.1-2.fc25 has been pushed to the Fedora 25 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-6d6718e947

Comment 14 Fedora Update System 2016-09-22 09:56:08 UTC
libreoffice-5.2.2.1-4.fc25 has been pushed to the Fedora 25 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-d959f4b5ec

Comment 15 Fedora Update System 2016-09-23 05:24:50 UTC
libreoffice-5.2.2.1-5.fc25 has been pushed to the Fedora 25 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-aa4fa71f75

Comment 16 Fedora Update System 2016-09-27 00:33:20 UTC
libreoffice-5.2.2.1-5.fc25 has been pushed to the Fedora 25 stable repository. If problems still persist, please make note of it in this bug report.

Comment 17 Paulo 2016-10-13 11:30:30 UTC
Not sure if this is the right place for this comment.

On 64 bit Arch Linux, updating Gnome to 3.22 (which is on Wayland by default) brought this LibreOffice bug back.
Plus the running app's icon does not show.
The current version is stated as 5.2.2.1, last updated on 2016-10-01 08:32 UTC.

Starting Gnome on X instead of Wayland doesn't help.
But the fix from comment #4 works and brings the icon back.

Comment 18 Kamil Páral 2016-10-13 13:13:55 UTC
Paulo, I guess this got fixed just locally in Fedora package for the moment, judging by maintainers just bumping the release part of the package NVR. You'll probably need to wait until an upstream fix is available or ask for a local patch in Arch as well. You can see the git for the Fedora package here:
http://pkgs.fedoraproject.org/cgit/rpms/libreoffice.git/log/?h=f25

Comment 19 Paulo 2016-10-13 13:55:31 UTC
Thanks Kamil,
I duplicated this bug in Arch and LibreOffice bug trackers.


Note You need to log in before you can comment on or make changes to this bug.